Random black blinks with Nvidia drivers

Hello, I am using Fedora 37, and from time to time, the top half of my monitor blinks black. It’s hard to describe; sometimes half or 1/4 of my screen just goes black for a very very short time. I tried to troubleshoot this issue, but the blinking seems to be totally random. However, they seem to appear more frequently after a reboot. I don’t have any idea what might be causing them.
Driver version 530.41.03
NVML Version: 12.530.41.03
Kernel: 6.2.9-200.fc37.x86_64
CPU: AMD Ryzen 5 3600 (12) @ 3.600GHz
DE: GNOME 43.4
Inxi-G results:
Device-1: NVIDIA TU106 [GeForce RTX 2060 SUPER] driver: nvidia v: 530.41.03
Display: wayland server: X.Org v: 22.1.9 with: Xwayland v: 22.1.9
compositor: gnome-shell v: 43.4 driver: X: loaded: modesetting
unloaded: fbdev,vesa dri: nouveau gpu: nvidia,nvidia-nvswitch resolution:
1: 1920x1080~144Hz 2: 1920x1080~75Hz
API: OpenGL v4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce RTX 2060
I was using Linux Mint for most of my Linux journey; I am very new to Fedora. I really enjoy using this distribution and would love to get some help.

1 Like

I also have gained this issue right after updating my nvidia driver to 530.41.03 using Software, top half of my screen (or sometimes the whole screen) goes black for a fraction of a second, blinks are random.
I don’t remember what my Nvidia driver version was before the update or how to revert back to it (if I did know).

Have either of you tried by chance the simple test of switching to xorg to see if this may be wayland related and not an issue with xorg?

Happens on both wayland and xorg

Exactly same issure here, i will try to reinstall drivers today.

I have successfully installed 525.105.17 version of the driver, following this tutorial How to Install Nvidia Drivers on Fedora | phoenixNAP KB. For now no blinking

It solved the issue

Which procedure of that tutorial did you use?
directly from nvidia.com?

The drivers from rpmfusion are already tweaked and pull in all needed dependencies plus they automatically update with each kernel or driver upgrade. The drivers from nvidia require manual updates.

Additionally, the drivers from rpmfusion are currently newer than the one you installed.

530.41.03 version was from rpmfusion, they didnt work. The working 525.105.17 version is directly from NVIDIA. I followed the manual option while installing them.