Screen starts blinking after first login

After first login to the f37 live environment or after setup on my computer with Nvidia GPU screen starts strange blinking and after setup fedora from live CD it’s also appears. I think that’s another bug with Nvidia+Wayland. So, can I fix it somehow.

Hi @jplie , welcome to the community!

I think the first thing to do would be to update your system to see if the issue has already been fixed. Could you update your system and reboot to check if the issue persists please?

Before we can note that this is a Nvidia + Wayland bug, it’ll be good to login to an X11 session to see if the bug persists.

1 Like

I’ve tried to login into x11 session and it works ok with it, except lock screen, it’s blinking anyway. And after installing Nvidia proprietary drivers, fedora works good now with Wayland, but nouveau sends a lot of error logs with Nvidia driver installed. Also after updating system on the nouveau desktop just don’t loading with x11 or Wayland session, booting from the old kernel in grub helped. So I think it’s nouveau issue now

1 Like

The live environment is unable to use nvidia. I assume you installed to the system then did a full update and installed the nvidia drivers. This would also require enabling the third party repos.
dnf upgrade
dnf install akmod-nvidia
Followed by a reboot.

If all the above were done does it still show the problems?
Please post the output of inxi -Fzxx and dnf list installed '*nvidia*' using the preformatted text button </> on the toolbar above so we can see those as you do on your screen.

If the nvidia drivers were installed as above nouveau should be giving no messages. Please also post what you are referring to as “nouveau error logs”.

After installing Nvidia drivers earlier all problems has gone. But now when I try to reinstall f38 I can’t install it because of screen blinking and installer that just doesn’t start. So where I should report it

I’d start a new topic to see if we can diagnose the error/issue and then report it to the right component.

1 Like

so what’s needed from me now? I’ve just can’t stay more on Ubuntu because of this problem

A new topic discussing your issues on the installer would be good I guess? We already seem to know the issue though—nouveau seems to have issues with your hardware, and one cannot use the nvidia binaries on the live image.

Do you have to reinstall F38? If you have a working F37 installation, upgrading that would be better here. Upgrades work great:

Fixes to the nouveau driver are made upstream and released, and will only then get to Fedora (and other distributions). So there’s no way to tell how long that’ll be. You could test out the “respins”—they contain newer packages, so if the bug you’re seeing has been fixed, it could be in them:

1 Like

I’ve tried f38 workstation respin and issue in the live iso was gone. Thanks for the information, I don’t know about respins earlier and my problem was already fixed.

1 Like