External monitor flickering after connecting Bluetooth device in GNOME 45

I had decided to wait for a while before updating from Fedora 38 to 39 to make sure things would be a bit more polished by the time I decided to finally update, but unfortunately my external monitor just keeps flickering to black, something that for sure did not happen before. Upon some trial and error, rebuilding the Nvidia kernel modules seemed to solve the issue, but every time I do that the problem keeps coming back for some reason. The monitor doesn’t appear to be disconnecting since it’s always detected in the settings menu. The few times I thought the problem was fixed it came right back after I connected my Bluetooth headphones to the computer. I also am running a laptop with an Intel iGPU and an Nvidia RTX 2060 dGPU.

Here is my output for inxi -Fzxx:

System:
  Kernel: 6.6.8-200.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.40-13.fc39 Desktop: GNOME v: 45.2 tk: GTK v: 3.24.39 wm: gnome-shell
    dm: GDM Distro: Fedora release 39 (Thirty Nine)
Machine:
  Type: Laptop System: Acer product: Predator PH317-54 v: V1.04
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: CML model: Vellfire_CMS v: V1.04 serial: <superuser required>
    UEFI: Insyde v: 1.04 date: 07/16/2020
Battery:
  ID-1: BAT0 charge: 44.9 Wh (100.0%) condition: 44.9/58.8 Wh (76.4%)
    volts: 15.9 min: 15.4 model: SMP KT00407009 AP18E7M serial: <filter>
    status: full
CPU:
  Info: 6-core model: Intel Core i7-10750H bits: 64 type: MT MCP
    arch: Comet Lake rev: 2 cache: L1: 384 KiB L2: 1.5 MiB L3: 12 MiB
  Speed (MHz): avg: 2758 high: 4900 min/max: 800/5000 cores: 1: 4900 2: 800
    3: 800 4: 4116 5: 4800 6: 800 7: 800 8: 4889 9: 800 10: 4799 11: 800
    12: 4801 bogomips: 62399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Acer Incorporated ALI
    driver: i915 v: kernel arch: Gen-9.5 ports: active: eDP-1 empty: DP-1,
    DP-2, DP-3, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:9bc4
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile]
    vendor: Acer Incorporated ALI driver: nvidia v: 545.29.06 arch: Turing pcie:
    speed: 2.5 GT/s lanes: 16 ports: active: none off: HDMI-A-3 empty: DP-4
    bus-ID: 01:00.0 chip-ID: 10de:1f15
  Device-3: Quanta [] driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 bus-ID: 1-7:4 chip-ID: 0408:a061
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 23.2.3
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    unloaded: fbdev,nouveau,vesa alternate: nv dri: iris
    gpu: i915,nvidia,nvidia-nvswitch display-ID: 0
  Monitor-1: HDMI-A-3 model: LG (GoldStar) W2241 res: 1680x1050 dpi: 87
    diag: 585mm (23")
  Monitor-2: eDP-1 model: ChiMei InnoLux 0x175c res: 1920x1080 dpi: 128
    diag: 437mm (17.2")
  API: OpenGL v: 4.6 vendor: intel mesa v: 23.3.1 glx-v: 1.4 es-v: 3.2
    direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
    device-ID: 8086:9bc4 display-ID: :0.0
  API: Vulkan v: 1.3.268 surfaces: xcb,xlib,wayland device: 0
    type: integrated-gpu driver: mesa intel device-ID: 8086:9bc4 device: 1
    type: discrete-gpu driver: nvidia device-ID: 10de:1f15 device: 2 type: cpu
    driver: mesa llvmpipe device-ID: 10005:0000
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: Intel Comet Lake PCH cAVS vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:06c8
  Device-2: NVIDIA TU106 High Definition Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f9
  API: ALSA v: k6.6.8-200.fc39.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:06f0
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: alx v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 07:00.0 chip-ID: 1969:e0b1
  IF: enp7s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 1-14:5 chip-ID: 8087:0026
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 5.2
    lmp-v: 11
Drives:
  Local Storage: total: 476.94 GiB used: 387.27 GiB (81.2%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN730
    SDBQNTY-512G-1014 size: 476.94 GiB speed: 31.6 Gb/s lanes: 4
    serial: <filter> temp: 36.9 C
Partition:
  ID-1: / size: 475.35 GiB used: 386.96 GiB (81.4%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 305.9 MiB (31.4%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 475.35 GiB used: 386.96 GiB (81.4%) fs: btrfs
    dev: /dev/nvme0n1p3
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 40.0 C pch: 33.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 448 Uptime: 12m Memory: total: 16 GiB available: 15.45 GiB
  used: 3.62 GiB (23.4%) Init: systemd v: 254 target: graphical (5)
  default: graphical Compilers: gcc: 13.2.1 Packages: pm: rpm pkgs: N/A
  note: see --rpm pm: flatpak pkgs: 69 Shell: Zsh v: 5.9
  running-in: terminator inxi: 3.3.31

I have looked everywhere and the only thing I managed to find was this post, however the GPU mentioned was AMD and the solutions didn’t work for me. Thank you for your time in advance.

According to your inxi output and the above you seem to be using the intel GPU with wayland.

Why that would be causing the flickering seems strange to me.

However, there is more troubleshooting to be done.
Please show us the output of dnf list installed \*nvidia\* and lsmod | grep nvidia, and modinfo nvidia

It also is much easier to read if you post the info as preformatted text with the </> button on the toolbar or enclose it with triple backquotes [ ``` ] on the lines preceding and following the text. As the name implies that retains the on-screen formatting you see.

I am curious – what seems the primary monitor is the external LG (Goldstar) with 1680x1050 resolution and the internal screen seems to be 1920x1080. Is that correct or am I reading it wrong?

Please post the output of xrandr so we can see the available resolutions for each monitor.

I apologize for the late reply. The different resolutions on both monitors had never been an issue up until now and this specific problem only started after updating to Fedora 39. Here are the outputs of the commands asked:

For dnf list installed \*nvidia\*:

akmod-nvidia.x86_64                      3:545.29.06-2.fc39 @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.6.8-200.fc39.x86_64.x86_64 3:545.29.06-2.fc39 @@commandline       
nvidia-gpu-firmware.noarch               20231211-1.fc39    @updates            
nvidia-modprobe.x86_64                   3:545.29.06-1.fc39 @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                   3:545.29.06-1.fc39 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64               3:545.29.06-2.fc39 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64     3:545.29.06-2.fc39 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64       3:545.29.06-2.fc39 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.i686            3:545.29.06-2.fc39 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64          3:545.29.06-2.fc39 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64         3:545.29.06-2.fc39 @rpmfusion-nonfree-nvidia-driver

For lsmod | grep nvidia:

nvidia_drm            118784  4
nvidia_modeset       1585152  2 nvidia_drm
nvidia_uvm           3522560  0
nvidia              62394368  38 nvidia_uvm,nvidia_modeset
i2c_nvidia_gpu         12288  0
video                  77824  3 acer_wmi,i915,nvidia_modeset

For modinfo nvidia:

filename:       /lib/modules/6.6.8-200.fc39.x86_64/extra/nvidia/nvidia.ko.xz
alias:          char-major-195-*
version:        545.29.06
supported:      external
license:        NVIDIA
firmware:       nvidia/545.29.06/gsp_tu10x.bin
firmware:       nvidia/545.29.06/gsp_ga10x.bin
rhelversion:    9.99
srcversion:     8302209549E8FEAC029EDC0
alias:          pci:v000010DEd*sv*sd*bc06sc80i00*
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        
retpoline:      Y
name:           nvidia
vermagic:       6.6.8-200.fc39.x86_64 SMP preempt mod_unload 
sig_id:         PKCS#7
signer:         fedora-107958837
sig_key:        31:B5:EE:B8:46:32:1E:5A:1D:A8:89:EA:6F:02:89:27:75:45:0E:8A
sig_hashalgo:   sha256
signature:      3B:97:45:4A:7E:7E:EA:AE:C0:52:68:8F:26:FC:AE:71:25:5E:25:23:
		C3:C9:1E:9F:A0:7D:94:FD:21:A3:CA:47:31:D3:D3:63:CD:FD:F5:EA:
		00:D5:FC:80:D1:10:53:F7:20:2C:64:F4:E2:1E:FA:82:8D:4E:80:84:
		A3:75:FF:5B:5C:C5:27:B3:48:0F:38:C5:68:18:28:3C:D6:75:00:8C:
		10:53:F9:7E:F0:32:BA:10:4D:4F:18:75:56:74:E4:22:C1:F1:E0:9A:
		CE:24:21:1D:49:CF:70:2F:ED:2B:FF:B2:F7:FF:54:15:92:A8:1C:FF:
		8E:5A:B4:11:7C:21:0D:EC:7C:8A:7F:3B:73:65:5F:9D:BB:C4:0F:55:
		AE:7D:DE:58:A7:13:47:C7:83:6E:75:FC:7D:34:7C:C6:6A:16:8C:4C:
		59:FC:C4:DB:3B:39:6F:82:8C:C9:46:5F:0F:79:46:F4:CF:E8:63:79:
		E7:F8:2A:0E:92:51:6E:97:9E:1B:92:DB:BB:07:5E:F5:F6:AF:F7:E9:
		1F:85:32:C5:B0:C3:C3:6F:53:85:11:C6:B1:40:F4:77:F9:BD:B1:46:
		39:0C:EC:BA:AE:E7:65:D4:F4:BF:8E:5D:80:76:47:CF:4B:D6:73:1A:
		25:60:46:11:E0:28:63:74:F6:3C:77:8B:DB:B3:20:1A:87:2B:4C:E1:
		BB:8B:69:4B:0B:67:51:BE:FE:AA:47:D5:B6:9A:57:3B:7F:3B:21:D4:
		F7:0A:3B:90:B4:3D:BA:CA:DD:9C:A4:FB:C4:FB:6F:DB:AE:7F:60:1D:
		8C:DA:25:A7:3E:34:E5:97:6A:10:D4:49:BF:68:35:AC:C6:61:BB:18:
		5F:69:D6:A5:92:1D:15:CE:82:5F:B1:07:C7:13:D8:9A:89:06:27:A5:
		58:78:39:C4:69:EF:59:6D:A4:6D:14:84:AA:5E:D7:DA:32:FC:12:6F:
		FC:3A:1E:0E:16:96:3F:69:B7:DE:CD:27:BB:D8:4F:0F:1E:8F:46:91:
		53:30:93:E2:0E:57:2E:2C:86:78:1C:EF:A5:23:AB:02:C6:67:7C:19:
		45:C8:5E:CB:09:52:13:81:CF:7F:E8:2D:A0:8F:39:76:EF:4D:9D:E6:
		CA:0F:13:4B:D3:07:DD:D2:67:0C:6C:5C:3A:FF:33:F2:71:1A:62:C1:
		A2:79:75:F8:78:93:28:9E:12:E2:58:63:59:EF:5A:83:3B:FF:56:8D:
		46:91:4C:B1:4A:30:87:4A:33:48:93:E1:AC:70:D9:A5:7C:1C:A6:8D:
		B9:7A:C0:0B:94:8A:16:04:E1:75:D7:C8:B9:E6:75:3D:5E:44:B8:50:
		23:C4:05:D8:59:96:CA:1E:81:A7:98:A1
parm:           NvSwitchRegDwords:NvSwitch regkey (charp)
parm:           NvSwitchBlacklist:NvSwitchBlacklist=uuid[,uuid...] (charp)
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_InitializeSystemMemoryAllocations:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_EnablePCIeGen3:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_TCEBypassMode:int
parm:           NVreg_EnableStreamMemOPs:int
parm:           NVreg_RestrictProfilingToAdminUsers:int
parm:           NVreg_PreserveVideoMemoryAllocations:int
parm:           NVreg_EnableS0ixPowerManagement:int
parm:           NVreg_S0ixPowerManagementVideoMemoryThreshold:int
parm:           NVreg_DynamicPowerManagement:int
parm:           NVreg_DynamicPowerManagementVideoMemoryThreshold:int
parm:           NVreg_EnableGpuFirmware:int
parm:           NVreg_EnableGpuFirmwareLogs:int
parm:           NVreg_OpenRmEnableUnsupportedGpus:int
parm:           NVreg_EnableUserNUMAManagement:int
parm:           NVreg_MemoryPoolSize:int
parm:           NVreg_KMallocHeapMaxSize:int
parm:           NVreg_VMallocHeapMaxSize:int
parm:           NVreg_IgnoreMMIOCheck:int
parm:           NVreg_NvLinkDisable:int
parm:           NVreg_EnablePCIERelaxedOrderingMode:int
parm:           NVreg_RegisterPCIDriver:int
parm:           NVreg_EnableResizableBar:int
parm:           NVreg_EnableDbgBreakpoint:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_RegistryDwordsPerDevice:charp
parm:           NVreg_RmMsg:charp
parm:           NVreg_GpuBlacklist:charp
parm:           NVreg_TemporaryFilePath:charp
parm:           NVreg_ExcludedGpus:charp
parm:           NVreg_DmaRemapPeerMmio:int
parm:           NVreg_RmNvlinkBandwidth:charp
parm:           rm_firmware_active:charp

And finally for xrandr:

Screen 0: minimum 16 x 16, current 3600 x 1080, maximum 32767 x 32767
HDMI-3 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 490mm x 320mm
   1680x1050     59.85*+
   1400x1050     59.86  
   1280x1024     59.81  
   1280x960      59.79  
   1152x864      59.78  
   1024x768      59.68  
   800x600       59.47  
   640x480       59.38  
   320x240       59.52  
   1440x900      59.75  
   1280x800      59.81  
   1152x720      59.75  
   960x600       59.63  
   928x580       59.53  
   800x500       59.50  
   768x480       59.38  
   720x480       59.71  
   640x400       59.20  
   320x200       58.96  
   1600x900      59.82  
   1368x768      59.71  
   1280x720      59.65  
   1024x576      59.58  
   864x486       59.45  
   720x400       59.55  
   640x350       58.91  
eDP-1 connected primary 1920x1080+1680+0 (normal left inverted right x axis y axis) 380mm x 210mm
   1920x1080    143.88*+
   1440x1080    143.80  
   1400x1050    143.89  
   1280x1024    143.79  
   1280x960     143.86  
   1152x864     143.92  
   1024x768     143.87  
   800x600      143.83  
   640x480      143.85  
   320x240      142.05  
   1680x1050    143.88  
   1440x900     143.86  
   1280x800     143.84  
   1152x720     143.77  
   960x600      143.72  
   928x580      143.50  
   800x500      143.68  
   768x480      143.69  
   720x480      143.85  
   640x400      143.37  
   320x200      141.40  
   1600x900     143.93  
   1368x768     143.77  
   1280x720     143.85  
   1024x576     143.91  
   864x486      143.63  
   720x400      143.88  
   640x350      143.57

I have also corrected the formatting errors mentioned on the original post.

Quick update: I have found a very weird temporary fix. I use the extension Dash to Panel in GNOME 45 and by allowing the panel to appear on both monitors the problem disappears unless I open something on full screen, which hides the panel that for some reason is preventing the problem from happening. I have tried to disable the extension to see if it could be the issue but having it disabled just made the problem appear yet again as no panel was present in my second monitor. I am truly at a loss as to what could be the issue here.