Fedora 35 beta - audio devices no longer detected

I have built-in speakers in my Philips monitor, connected via HDMI and a Logitech webcam/microphone via USB that have always “just worked”
On upgrading to the F35 beta, I see no audio devices detected.
I’m using KDE and my hardware profile is here: HW probe of Intel NUC10i7FNB K61360-30... by Intel Client Systems (NUC10i7FNK) #28ce3a6f8d

Does anyone have suggestions on how to scan for these devices and or an idea as to what the problem is?


And this same problem is present on my laptop with built-in speakers, microphone, and webcam: HW probe of Notebook N2x0WU #410a2dab96

I got this once, and turned out pipewire had crashed. Can you check if it’s running:

systemctl --user status pipewire

and maybe try restarting it to see if that helps?

systemctl --user restart pipewire

It’s a persistent condition across reboots for me and systemctl indicates that pipewire is running.
A restart of either the machine or pipewire does not help.

1 Like

We can mark this solved - wireplumber is dead and needs restarting, not pipewire:

$ systemctl --user restart wireplumber


Ah, so close XD