Audio issues under Fedora 35 with USB Audio Interface

I upgraded to Fedora 35 two days ago. At first, everything seemed to be working fine. But suddenly I had sound (and video) problems. Video was playing every 20 seconds one frame, audio not at all. After restarting everything seemed to be fine.

But at some point, not even rebooting solved the issue. So I tried systemctl --user enable --now wireplumber.

This solved the issue at first but not for long. Anyway, I did a lot of different things, like: sudo dnf swap wireplumber pipewire-media-session or installing pipewire-pulse and running it.

Currently it looks like this:
pactl list short sinks returns this (I need 45, but the numbers keep changing):

35	alsa_output.pci-0000_0b_00.1.hdmi-stereo	PipeWire	s16le 2ch 48000Hz	SUSPENDED
45	alsa_output.usb-Focusrite_Scarlett_6i6_USB_00052950-00.analog-surround-21	PipeWire	s32le 3ch 48000Hz	SUSPENDED
47	alsa_output.pci-0000_0d_00.3.iec958-stereo	PipeWire	s16le 2ch 48000Hz	SUSPENDED

Number 35 works when selecting it with pactl set-default-sink 35, but 45 does not. And furthermore, my audio interface, a Focusrite Scarlett 6i6, doesn’t even register mic input (it normally does, I can see the input light lighting up when I talk on the interface, even when connected to no computer at all).

It seems to be something wrong with it, but in Windows everything is still okay, and a with Fedora 34 and even a yesterday it worked fine with Fedora 35 for some time.

I have no idea what low level media server I have installed now, what I changed and what I didn’t change, so I’m glad to provide further details.

I would love to go back to the audio setup with Fedora 34, but I’m unable to make a clean uninstall of all current audio drivers or media servers etc and I don’t even know how Fedora 34 worked with audio. Even after reading the arch linux wiki entry for pulseaudio, alsamixer, pact and pipewire I still have no idea on how they are related and what they do.

Please read the changelog for F34 and F35. There it explains what has been made since F34. With links to the wiki to undo if you like.
Releases/34/ChangeSet - Fedora Project Wiki
Releases/35/ChangeSet - Fedora Project Wiki

But there are also Kernel problems who could cause the USB problem.
Do you have older Kernel entries in the grub boot menu to test?

Pipewire substitutes Pulsaudio. But most of pulsaudio things are still working with the pipewire.pulsaudio plugin.

More detailed see:

When I run pactl info I currently get Server Name: PulseAudio (on PireWire 0.3.39). Am I using the pirewire.pulsaudio plugin?

Furthermore, even when booting with grub to an old kernel, my audio interface dies on startup, weird. Audio seems to work normally atm, just switching to the USB Interface results in no audio.

When running wireplumber, audio stops working.

Is dnf swap wireplumber pipewire-media-session a good idea?

Yes … see here how you can check if everything works fine (all the services):

We better fix the real problem … let’s see … check in /etc if you have a folder name /etc/pipewire?

If yes delete it if you use the default settings. The /etc/pipewirenot should be there. The default is in /usr/share/pip-wire. let this been untouched.

Then try to restart wireplumber.

There was no folder named /etc/pipewire. wireplumber is enabled and running, pipewire.* and pipewire-pulse.* result in no matches found: pipewire(...)

(Currently I get audio btw, but not via the USB Audio Interface)

Don’t forget --user
systemctl --user status pipewire.*

Yes of course, I did that.

Copied from terminal:

> systemctl --user status pipewire-pulse.*
zsh: no matches found: pipewire-pulse.*
> systemctl --user status pipewire.*
zsh: no matches found: pipewire.*

You need to quote those so that zsh doesn’t try to expand the *.

1 Like

Oh thanks

> systemctl --user status "pipewire-pulse.*"
● pipewire-pulse.socket - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.socket; enabled; vendor preset: enabled)
     Active: active (running) since Fri 2021-11-05 08:16:52 CET; 3h 1min ago
   Triggers: ● pipewire-pulse.service
     Listen: /run/user/1000/pulse/native (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire-pulse.socket

Nov 05 08:16:52 fedora systemd[2012]: Listening on PipeWire PulseAudio.

● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; disabled; vendor preset: disabled)
     Active: active (running) since Fri 2021-11-05 08:16:53 CET; 3h 1min ago
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 2474 (pipewire-pulse)
      Tasks: 2 (limit: 19052)
     Memory: 23.3M
        CPU: 1min 34.770s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-pulse.service
             └─2474 /usr/bin/pipewire-pulse

Nov 05 08:16:53 fedora systemd[2012]: Started PipeWire PulseAudio.


> systemctl --user status "pipewire.*"
● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/user/pipewire.service.d
     Active: active (running) since Fri 2021-11-05 08:16:53 CET; 3h 22min ago
TriggeredBy: ● pipewire.socket
   Main PID: 2472 (pipewire)
      Tasks: 2 (limit: 19052)
     Memory: 9.4M
        CPU: 40.828s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─2472 /usr/bin/pipewire

Nov 05 08:16:53 fedora systemd[2012]: Started PipeWire Multimedia Service.

● pipewire.socket - Multimedia System
     Loaded: loaded (/usr/lib/systemd/user/pipewire.socket; enabled; vendor preset: enabled)
     Active: active (running) since Fri 2021-11-05 08:16:52 CET; 3h 22min ago
   Triggers: ● pipewire.service
     Listen: /run/user/1000/pipewire-0 (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire.socket

Nov 05 08:16:52 fedora systemd[2012]: Listening on Multimedia System.

I’ve updated to fedora 35 yesterday, and very impress I don’t have any issue after upgreade including my audio laptop and my usb audio usually I used to listening my favorit song in laptop. No need further configuration. pipewire works perfectly and flawlessly as in Fedora 34.

Nice to hear, but mine doesn’t. Any idea why this could be? And as I said, it did work at first, but always stopped working after a couple of hours.

1 Like

Are you using the original power supply? Is the USB Cable not a too long one?

And by the way, compatibility with Linux is not 100% out of the box.

Yes, everything is original. And again, everything still works with Windows (same PC, same cables etc). I think I have screwed something up with my audio or usb setup in fedora. I mean, it worked for years and now the interface seems to crash instantly on boot up or when I connect it to the running PC.

Could you solve your problem under Fedora Linux 35?
If yes a solution would be great also for others.