Fedora 34: Install NVIDIA Control Panel to be able to switch GPU

I have enabled 3rd party drivers but the NVIDIA app I can download from Software doesn’t allow me to Switch from Auto, NVIDIA or Intel GPU, it only has some settings for apps, what is the correct process to install the NVIDIA Control Panel to be able to switch between the 2 GPUs, thanks

The nvidia control panel does not control that. I think you are meaning nvidia-settings which gives the menu item “nvida server settings” but it does not select which apps use the card by default.

Use of the nvidia card is selected from the gnome menu when you right click on the icon and select “use discrete gpu”

You also have to be using the xorg display since wayland and nvidia do not play in the same sandbox at present. Use of xorg can be selected at login by the gear in the lower right corner of the login screen.

@computersavvy I’m also interested in this point. I’m trying to install Nvidia driver from rpm-fusion on a Thinkpad t580 with comes with UHD Intel 620 and an Nvidia mx150 GPU.
From what I know, Nvidia driver supports XWayland. I’m a bit confused about this.
I suppose that:
1 .The non native Wayland application should use the discrete GPU also in a Wayland session (right clicking in gnome…)
2. Applications that natively support Wayland won’t be able to use the discrete GPU in a Wayland session.
Am I wrong? I do not actually need the discrete GPU but I really like to get everything working under Linux, you know, as a personal challenge. Could you explain please?
Many thanks for your time.

You probably have seen the same as I have on xwayland and nvidia with the updates. I cannot provide any more details about wayland and nvidia since I have not tried it with this laptop. I may experiment a little with wayland once Fedora 35 is officially released as beta in a few weeks.

I have been using my nvidia GPU as primary with xorg since I got the laptop.
It has

Intel CoffeeLake-H GT2 [UHD Graphics 630]
NVIDIA TU116M [GeForce GTX 1660 Ti Mobile]

GPUs and I have the nvidia set to primary by using a file /etc/X11/xorg.conf.d/nvidia.conf with contents here.

$ cat /etc/X11/xorg.conf.d/nvidia.conf 
#This file is provided by xorg-x11-drv-nvidia
#Do not edit

Section "OutputClass"
	Identifier "nvidia"
	MatchDriver "nvidia-drm"
	Driver "nvidia"
	Option "AllowEmptyInitialConfiguration"
	Option "SLI" "Auto"
	Option "BaseMosaic" "on"
	Option "Primary" "yes"

Section "ServerLayout"
	Identifier "layout"
	Option "AllowNVIDIAGPUScreens"
	Option "Primary" "yes"

I added the Option "Primary" "yes" lines according to info I found a long time ago at (I think) the rpmfusion site.
That file is from a template found at /usr/share/X11/xorg.conf.d/nvidia.conf with the lines mentioned being the only changes I made.

My laptop always just works with both the internal and external monitors, unlike some who have trouble that seems related to the (missing) content of that file on their systems

The PrimaryGPU option enforces the use of the dGPU (the Nvidia GPU) by default for rendering card. (and also enable the availability of external display when wired via the dGPU).

But it has a cost to consume more power and defeat the point of having Optimus at all.

Instead, one should use the render offload technique to run an application on the dGPU instead of the default.
Recent Gnome also has an option to control that on a menu.

I hope this helps.