Having trouble using EnvyControl on my Lenovo laptop

A bit about my situation

I am relatively new to Fedora (however not completely new to Linux) and i am currently trying to figure out how to set up my Fedora 36 installation to be my daily driver.
Everything is going relatively smoothly. However I am currently running into some trouble getting my system to actually utilize my dedicated NVIDIA GPU and not the integrated Intel GPU.

What i have tried

I initially looked up a solution and found this guide:

And i followed it and everything seemed to work, up until i rebooted my system after using EnvyControl to switch to my NVIDIA GPU. My system seemed to note have switched at all.

When i run the following command:

glxinfo | egrep "OpenGL vendor|OpenGL renderer"

I get:

OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) UHD Graphics 630 (CFL GT2)

And on top of this the NVIDIA x server application tells me that i have 0% GPU load.

I have tried searching the Ask Fedora forum to see if anyone has encountered this problem before me. The best match I can see is this:

And from what I can tell it never actually comes to a conclusion.

My machine specs

I am currently using a Lenovo Legion Y530-15ICH and the only upgrade i have done to it is that i have swapped out the SSD for a larger one.

What I need

I would very much appreciate any ways of making my current approach work. I am also open to any other possible solutions to the overarching problem of my system not utilizing my NVIDIA GPU.

Any help is welcome and appreciated.

If you want the nvidia GPU to always be used the instructions are here
and here

Be aware that this only works if you log in with xorg since it does not affect the wayland config.

There are two stanzas in the nvidia.conf file referenced and I made the alteration in both stanzas.

1 Like

I currently don’t have too much time. But i will see if that works.
Thank you :smile:

Oh my god. I just feel so stupid right now. Logging in with xorg fixed everything. Thank you so much.