Fedora 32 Samsung Printer Loop


I have a Samsung ML-2525w laser Printer it’s connected by Ethernet.

I downloaded Samsung UnifiedLinuxDriver_1.0.0.tar.gz and installed via text

sudo ./install.sh

Then I went to settings printer and added the printer it went thru the motions but the test page did not print.

So I deleted the printer and rebooted. It ran thru some updates and then I added it back in and the test page works. I tested Librewriter and it works fine also.

But the log shows
[cups-driverd] Skipping “/usr/share/ppd/samsung”: loop detected!

This is the only way I can make the printer work. The builtin driver does not work.
Any advice, would be appreciated

running an ML-2850 connected vi USB, here.

you might try via web-IF of cups:


I installed no extra package. just fetched the driver cups offered.
I don’t know if this works for model too, but I mean I have seen drivers for ML-2525

1 Like


I reloaded from scratch using the stock lpx driver from the printer catalog.
The printer engine starts up but it never prints. The error is cups bidirectional postcript error. Also tried the lpx driver with cups administration

When I printed from cups web page it displayed a message “I had the wrong driver.”
This is the same postscript bi directional printing error So I reflected that there could be another driver that works from Samsung…


Ubuntu 23 I tested and the printer catalog showed a couple of Ml-2525w models. So I tested ML-2525 2.0 and that was the correct choice. However,with Fedora 32 the setup for Jetdirect is limited to 2 ML-2525w models and the stock lpx one is broken. Tested ML-2525w the driver from the Unified Package and it worked…

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.