Fedora 30 Display orientation flipped after upgrade

i know… but in my defense, i have not been able to find the answer elsewhere. and while there seems to be a few other discussions on this topic (both here and elsewhere) the answers are not such as i can instantly understand or implement them. (still fairly new to Linux and fedora in general) so heres what im running into.
HP EliteBook 8440p worked fine on fedora 29, screen rotation correctly sensed the orientation of the display and (while a bit sensitive) maintained the orientation until the display(entire laptop) was turned on its side or upside down. thought this was a neat feature and enjoyed the abilitiy to flip my laptop on its side to use the elongated display to work on documents.

After upgrading to Fedora 30 it appears that the system is mis reading the Accelarometer (?) and is flipping the display 180 deg. when in its normal use position (Landscape?) however when in the elongated (portrait?) position it is correctly orientated.

searching for solutions led me to Reddit - Dive into anything
where it was suggested to use the command line to perform this command ( dnf erase iio-sensor-proxy) this worked but after rebooting the system GNOME does not load and i was left with a strict command line interface with no option to use GUI apps.
after researching i was able to use the (dnf history undo ##) command to get the system back to its previous configuration. This included the display orientation issue. further research showed that it was Supposedly fixed upstream already, and that https://github.com/systemd/systemd/blob/master/hwdb/60-sensor.hwdb) Location on disk is `/usr/lib/udev/hwdb.d/60-sensor.hwdb could resolve the issue. (heres where my ignorance comes into play) i looked at the file but could not figure out how to implement it. continuing to search for other solutions i found that blacklisting (hp_accel) is another option. however i also have no idea how to do that either.

im beginning to run out of patience for an OS that, in its previous instance worked perfectly fine. ive been using fedora since fedora 26 and i know that there is some work that the users must do to make the OS work properly on individual systems. and im fine with that as long as it gives me a level of control that i would not normally have with other OS’s (namely MicroShaft) but this is the first time i haven’t been able to find a solution that could be easily implemented even with my lack of knowledge of the operating system. Most solutions i have come across will have detailed notes or step by step instructions. but this issue seems to defy convention. /Rant

Please… I just want to keep using my Laptop with Fedora 30. Its Screaming Fast and works well with what i want to do. but i cant allways have my laptop on its side.

1 Like

I had a similar problem with an Elitebook 850 G2 and upgrading to Fedora 31 just fixed it. Leaving this information here just in case someone coming from google needs it or in case you want to give it another try.

I also had the problem on my HP Probook 450 a couple of years ago with an earlier Fedora release running. I think the release version is not relevant. It is like when you turn your phone, the device senses the motion and re-orients the display accordingly.

Odd as this may sound, pick up the notebook PC and rotate it frontward and/or backward until the display orients itself, correctly. Then, in the Gnome controls at the top right of the screen, drop down the menu. At the very bottom, there are three icons. Click the middle one to make it show as a locked lock. Then, the screen orientation should remain locked, correctly.