Keyboard flip doesn't trigger "tablet" mode

As title says, I’m having issues with my HP ProBook x360 G5 EE running Fedora Workstation 40 on Gnome . Flipping the keyboard back doesn’t trigger any sensors. Frankly, I’m not sure where to start and what outputs to post here, because every single thing I tried from the internet didn’t worked. I should probably mention that switching session to X11 doesn’t work either.

What works: touch screen
What doesn’t work: automatic screen rotation

Any help is appreciated. Thanks in advance.

I’m having the same issues with Fedora 40 Gnome using Wayland of no detection of screen flip on my Dell Inspiron 14 2-in-1 7435.

What does monitor-sensor report?
Note that in Gnome the code to rotate the display has been removed. You need to install some add-on.

In my case monitor-sensor reports undefined

For me, it just says Waiting for iio-sensor-proxy to appear

Just to be on the safe side: iio-sensor-proxy is installed and running?
What does rpm -q iio-sensor-proxy and systemctl status iio-sensor-proxy.service say?

There is some ‘debugging’ information on iio-sensor-proxy project web page (Bastien Nocera / iio-sensor-proxy · GitLab).

Probably your sensor hardware is not fully supported/recognized by the kernel. Then I hope that someone else can jump in, as for me it worked out of the box (mine is an Acer Spin SP111-34N).


(I took some more notes for troubleshooting that I can share with you:

The first one says
iio-sensor-proxy-3.5-3.fc40.x86_64,
and the second one says
[a bullet] iio-sensor-proxy.service - IIO Sensor Proxy service Loaded: loaded (/usr/lib/systemd/system/iio-sensor-proxy.service; static) Drop in: /usr/lib/system/service.d 10-timeout-abort.conf Active: inactive (Dead)

Tried options=force_tablet_mode and both things I shared above were the same.