SW_TABLET_MODE on Yoga L13 undetected / switch manually

Hello folks,

I’ve got a Thinkpad L13 Yoga I installed Fedora 35 KDE Plasma. However, when I switch it to become a tablet, the SW_TABLET_MODE is not triggered. I looked at it using “libinput debug-events” and using “evtest”. The event code in evtest exists, but it is never triggered. Instead on a L390 Yoga everything works fine. So I have the following questions:

  1. does anyone else have a Thinkpad Yoga L13 and does it work there? I want to confirm this, because maybe the sensor is broken or it is just unsupported, yet. Or does anyone have an idea how I can confirm it is working or not? In 1 it seems to be supported, but I want to be sure when I sent it back to the vendor.

  2. As a workaround, I’d like to switch it manually. As far as I understood, the kernel emits a “SW_TABLET_MODE” event wich triggers all other functions. So can I somehow tell the kernel manually to emit this event? Or are there any other methods to change the mode manually? I have seen a solution for Arch 2, but it requires sysmoded (which I canot find for Fedora). I also tried to look how to code something, but the only things I found where the other way around.

Thank you very much for your help,


Hi there, I’m in a hurry here but just saying on my L13 Yoga the debug-events outputs:

-event13 SWITCH_TOGGLE +38.963s switch tablet-mode state 1
event13 SWITCH_TOGGLE +45.739s switch tablet-mode state 0

Okay, thank you very much! So 1) is closed and I think the sensor does not work and I can send it back.

Question still ist 2), would be useless when it works, but still interesting, even for Convertibles which are not supported in that way (should be generic not Thinkpad specific…).

Best Regards,


I would find it weird if the reason was this, but still regarding 1), FYI, my BIOS version is not stock, it is:

R1FET42W (1.16 )

Okay, where did you get this BIOS? I think it is worth a try.

Lenovo website. Will post detailed info later.

$ sudo dmidecode|grep "Product Name"
	Product Name: 20VKCABCDEF
	Product Name: 20VKCABCDEF

Go to https://pcsupport.lenovo.com/

Paste the model (example: 20VKCABCDEF), press ENTER,
Drivers & Software, BIOS & UEFI, " BIOS Update (Utility & Bootable CD) for Windows 11, 10 (64-bit) - ThinkPad L13 Gen 2, L13 Yoga Gen 2", choose BIOS Update (Bootable CD)
(you can dd it to a pen).

Okay, BIOS was also updated. It does not work. However, we tried MS Windows and it worked. I do not know why this does not work here. if anyone has an idea, please respond. In the meantime I’d consider this type of Thinkpad Yoga not to be compatible using Linux…

Can you check do you have ’ iio-sensor-proxy ’ package install and do you use plasma on wayland if yes try to run plasma on xorg (when you chose your user name and write down your password you will have option for desktop session ‘plasma on x11’ bottom left on screen–default is plasma on wayland it is dropdown option).Once you run ‘plasma on x11’ check it is working tablet mode


the package is installed and “monitor-sensors” also shows the rotation. But still it does not recognize the display has been swappend and the tablet mode is not triggered neither using wayland nor x11. The sensors for that i can see, but no sensor output.

As a workaround I was thinking of manually triggering the tablet mode, but i do not find how to do so. It seems a bit complicated how this works. I also do not understand how this script https://aur.archlinux.org/packages/tablet-mode will work and trying to get it running under fedora.

Best Regards

I have the same situation on my HP ENVY x360. This did not work for me but it might work on your system.


this does not work. I cannot see any switch event when using libinput. However, using Windows it workes. I assume there is no driver for this model?

On my other Thinkpad i can see
-event6 SWITCH_TOGGLE +5.266s switch tablet-mode state 1
event6 SWITCH_TOGGLE +12.476s switch tablet-mode state 0

This complete is missing on the Yoga L13 Gen2.

But it seems I cannot simulate this event either. So I still consider this as non working model.

Thanks a lot for giving me some hints, but I am giving it up regarding this model.