F40 When using fractional scaling KDE Plasma "launch feedback" bouncing icon leaves artifacts at bottom of screen


Choosing “Configure Display Settings” on KDE Plasma and choosing a “Scale” value that is not a multiple of 100%, followed by launching an application, results in “launch feedback” bouncing icon leaving artifacts at the very bottom of the screen. These artifacts stay there and do not go away; they stay animated as well and do not stop moving.


Integer rounding from fractional scaling is handled in an inconsistent way that sometimes results in the very bottom row of pixels being shown as black and other times results in colored pixels being drawn to the very bottom row.

Reproducing this error may require moving the cursor to the bottom of the screen while an application is launching and the “launch feedback” icon is bouncing around. Reproducing this error is easiest when the KDE Plasma toolbar is “floating” at the bottom of the screen; otherwise the toolbar may hide the artifacts by overwriting them.

See the following image taken after launching “Chrome” with a “scale” setting of 205% on a 3.5k laptop monitor and notice the artifacts below the Dolphin, Firefox, and Chrome icons:

Related Issues

Proposed common issue “Fractional scaling in Fedora 40 Workstation makes some applications blurry”


1.) Use only whole multiples of 100% for “Scale” slider within Display Settings (e.g. 100%, 200%, 300%, etc).

2.) System settings → Cursors → Configure Launch Feedback ; set “Cursor feedback” to “none.”

From Proposed Common Issues to Ask Fedora

This is either a problem with KDE Plasma, or the graphical drivers for your GPU. Try to file the bug into https://bugs.kde.org and see what the developers think. Thanks.

I can at least add that this is not a Fedora-specific issue.

I’ve experienced the same on openSUSE Tumbleweed.

Related to that, I’ve noticed that the screen indicator box (the one that says “Built-in Screen $RESOLUTION”) in the same settings window lights up when selecting certain scaling values and if it lights up then the artifacts that OP mentioned also appear.

Laptop with Intel i7-13700H CPU with integrated graphics
Wayland session
Plasma 6.0.4
Frameworks 6.1.0
Qt 6.7.0
Kernel 6.8.8

OpenSUSE addresses this by limiting the scale to increments of 6.25% (6.25%, 12.5%, 18.75%, 25%, etc). I’m using OpenSUSE Slowroll now and this bug doesn’t occur on there.

When you had this issue on Tumbleweed, were you limited to increments of 6.25%, or was it allowing any scale value whatsoever?

Well, it’s not “had”, it’s very much current. I’ve just recently installed TW KDE on my laptop (currently 20240509) and the bug is still there. Scaling can be changed in 5% increments.

Interesting. I’m using Slowroll. I installed from the 20240509 ISO image and I don’t have this bug anymore. I am limited to increments of 6.25%. I’ll bet this bug goes away when you use increments of 25% on yours (since you’re stuck at 5% increments).