F38 power profile can't switch out of "Power Saver" to balanced or performance with ui or cli

I am on a thinkpad 7840u and am permanently stuck in power saver mode regardless of bios settings, using the cli with gnome, or changing the associated /sys files. I’ve heard of this problem in kernel 6.1 but thought it was resolved since then. Tested on 6.4, 6.5 and F39 beta does not solve issue.

Can you paste the output of powerprofilesctl list ?

$ powerprofilesctl list
    Driver:     platform_profile
    Degraded:   no

    Driver:     platform_profile

* power-saver:
    Driver:     platform_profile

What happens when you powerprofilesctl set balanced or performance? Do you get any error messages?

Unfortunately no error messages. No matter how fast I powerprofilesctl get after setting to balanced or performance it always returns power-saver.

Hello @glome ,
I found powerprofiles daemon to be my problem. I uninstalled it and installed tuned and got better results. You may want to try tuned.

Hmm. I set to balanced and am getting 10W power consumption on average with web browser open doing nothing. On windows it’s ~3W.

Is that using tuned? I just suggested it since it is seemingly more configurable than the default. In my case it identified my desktop as a laptop for some unknown reason, and wouldn’t let me choose anything other than powersaver.

Oh, I just read an article from phoronix about how it’s something with the firmware that the manufacturer needs to figure out. Thanks.

That is absolutely possible. These modes are dependent on the system firmware.