Eye of GNOME from Fedora Registry doesn't open JPEG files

JPEG is supported by EOG but the version from Fedora Registry says: Could not load image ‘image_name’. Unrecognized file format.
I’m using Silverblue 31.

1 Like

I have the exact same problem!

Is it happening for all your JPEG images or a just a few you click on? Because I’m thinking the reason may be the JPEG file is corrupt. If the problem persists you can file a bug here. https://gitlab.gnome.org/GNOME/eog/issues/

It’s happening for all JPEG files.
They are not corrupt, the thumbnails are displayed normally in Nautilus.
I think the JPEG support is missing from the version in Fedora Registry.
For example, this image from Ars Technica is not displayed in Eye of GNOME.

I have the same issue with the caveat that it also does not work with gifs for me, if I install the flathub version of eog I can view all my images

Indeed, also GIFs (and maybe other formats) are not being displayed.

Hi! I cannot confirm. To be honest, I only checked it with one JPG-image but it opened and displayed without problems. How did you install eog?

edit: I installed it via a toolbox with

sudo dnf eog

We are talking about the version from the Fedora Registry (from the GNOME Software).
Other versions such as the one from the toolbox or the one from Flathub work as expected.

I can confirm that’s due to the Fedora Registry version of the Eye of GNOME. When I used that I couldn’t open any JPEG-files but after installing the Flatpak version everything works fine!

Has anybody reported this bug at Red Hat’s Bugzilla?