Exiting programs in GNOME does not work properly

Dear all!

I have latest update of Fedora 33 (both rpm-ostree upgrade and flatpak update), but occured also with older versions. First I thought it happens only with Firefox, but it seems to happen with other programs as well.

When exiting a program in GNOME, it is not shown anymore. But, the process still exists.I googled for such a behavior, but haven’t found anything. Restarting is not possible, since the process still exists.

I think that following might be related: Sometimes when opening new Firefox’s windows, it take up to several minutes, until a new window is shown.

Do you have encounter similar problems?
(I haven’t found a similar bug report…but may have search for wrong key words?)

Cheers Florian

1 Like

Example of FireFox by ournalctl -b --since='today':

mar 15 23:11:26 fedora gnome-shell[1544]: libinput error: event5  - AlpsPS/2 ALPS DualPoint TouchPad: client bug: event processing lagging behind by 31ms, your system is too slow
mar 15 23:11:26 fedora NetworkManager[863]: <info>  [1615846286.7262] manager: NetworkManager state is now CONNECTED_GLOBAL
mar 15 23:11:30 fedora firefox.desktop[19088]: ###!!! [Child][MessageChannel] Error: (msgtype=0x5C0009,name=PHttpChannel::Msg_DeletingChannel) Channel closing: too late to send/recv, messages will be lost
mar 15 23:11:31 fedora chronyd[750]: Selected source 91.206.8.34 (2.fedora.pool.ntp.org)
mar 15 23:11:31 fedora firefox.desktop[14821]: ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
mar 15 23:11:31 fedora gnome-shell[1544]: libinput error: event5  - AlpsPS/2 ALPS DualPoint TouchPad: client bug: event processing lagging behind by 15ms, your system is too slow
mar 15 23:11:33 fedora chronyd[750]: Selected source 86.59.80.170 (2.fedora.pool.ntp.org)
mar 15 23:11:33 fedora systemd[1434]: app-gnome-firefox-14821.scope: Succeeded.
mar 15 23:11:33 fedora systemd[1434]: app-gnome-firefox-14821.scope: Consumed 49min 9.660s CPU time.
...

mar 15 23:12:47 fedora gnome-shell[1544]: Received error from D-Bus search provider firefox.desktop: Gio.DBusError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name is not activatable

...

mar 15 23:14:54 fedora rtkit-daemon[746]: Supervising 7 threads of 3 processes of 1 users.
mar 15 23:14:54 fedora rtkit-daemon[746]: Supervising 7 threads of 3 processes of 1 users.
mar 15 23:14:55 fedora rtkit-daemon[746]: Supervising 7 threads of 3 processes of 1 users.
mar 15 23:14:55 fedora rtkit-daemon[746]: Supervising 7 threads of 3 processes of 1 users.
mar 15 23:14:55 fedora rtkit-daemon[746]: Supervising 7 threads of 3 processes of 1 users.
mar 15 23:14:55 fedora rtkit-daemon[746]: Supervising 7 threads of 3 processes of 1 users.
mar 15 23:14:55 fedora rtkit-daemon[746]: Successfully made thread 22639 of process 20108 (/usr/lib64/firefox/firefox) owned by '1000' RT at priority 10.
mar 15 23:14:55 fedora rtkit-daemon[746]: Supervising 8 threads of 4 processes of 1 users.
mar 15 23:14:55 fedora firefox.desktop[20039]: ###!!! [Child][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
mar 15 23:14:55 fedora systemd[1434]: app-gnome-firefox-20039.scope: Succeeded.
mar 15 23:14:55 fedora systemd[1434]: app-gnome-firefox-20039.scope: Consumed 1.783s CPU time.```

Your Firefox is not flatpak, right? Silverblue includes Firefox in the image…

Which other applications? Flatpak installations?

You are right…

The software tool as well. And Shotwell, which is a flatpak from flathub.

I don’t have Shotwell, but I confirm that GNOME Software keeps running in background when closed.

I think this is by design.
If you check the process, you’ll see the --gapplication-service switch:

$ ps aux | grep -i software
fede        1929  0.6  2.9 1475292 237332 ?      Sl   22:06   0:09 /usr/bin/gnome-software --gapplication-service

I think the switch is determined by this setting:

$ grep DBusActivatable /usr/share/applications/org.gnome.Software.desktop 
DBusActivatable=true

IIRC copying the desktop file to ~/.local/share/application/ and changing DBusActivatable to false might change the behaviour.

IIUC flatpak apps can handle the run in background through the Settings, see also this discussion.

1 Like