Dual boot with Windows 10 installation error

From your lsblk -f I guess your EFI partition is nvme0n1p1 (usually it have FAT filesystem).

If your nvme drive already full and the only blank partition are on sda, from “Device Selection” you could try to select both Disks. Hopefully it will identify the EFI partition.

But please be aware of any messages to make sure that the installation destination are correct and did not removing your current Windows OS. As long as the “Begin Installation” not pressed, the partition layout will not apply and you could exit the installation and try again.

Even if I select both disks, the same error shows up.

Have yoi tried with the new workstation iso

Would you like also to try to make sure that the 78GB free disk in sda are not formatted using “Disks” app from Gnome live usb (App list → Utilities → Disks)? May be you also want to try to disable Windows fast start up.

Maybe Windows still hold your data in those data partition, try to boot to windows then login to dekstop windows, open file explorer, then open your drive data, then close explorer then restart your computer/laptop then try to directly from your usb live fedora than try again.

Tried disabling Windows fast startup and checked in Gnome Disks, still the same error.

Also tried the Workstation as @frankjunior suggested or opening/closing Windows Explorer, still nothing.

Can you try use partition manager app in kde and use it to make a partition with ext4 or btrfs file system then try to install onto it and delete that partition while install and install it as intended i don’t understand what is going wrong here.
@computersavvy told tell us that and see if you can create partition with linux file system like ext4 xfs btrfs what ever then from anaconda installer delete that partition which was newly created then it should be ok.

This is beginning to sound like the partition was prepared improperly.

I have found that if you use windows to create the partition it prevents linux from using it properly. Since the remainder of the driver appears to be ntfs, I have to ask how that blank space was created.

The way that has always been successful for me was to use the windows disk manager and shrink the file system/partition, leaving the space I wanted for linux as unallocated. Then when I install linux into that empty space it just works.

If I instead use windows to create a partition in that space I usually encounter problems.

I’m sorry if I explained it incorrectly, but I did it like this (you can see it in the first screenshot in the original post, where the 78.13 GB space is unallocated.)

Thank you so much for this idea!

I used the KDE Partition Editor to create a blank 600MB partition and a 1024MB partition and left space for the btrfs. Then I used Custom Advanced (Blivet-GUI) to format them, add mount points (/boot/efi for the 600MB one and /boot for the 1024MB) and create the btrfs volume (and 2 subvolumes, root and home). Then Fedora finally installed without a problem.

Kindly make that as a solution which ever worked for you.

I marked my own reply as a solution, because I didn’t do it exactly how you said, but you gave me the idea.