Fedora installation failed and I cant get back to Windows 10 =(

Hi guys.
I tried to install Fedora 37 with Rufus, uploaded to pen-drive, during installation it asked me to give more space, so I offered 40GB from my disk C free space, but installation failed cause showed the message: “Failed to set efi boot target”. I found similar issues with this and as I understood, I need to create a new disk from Windows tools in order to offer space for Fedora plus check this UEFI & BIOS installation rules.

However, now I cant get back to Windows. During loading without Linux Pen-drive, it just black screen where says to insert system pen in order to start. And all this stuff that I found in internet doesnt help: (link limit) - I dont have Windows Repair CD
Checked youtube video (link limit) → going with sudo update-grub → command not found. Going with this then:

henryju/G15 or grub2 - update-grub command not found - Ask Ubuntu → “grub-mkconfig” and “sudo: apt-get” both not found

If you are available for a discord discussion: aret#7469

For now what I tried, I came to answer that my Windows 10 system was deleted, cause it doesnt exists in Boot menu, like here

Will check what I can do…

My disk partitions, is windows still there? I tried to repair from Windows ISO - no effect, thinking about full system reinstallation…

You originally did not need to offer free space from windows. It has long been suggested that one uses windows to manage windows and linux to manage linux. Accordingly using the windows disk manager to shrink the windows file system is the recommended way to adjust its size, then an install into the unallocated space is easy, particularly with the automatic partitioning.

Now it is harder because we really at this point do not know the status.
A windows install/recovery iso image can be downloaded from microsoft at https://www.microsoft.com/en-us/software-download/windows10ISO
That image can be put onto a USB and used to recover the windows installation.

Next you can use windows disk manager to free up enough space to use for installing Fedora, and leave the space as unallocated.

You also need to be aware if windows is booting in legacy or uefi mode since the fedora install needs to be the same.

When booted to the live install fedora media a text window with the output of sudo fdisk -l should show you a partition that is marked as the EFI System if windows is booting in uefi mode.

You now should be able to do an install to the drive.

Note, that if you booted and installed in legacy mode and windows is booting to uefi mode you will not be able to dual boot. The reverse is also true. The only way to install and dual boot is if you boot from the usb live image in the same mode as windows boots so the install is done properly.

Note that random references on the web are more apt to be wrong than correct since they are often just that one persons reference and may not match your hardware, OS, or situation.

We are glad to assist if you are patient enough to ask and wait for a response.

1 Like

Some observations:

  1. Your drive is partitioned by MBR, not by GPT. That is not specifically a problem, but many instructions you might find for fixing things may assume GPT, so that is a detail to be careful of.

  2. Likely your system was set up for “legacy” boot. But you should check that in BIOS settings in order to be sure, because legacy boot makes a big difference in what you need to do to fix things.

  3. Your second partition(size 400G) is very likely your Windows system and very likely undamaged. Only the boot connection to reach it is damaged.

  4. If it is legacy boot then your fifth partition (sda5 when booted in the live linux system) is your boot partition. (It is probably your boot partition even if you don’t have legacy boot). The contents of that partition would be very helpful in understanding what has gone wrong and what can be done to fix it. Maybe someone who knows more could diagnose without that info, but I likely couldn’t.

  5. You should not need screen photos when booted in the live system. You should be able to connect to the internet and to this forum while booted in that system. Then you can copy/paste text directly into forum posts (please use the </> button to create pre-formatted text when pasting in blocks of text).

  6. To look at the contents of sda5 there are many methods, so if you already know how, do it your way. I tend to use:

sudo mkdir /mnt/sda5
sudo mount /dev/sda5 /mnt/sda5
sudo tree /mnt/sda5

I assume that gives too much text to see on screen, but maybe not too much to copy/paste here. If it seems to be only a few screen fulls, you might use:

sudo tree /mnt/sda5

then used the Edit menu of the terminal window to select all and copy, then paste into this thread.

  1. That one has me confused, because I’m still guessing your Windows system was using legacy boot, but that error seems to imply the linux installer thought it was not using legacy boot. It might end up easiest to fix things by changing the setting in the BIOS to not use legacy boot (rather than fixing the boot connections to correctly do legacy boot dual-boot). I don’t know yet.

Thanks for answers guys.
I tried to restore and repair windows with downloaded ISO from pen-drive (no effect) and tried reinstall Windows, but it said that I cant install on MBR partitions (strange, cause I specifically made pen-drive as MBR). In BOOT screen there was no options to boot PC without external drive, so I stop there. Anyway, as Fedora was working even without installation, I had opportunity to download important files to external HDD from linux, and brought my laptop to tech-specialist - he will reinstall Windows and install Linux.
Thanks for help, at least if something similar happens in future, I know what to do.

This says windows was installed in legacy mode.
Windows uses msdos partitioning for legacy mode boot and gpt partitioning for uefi boot. AFAIK there are no exceptions to this.

Looking at that image it seems to me that sda5 is probably the esp for uefi boot (/boot/efi), with sda6 being /boot and sda7 being the main OS.

If my analysis is correct then there is only one of 2 real solutions.

  1. reinstall linux in legacy mode, using sda5, 6, & 7 as the linux space. Delete those partitions then reinstall linux.
  2. reinstall windows in uefi mode which would completely wipe out all the data on the drive, repartition the drive as GPT, then install windows clean. Following which linux could be reinstalled in uefi mode.