Why I Install Fedora 38 Beta Failed?

I Tried btrfs and ext4 Format, All Failed.
My Computer is Thinkpad X220i.
how to solve this problem?

Is this a whole erased disk install? Or a Windows dual boot install?

Windows dual boot install.

I have a similar experience last week.

I erased whole disk, install Windows NOT using whole disk. Then boot Fedora installer trying to use the reserved free space. Then installer aborted similarly to yours.

Lastly, I re-install Windows using whole disk, follow by Fedora w/ free up space. Then installation went OK.

Should I reinstall Windows first and then install Fedora?

If you have time to help trouble shoot this issue, it can help more user that might face the same problem.

If you are in hurry, I think re-install Windows to using whole disk is worth a try. It worked for me.

I always recommend installing windows first then linux.
Windows bootloader seems to not allow booting linux from grub if it is installed last. Grub is happy to boot either OS if they are installed properly.

I have never installed windows in a mode that reserved space on the disk.
Your description seems to indicate that windows may not have left the space unallocated but instead treated it as additional drive space and actually created a partition there. If it did then using gdisk or fdisk from within the live boot installer could have been used to free up that space and continue installing.

My method has always been to use the right tools. When I have a windows disk and want to change the size I use the windows disk manager to free up the space. Some report success shrinking an ntfs windows partition with linux partitioning tools, but I would rather not take the chance on something not working properly.

Any partition that is created by windows is marked by windows so it can be recognized (as a windows device). This is probably what happened with the failed install. The partition was not totally clean.

I also use windows disk manager (or the macOS Disks tool on macs). Close source vendors can change something that breaks 3rd party tools (or even their own tools!) without telling users, so when messing with vendor filesystems, use vendor tools whenever practical.

1 Like

I currently don’t know what Version of the install iso you use, but I would try another one, maybe from here:

maybe the last anaconda went in (though it fixed another bug):

the screenshot says:

the installer already installs the OS, what - AFAIK- usually comes after successful partitioning and formating !

your bug looks similar to: