Dual boot with Windows 10 installation error

I have a 1TB SSD with Windows 10 on it and a 3TB HDD that i use for storage. I want to install Fedora 35 KDE Spin on the HDD next to the data partition, so I shrank the data partition in Windows disk management.

(Nepřiřazeno means Not allocated)

I flashed Fedora on a USB flash drive using the Fedora Media Writer. In the installer I selected the HDD like this:

But it ended up with an error.

It’s a UEFI system and both drives should be using GPT. I also have a screenshot of the HDD in GParted.

Any help would be appreciated!

Why not install parallel to the windows in the ssd just make unallocate 60gb(recommended) of storage in your ssd and select that storage with / and make it btrfs try to install it you will see a better experience.
And the unallocated will be Marged with the normal ntfs that you can in windows and fedora also.
Select advance option custom with guided select that unallocated of your ssd and here you go install it and everything will be fine don’t worry and if you want to install in hdd you can do it as i have told in the ssd one

I don’t really care about the HDD being slower and I want to have free space on my SSD, so that’s why I want to install Fedora to the HDD.

Selecting unallocated on the HDD in custom storage configuration gives me an error, I already tried that.

Nooo if you can see the unallocated storage then try like that
Try to create a partition with btrfs and then select that partition and go on

I don’t understand.

Do you mean this?

That gives me an “Unable to allocate requested partition scheme” error

Or do you mean the + button on the bottom? That allows me to create a btrfs root partition but it shows the same error when I try to create a /boot or /boot/efi partition

Leave it just follow it tap on the plus button and set 78848mb and mount point (/) filesystem btrfs recommended and a partition and then use a other space 1024 as (/boot) as another partition and then click done. Sometimes /boot may not be required but having it in the first place is not bad and install it i hope it will install fine.
If you need something like a screenshot let me know if you still can’t do that.

It shows an error when creating the /boot or /boot/efi partition and it won’t allow me to install without a /boot/efi partition

(i set a different size than you suggested for the / btrfs partition on my screenshot but that isn’t important)

Would you like to post lsblk -f to see your current partition layout?

[liveuser@localhost-live ~]$ lsblk -f
NAME     FSTYPE FSVER LABEL               UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0    squash 4.0                                                                           
loop1    ext4   1.0   Anaconda            fff21562-979e-4bd4-af74-455e66418265                
│        ext4   1.0   Anaconda            fff21562-979e-4bd4-af74-455e66418265    1.1G    84% /
         ext4   1.0   Anaconda            fff21562-979e-4bd4-af74-455e66418265    1.3G    81% /run/install/source
         ext4   1.0   Anaconda            fff21562-979e-4bd4-af74-455e66418265    1.1G    84% /
└─sda2   ntfs                             28E6525DE6522B78                                    
sdb      iso966 Jolie Fedora-KDE-Live-35-1-2
│                                         2021-10-26-06-06-09-00                              
├─sdb1   iso966 Jolie Fedora-KDE-Live-35-1-2
│                                         2021-10-26-06-06-09-00                     0   100% /run/initramfs/live
├─sdb2   vfat   FAT16 ANACONDA            AD0B-D4CC                                           
└─sdb3   hfsplu       ANACONDA            ebb7c601-055f-3583-806c-db392e27fa92                
zram0                                                                                         [SWAP]
│        vfat   FAT32                     F0E2-6241                                           
│        ntfs                             62DEE78CDEE756B7                                    
         ntfs                             B85EEA3D5EE9F452                                    

Here is a screenshot for your easy solve
Try in both modes i only have workstation iso so i run a vm and do it there with 20 gigs you just create a single btrfs with / as mount point and do accept changes and once you have done that done ok.

I tried that, but if I only create the / partition then I can’t click Done because it also needs a /boot/efi partition both in the Custom and in Advanced Custom (Blivet-GUI)

This is what happens if I try to create the /boot/efi partition in Advanced Custom (Blivet-GUI)

I find something related to your issue read this

You can also try on your ssd and it will show you a option to reclaim space and it will install with out a issue.

I think the issue in that forum post is probably something else than in my case, as I can’t even begin the installation process. They actually solved their issue by installing in non-UEFI mode, which I think is a bad choice.

Okey try it again reboot and insert usb again and lets try.go to custom option and thn First create a /boot/efi with 1gb and / root (btrfs) rest of space and try to install it again i think it should work i think the issue is actually your system need a space for bootloader but as you don’t have one in the 3tb of hdd so the error happens try again the actual bootloader for windows system is on ssd maybe that is the reason of failture so do it like i said i think this time it will be ok.

I tried this many times with different USB drives and creating the /boot/efi partition first but no luck. 600 MB is enough for /boot/efi because Fedora by default uses a 600 MB /boot/efi and a 1024 MB /boot

I actually tried doing the same thing in a VM (I installed Windows, added a second drive and partitioned it like I have on my real PC) and it worked without any errors, so it’s weird that it doesn’t work on my real PC

I just find a video that maybe can help you i think.he have explained everything quite nicely

My problem is I can’t create the /boot/efi partition he creates at 8:40 in the video

I really don’t know why what is the issue but the last thing i could say or suggest that if you can just try with the workstation iso

and do consider checking the hash before making usb
In windows
Go to the directory of the containing file with cd certutil -hashfile filename.extension SHA256
In linux
Go to the file containing folder with files app and open terminal
sha256sum filename.extension