DNF upgrade error

Attempted to clean package cache after error messages from upgrade but dnf keeps giving same error after clean.

The first error seems to be related to your rpmdb. Did you use rpm to install/remove packages instead of dnf at some point?

The second is a weird one. I think it’s happened because you missed an intermediate update:


Can you try running dnf update --allowerasing to see if that helps? man dnf for information on the option etc.

1 Like

No to rpm. I’m new to Fedora and rpm packages. I’ve used Debian distros up until now mostly. I have used the “autoremove” feature in dnf and “clean all” for house keeping. Will try your suggestion and report back.

Back where i started with same result.
Executed dnf update --allowerasing
dnf clean all
dnf autoremove
dnf check-update
dnf upgrade
Dito result…

Try remove it and reinstall to see if it solve the problem of dependencies. sudo dnf remove libreoffice-core && sudo dnf reinstall libreoffice-core if this do nothing try sudo dnf distro-sync --allowerasing && sudo dnf --refresh upgrade --allowerasing


1 Like

Well this went from bad to worse.I no longer have a working office suite and the computer won’t upgrade. Stuck in a perpetual loop of conflict. I may save files and reinstall system at this point, which I perceive to be easier than deducing this fuster cluck.

1 Like

To restore libreoffice you only need sudo dnf install libreoffice what will install full package of suite or you can one by one install them calc word etc… from console or gnome software. The real problem is with the upgrade…and yes a fresh install is always the better option and it is than i do every time when a new version is out. Is good to do a simple script to install the things than you wish have what is easy run and save time too.

Sorry than nothing helped you.

1 Like

Eh? You removed libreoffice but still got libreoffice related conflicts? That really doesn’t sound right. Was it the same packages or different packages that were conflicting?

Thanks for trying guys, it was appreciated. It is time to step back punt and reset the field.

1 Like

I decided against re-installing system and now see that would have been foolish.
I ran an update and when I upgraded I just added “dnf upgrade -x libreoffice…” , which exclude those packages and the upgrade proceeded as normal.
It should be noted that even though I have uninstalled libreoffice, it stills shows up after I check-update.
If someone can explain that, I would like to hear about it.

dnf check-update
Last metadata expiration check: 2:53:49 ago on Wed 04 Dec 2019 09:28:12 AM EST.

libreoffice-core.x86_64 1: updates

If you problem is with libreoffice only right now you can try reinstall it and see than it does say

sudo dnf reinstall libreoffice-core && sudo dnf reinstall libreoffice*

Try the command above and check if this solve the problem and if it doesn’t post the output


Well, this shows an error. Did a dnf transaction fail at some point? Did the system turn off during an update or something, for example? As I’d said in the first post—there’s something wrong with the rpmdb on your machine. You could try to reset it using rpm --rebuilddb, but please read this page before proceeding: