After install, first system upgrade prompt error

i just installed fedora brand new. now a few minutes later it says there are some updates to download, 246 packages, sure ok. but it doesn’t because of error "update issue: internal error error running transaction: mesa-filesystem(x86-32) = 21.0.3-2.fc34 is needed by (installed) mesa-drivers-21.0.3-2.fc34.i686

so for example after a long list of updates that its downloading the last few lines are these, and i have tried them:

i tried in konsole: “sudo dnf clean all” but it did not help.

i can’t install any updates at all for the system until i get this sorted out, pls help. i did search before i posted, nothing seemed applicable to my issue.
Running transaction check
Error: transaction check vs depsolve:
mesa-filesystem(x86-32) = 21.0.3-2.fc34 is needed by (installed) mesa-dri-drivers-21.0.3-2.fc34.i686
To diagnose the problem, try running: ‘rpm -Va --nofiles --nodigest’.
You probably have corrupted RPMDB, running ‘rpm --rebuilddb’ might fix the issue.
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing ‘dnf clean packages’.

1 Like

This kind of issue is typically transient.
It should be resolved automatically when the mirrors are synced.
Try again in a few hours, or run a few times until DNF selects an up-to-date mirror:

sudo dnf --refresh upgrade

In the meanwhile, dnf update --skip-broken should allow you to update the rest of the system.

I would guess that the 32-bit packages are just being neglected a bit since Fedora Linux doesn’t support running on 32 bit hardware since Fedora Linux 31. Some of those packages are still needed for, e.g., running older 32-bit games under wine. If the problem persists for more than a week or two, you could file a bug report.

1 Like