Dnf update FAILED several times

Hi, tried to do dnf update, several times. It downloads all the packages but at the end gives an error message:
Total 6.0 MB/s | 847 MB 02:21
Delta RPMs reduced 847.7 MB of updates to 846.6 MB (0.1% saved)
Running transaction check
error: rpmdbNextIterator: skipping h# 21
Header V4 RSA/SHA256 Signature, key ID 19940e11: BAD
Header SHA256 digest: OK
Header SHA1 digest: OK
error: rpmdbNextIterator: skipping h# 21
Header V4 RSA/SHA256 Signature, key ID 19940e11: BAD
Header SHA256 digest: OK
Header SHA1 digest: OK
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing ‘dnf clean packages’.
Error: An rpm exception occurred: package not installed

You did not mention if you tried cleaning the cache with the suggested command at the end of the output. If you did, then we need more information about your system so that we can help you, like Fedora version, etc…

You did not mention if you had tried the standard dnf upgrade --refresh to verify you had new clean metadata downloaded or any thing else you may have tried other than repeating the same thing over and over. You also did not mention how long a time period you have been trying this. Sometimes the mirrors may cause similar and transient issues with a potentially corrupted download.

One kind of final try and rather extreme would be to rebuild the rpm database. That can be done with sudo rpm --rebuilddb, though it should not just be done arbitrarily but only as a last resort.

1 Like

Hi Jeff V, It all just started yesterday. I did clear the cache, a couple of times. It wasn’t for an upgrade, it was for an update (if that makes a difference. it concerns F38 / newest version.
I usually do an “dnf update” at the end of every session before locking or shutting the system down. Should I try “dnf upgrade --refresh” as you suggested anyway?

regards

Hi Mike,It all just started yesterday. I did clear the cache, a couple of times. It wasn’t for an upgrade, it was for an update (if that makes a difference. it concerns F38 / newest version.
Which I installed at the end of April.

I usually do an “dnf update” at the end of every session before locking or shutting the system down. And it always goes smoothly, this is the first time I’ve encountered this problem.

I would suggest trying dnf upgrade --refresh as has been suggested.Upgrade and update are the same with dnf. You might also try
dnf distro-sync .

Hi, Cleared the cache, ran sudo dnf upgrade --refresh and go this:
(315/316): ffmpeg-6.0-10.fc38.x86_64.rpm 279 kB/s | 1.7 MB 00:06
(316/316): ffmpeg-libs-6.0-10.fc38.x86_64.rpm 1.5 MB/s | 8.0 MB 00:05

Total 4.7 MB/s | 853 MB 03:00
Running transaction check
error: rpmdbNextIterator: skipping h# 21
Header V4 RSA/SHA256 Signature, key ID 19940e11: BAD
Header SHA256 digest: OK
Header SHA1 digest: OK
error: rpmdbNextIterator: skipping h# 21
Header V4 RSA/SHA256 Signature, key ID 19940e11: BAD
Header SHA256 digest: OK
Header SHA1 digest: OK
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing ‘dnf clean packages’.
Error: An rpm exception occurred: package not installed
[frank@asus-fedora ~]$

Then I cleaned packages again and ran sudo dnf distro-sync and got this at the end:
315/316): zenity-3.92.0-2.fc38.x86_64.rpm 823 kB/s | 3.2 MB 00:04
(316/316): ffmpeg-libs-6.0-10.fc38.x86_64.rpm 2.6 MB/s | 8.0 MB 00:03

Total 3.8 MB/s | 853 MB 03:45
Running transaction check
error: rpmdbNextIterator: skipping h# 21
Header V4 RSA/SHA256 Signature, key ID 19940e11: BAD
Header SHA256 digest: OK
Header SHA1 digest: OK
error: rpmdbNextIterator: skipping h# 21
Header V4 RSA/SHA256 Signature, key ID 19940e11: BAD
Header SHA256 digest: OK
Header SHA1 digest: OK
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing ‘dnf clean packages’.
Error: An rpm exception occurred: package not installed
[frank@asus-fedora ~]$

I found this when searching for ‘rpmdbNextIterator’.

I suggest you find that package (which might be #21 in the list of packages to be installed) and remove it. Also note that it is mentioning 3rd party so identifying the repo involved and disabling it might be all that is required.

Please post the output of dnf repolist so we might assist in identifying the source of this issue.

Hi Jeff V, here is the readout from sudo dnf repolist:

[frank@asus-fedora ~]$ sudo dnf repolist
[sudo] password for frank: 
repo id                                        repo name
brave-browser-rpm-release.s3.brave.com_x86_64_ created by dnf config-manager from https://brave-browser-rpm-release.s3.brave.com/x86_64/
copr:copr.fedorainfracloud.org:kwizart:fedy    Copr repo for fedy owned by kwizart
copr:copr.fedorainfracloud.org:phracek:PyCharm Copr repo for PyCharm owned by phracek
fedora                                         Fedora 38 - x86_64
fedora-cisco-openh264                          Fedora 38 openh264 (From Cisco) - x86_64
fedora-modular                                 Fedora Modular 38 - x86_64
google-chrome                                  google-chrome
google-earth-pro                               google-earth-pro
protonvpn-fedora-stable                        ProtonVPN Fedora Stable repository
rpmfusion-free                                 RPM Fusion for Fedora 38 - Free
rpmfusion-free-updates                         RPM Fusion for Fedora 38 - Free - Updates
rpmfusion-free-updates-testing                 RPM Fusion for Fedora 38 - Free - Test Updates
rpmfusion-nonfree                              RPM Fusion for Fedora 38 - Nonfree
rpmfusion-nonfree-nvidia-driver                RPM Fusion for Fedora 38 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam                        RPM Fusion for Fedora 38 - Nonfree - Steam
rpmfusion-nonfree-updates                      RPM Fusion for Fedora 38 - Nonfree - Updates
rpmfusion-nonfree-updates-testing              RPM Fusion for Fedora 38 - Nonfree - Test Updates
teamviewer                                     TeamViewer - x86_64
updates                                        Fedora 38 - x86_64 - Updates
updates-modular                                Fedora Modular 38 - x86_64 - Updates
[frank@asus-fedora ~]$

Going according to the package list, see the copy paste below:

(19/316): akregator-23.04.0-1.fc38.x86_64.rpm 457 kB/s | 2.1 MB 00:04
(20/316): alternatives-1.24-1.fc38.x86_64.rpm 52 kB/s | 39 kB 00:00
(21/316): annobin-docs-12.10-1.fc38.noarch.rpm 91 kB/s | 94 kB 00:01
(22/316): alsa-utils-1.2.9-1.fc38.x86_64.rpm 608 kB/s | 1.2 MB 00:01
(23/316): at-spi2-atk-2.48.2-1.fc38.x86_64.rpm 119 kB/s | 85 kB 00:00
(24/316): at-spi2-core-2.48.2-1.fc38.x86_64.rpm 240 kB/s | 372 kB 00:01
(25/316): annobin-plugin-gcc-12.10-1.fc38.x86_6 347 kB/s | 893 kB 00:02

If this is what you meant, it looks like annobin-docs-12.10-1.fc38.noarch.rpm,

is the culprit, if this is what you meant (?). So how can I remove it (?), if you think this is the problem? or do you have something else in mind?

Hi Jeff, I removed protonvpn, ( because at the very beggining of the problem there was mention, in the terminal about proton, so i removed it), cleared the cache, did dnf autoremove, sudo dnf upgrade and then got the following;

MIRROR] ffmpeg-6.0-10.fc38.x86_64.rpm: Status code: 404 for https://mirror.netsite.dk/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-6.0-10.fc38.x86_64.rpm (IP: 185.224.16.132)
[MIRROR] ffmpeg-libs-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mirror.netsite.dk/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-libs-6.0-10.fc38.x86_64.rpm (IP: 185.224.16.132)
[MIRROR] libavdevice-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mirror.netsite.dk/rpmfusion/free/fedora/updates/38/x86_64/l/libavdevice-6.0-10.fc38.x86_64.rpm (IP: 185.224.16.132)
[MIRROR] ffmpeg-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mirror.netsite.dk/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-6.0-10.fc38.x86_64.rpm (IP: 185.224.16.132)
[MIRROR] libavdevice-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mirror.yandex.ru/fedora/rpmfusion/free/fedora/updates/38/x86_64/l/libavdevice-6.0-10.fc38.x86_64.rpm (IP: 213.180.204.183)
[MIRROR] ffmpeg-libs-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mirror.yandex.ru/fedora/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-libs-6.0-10.fc38.x86_64.rpm (IP: 213.180.204.183)
[MIRROR] ffmpeg-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mirror.yandex.ru/fedora/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-6.0-10.fc38.x86_64.rpm (IP: 213.180.204.183)
[MIRROR] libavdevice-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mirrors.netix.net/rpmfusion/free/fedora/updates/38/x86_64/l/libavdevice-6.0-10.fc38.x86_64.rpm (IP: 87.121.121.2)
[MIRROR] ffmpeg-libs-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mirrors.netix.net/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-libs-6.0-10.fc38.x86_64.rpm (IP: 87.121.121.2)
[MIRROR] ffmpeg-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mirrors.netix.net/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-6.0-10.fc38.x86_64.rpm (IP: 87.121.121.2)
[MIRROR] libavdevice-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mirror.de.leaseweb.net/rpmfusion/free/fedora/updates/38/x86_64/l/libavdevice-6.0-10.fc38.x86_64.rpm (IP: 37.58.58.140)
[MIRROR] ffmpeg-libs-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mirror.de.leaseweb.net/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-libs-6.0-10.fc38.x86_64.rpm (IP: 37.58.58.140)
[MIRROR] ffmpeg-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mirror.de.leaseweb.net/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-6.0-10.fc38.x86_64.rpm (IP: 37.58.58.140)
[MIRROR] libavdevice-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mir01.syntis.net/rpmfusion/free/fedora/updates/38/x86_64/l/libavdevice-6.0-10.fc38.x86_64.rpm (IP: 5.83.232.126)
[MIRROR] ffmpeg-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mir01.syntis.net/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-6.0-10.fc38.x86_64.rpm (IP: 5.83.232.126)
[MIRROR] ffmpeg-libs-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://mir01.syntis.net/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-libs-6.0-10.fc38.x86_64.rpm (IP: 5.83.232.126)
[MIRROR] libavdevice-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://www.fedora.is/rpmfusion/free/fedora/updates/38/x86_64/l/libavdevice-6.0-10.fc38.x86_64.rpm (IP: 176.57.227.242)
[MIRROR] ffmpeg-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://www.fedora.is/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-6.0-10.fc38.x86_64.rpm (IP: 176.57.227.242)
[MIRROR] ffmpeg-libs-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://www.fedora.is/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-libs-6.0-10.fc38.x86_64.rpm (IP: 176.57.227.242)
[MIRROR] ffmpeg-libs-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://rpmfusion.ip-connect.vn.ua/free/fedora/updates/38/x86_64/f/ffmpeg-libs-6.0-10.fc38.x86_64.rpm (IP: 194.5.96.10)
[MIRROR] ffmpeg-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://rpmfusion.ip-connect.vn.ua/free/fedora/updates/38/x86_64/f/ffmpeg-6.0-10.fc38.x86_64.rpm (IP: 194.5.96.10)
[MIRROR] libavdevice-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://rpmfusion.ip-connect.vn.ua/free/fedora/updates/38/x86_64/l/libavdevice-6.0-10.fc38.x86_64.rpm (IP: 194.5.96.10)
[MIRROR] ffmpeg-libs-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://fr2.rpmfind.net/linux/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-libs-6.0-10.fc38.x86_64.rpm (IP: 195.220.108.108)
[MIRROR] ffmpeg-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://fr2.rpmfind.net/linux/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-6.0-10.fc38.x86_64.rpm (IP: 195.220.108.108)
[MIRROR] libavdevice-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://fr2.rpmfind.net/linux/rpmfusion/free/fedora/updates/38/x86_64/l/libavdevice-6.0-10.fc38.x86_64.rpm (IP: 195.220.108.108)
[MIRROR] ffmpeg-libs-6.0-10.fc38.x86_64.rpm: Status code: 404 for https://download1.rpmfusion.org/free/fedora/updates/38/x86_64/f/ffmpeg-libs-6.0-10.fc38.x86_64.rpm (IP: 193.106.119.144)
[MIRROR] libavdevice-6.0-10.fc38.x86_64.rpm: Status code: 404 for https://download1.rpmfusion.org/free/fedora/updates/38/x86_64/l/libavdevice-6.0-10.fc38.x86_64.rpm (IP: 193.106.119.144)
[MIRROR] ffmpeg-6.0-10.fc38.x86_64.rpm: Status code: 404 for https://download1.rpmfusion.org/free/fedora/updates/38/x86_64/f/ffmpeg-6.0-10.fc38.x86_64.rpm (IP: 193.106.119.144)
[MIRROR] ffmpeg-libs-6.0-10.fc38.x86_64.rpm: Status code: 404 for https://download1.rpmfusion.org/free/fedora/updates/38/x86_64/f/ffmpeg-libs-6.0-10.fc38.x86_64.rpm (IP: 193.106.119.144)
[MIRROR] libavdevice-6.0-10.fc38.x86_64.rpm: Status code: 404 for https://download1.rpmfusion.org/free/fedora/updates/38/x86_64/l/libavdevice-6.0-10.fc38.x86_64.rpm (IP: 193.106.119.144)
[MIRROR] ffmpeg-6.0-10.fc38.x86_64.rpm: Status code: 404 for https://download1.rpmfusion.org/free/fedora/updates/38/x86_64/f/ffmpeg-6.0-10.fc38.x86_64.rpm (IP: 193.106.119.144)
[MIRROR] ffmpeg-libs-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://ftp.upjs.sk/pub/mirrors/rpmfusion.org/free/fedora/updates/38/x86_64/f/ffmpeg-libs-6.0-10.fc38.x86_64.rpm (IP: 158.197.16.70)
[MIRROR] libavdevice-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://ftp.upjs.sk/pub/mirrors/rpmfusion.org/free/fedora/updates/38/x86_64/l/libavdevice-6.0-10.fc38.x86_64.rpm (IP: 158.197.16.70)
[MIRROR] ffmpeg-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://ftp.upjs.sk/pub/mirrors/rpmfusion.org/free/fedora/updates/38/x86_64/f/ffmpeg-6.0-10.fc38.x86_64.rpm (IP: 158.197.16.70)
[MIRROR] ffmpeg-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://repo.fedora.md/mirrors/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-6.0-10.fc38.x86_64.rpm (IP: 95.65.43.79)
[FAILED] ffmpeg-6.0-10.fc38.x86_64.rpm: No more mirrors to try - All mirrors were already tried without success
(313-314/315): libav 99% [===================-] 5.2 MB/s | 845 MB 00:01 ETA
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing ‘dnf clean packages’.
Error: Error downloading packages:
ffmpeg-6.0-10.fc38.x86_64: Cannot download, all mirrors were already tried without success
[frank@asus-fedora ~]$

So I am totally confused as to what the problem might be. Any suggestions? Also I tried,
sudo rpm --rebuilddb, earlier and that had no effect.
regards magic

Hi Jeff V, new good news.
Unexplainable, but the system seems to be working normal again. I did a Software update (not with the terminal, but using the software system).
Through that there was a mandatory rebooting. Then I reinstalled protonvpn, did a sudo dnf update, which functioned normally, cleared the cache,

( 0 files deleted ) did another sudo dnf update… nothing to do… result.

So I don’t know what happened, but I am content at this time.

Best regards for you help and support & patience.

Have a nice day,

Frank / Magic

please paste terminal output as Preformatted Text using </>-symbol from toolbox. It is much easier to read, see example:

[MIRROR] ffmpeg-6.0-10.fc38.x86_64.rpm: Status code: 404 for http://repo.fedora.md/mirrors/rpmfusion/free/fedora/updates/38/x86_64/f/ffmpeg-6.0-10.fc38.x86_64.rpm (IP: 95.65.43.79)
[FAILED] ffmpeg-6.0-10.fc38.x86_64.rpm: No more mirrors to try - All mirrors were already tried without success
(313-314/315): libav 99% [===================-] 5.2 MB/s | 845 MB 00:01 ETA
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing ‘dnf clean packages’.
Error: Error downloading packages:
ffmpeg-6.0-10.fc38.x86_64: Cannot download, all mirrors were already tried without success

Hi Flo, thanks for your tip / feedback / interest.
As I have written to Jeff V, it seems the problem has either cleared itself (somehow, or gone away) as the “sudo dnf update” works again as normal.

Thank you for your concern and have a nice day.

Magic

Glad to know that things have cleared up.
:+1:

The initial reported error seemed to be an invalid gpg key on one of the packages being updated.

Removing protonvpn may have removed the package that was causing the error, or clearing the cache, or ?. Maybe even just an update in the mirrors.

I note that you have both the nonfree and the free testing repos from rpmfusion enabled. That seems unusual unless you are deliberately are doing testing for the packages from rpmfusion. If not intentionally doing testing then those 2 repos should probably be disabled.

The long list of 404 errors with trying to update ffmpeg may have been due to the rpmfusion testing repos since the 6.0-10 release has already been replaced with the 6.0-11 release, but I cannot confirm that.

Hi Jeff V,
Concerning the free, non free repos, I didn’t install them extra, I just let the Fed 38 install itself with the new version F38 at the end of April.
If you think it is or could cause problems, and I don’t actually need them, I suppose I could remove them, but I would need definite instructions as to going about removing or disabling them.
I’m not that “tech savvy” with the Fed. Terminal. I would be interested in your feedback. What purpose do they serve?

You don’t have to remove the rpmfusion repo’s
just disable the rpmfusion testing repo’s you can do that from gnome software

Was that a new clean install of F38 or an upgrade from F37?

If a new clean install then it is obvious that several additional repos that are not part of a fedora install were installed & enabled. If an upgrade then it is obvious that at some point the additional repos were already installed & enabled.

This is what I see on a new clean install of F38

# dnf repolist
repo id                                                        repo name
copr:copr.fedorainfracloud.org:phracek:PyCharm                 Copr repo for PyCharm owned by phracek
fedora                                                         Fedora 38 - x86_64
fedora-cisco-openh264                                          Fedora 38 openh264 (From Cisco) - x86_64
fedora-modular                                                 Fedora Modular 38 - x86_64
google-chrome                                                  google-chrome
rpmfusion-nonfree-nvidia-driver                                RPM Fusion for Fedora 38 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam                                        RPM Fusion for Fedora 38 - Nonfree - Steam
updates                                                        Fedora 38 - x86_64 - Updates
updates-modular                                                Fedora Modular 38 - x86_64 - Updates

Anything more than that is something the user has deliberately changed from a default clean install.

The first column of the dnf repolist output gives the repo ID.
To disable any repo from the command line use the command
sudo dnf config-manager --disable <repo id> and one can --disable or --enable already installed repos such as the rpmfusion testing repos.

Hi, it was an upgrade from F37.

Here is the present repolist;

[frank@asus-fedora ~]$ sudo dnf repolist
[sudo] password for frank:
repo id repo name
brave-browser-rpm-release.s3.brave.com_x86_64_ created by dnf config-manager from https://brave-browser-rpm-release.s3.brave.com/x86_64/
copr:copr.fedorainfracloud.org:kwizart:fedy Copr repo for fedy owned by kwizart
copr:copr.fedorainfracloud.org:phracek:PyCharm Copr repo for PyCharm owned by phracek
fedora Fedora 38 - x86_64
fedora-cisco-openh264 Fedora 38 openh264 (From Cisco) - x86_64
fedora-modular Fedora Modular 38 - x86_64
google-chrome google-chrome
google-earth-pro google-earth-pro
protonvpn-fedora-stable ProtonVPN Fedora Stable repository
rpmfusion-free RPM Fusion for Fedora 38 - Free
rpmfusion-free-updates RPM Fusion for Fedora 38 - Free - Updates
rpmfusion-free-updates-testing RPM Fusion for Fedora 38 - Free - Test Updates
rpmfusion-nonfree RPM Fusion for Fedora 38 - Nonfree
rpmfusion-nonfree-nvidia-driver RPM Fusion for Fedora 38 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam RPM Fusion for Fedora 38 - Nonfree - Steam
rpmfusion-nonfree-updates RPM Fusion for Fedora 38 - Nonfree - Updates
rpmfusion-nonfree-updates-testing RPM Fusion for Fedora 38 - Nonfree - Test Updates
teamviewer TeamViewer - x86_64
updates Fedora 38 - x86_64 - Updates
updates-modular Fedora Modular 38 - x86_64 - Updates
[frank@asus-fedora ~]$