Dash to Dock extension doesn't work with Gnome Tweaks


#1

I used Gnome Software to install some extensions, Dash to Dock among them. Everything worked fine. Then I managed to install Gnome Tweaks. And Dash to Dock got broken. Gnome Tweaks can’t load it with not so helpful error message “Error loading extension”. Several other extensions from Gnome Software work fine (Screenshot tool, AppIndicator). Of course, I tried to remove and install it again with the same result.
I must add that I’m on Silverblue Rawhide. Does anyone met same troubles with Dash to Dock? That’s practically one best extension for Gnome that I can call “system seller”. Gnome gets almost unusable without it.


#2

Try journalctl -b 0 /usr/bin/gjs and see if you see any errors related to Dash to Dock.

(As a side note, have you tried just hitting the logo key and searching for apps to run, or using the keyboard shortcuts to navigate workspaces?)


#3

Thank you. I tried it clean way: with no Dash to Dock extension installed there were no log records. Then I installed Dash to Dock (still no records), loaded Gnome Tweak and this appeared:

– Logs begin at Sat 2018-11-17 17:07:51 +05, end at Mon 2018-11-26 13:11:52 +05. –
ноя 26 13:11:04 localhost.localdomain org.gnome.Chara[3796]: Some code called array.toString() on a Uint8Array instance. Previously this would have interpreted the bytes of the array as a string, but that is nonstandard. In the future this will return the bytes as comma-separated digits. For the time being, the old behavior has been preserved, but please fix your code anyway to explicitly call ByteArray.toString(array).
(Note that array.toString() may have been called implicitly.)
0 [“resource:///org/gnome/Characters/BackgroundService/js/searchProvider.js”:26]
1 [“resource:///org/gnome/Characters/BackgroundService/js/service.js”:33]
2 ["/usr/share/org.gnome.Characters/org.gnome.Characters.BackgroundService":6]
ноя 26 13:11:04 localhost.localdomain org.gnome.Chara[3796]: Some code accessed the property ‘SearchProvider’ on the module ‘searchProvider’. That property was defined with ‘let’ or ‘const’ inside the module. This was previously supported, but is not correct according to the ES6 standard. Any symbols to be exported from a module must be defined with ‘var’. The property access will work as previously for the time being, but please fix your code anyway.
ноя 26 13:11:05 localhost.localdomain org.gnome.Chara[3796]: JS WARNING: [resource:///org/gnome/Characters/BackgroundService/js/searchProvider.js 50]: String.toUpperCase is deprecated; use String.prototype.toUpperCase instead

I actually can’t make heads or tails out of it. Looks like some code (Dash to Dock probably) calls some deprecated functions. But that could be Gnome Tweak itself as well.

Of course, that is the only way on a clean Gnome environment. But that is in no way convenient for me. I think that interface should follow the principle “least interaction - most information”. When I look at the screen on a clean Gnome, I can’t see which apps are loaded and where. I need to press additional key which actually not so helpful as it overloads the eyes with information: big, small, medium size windows in Activities. Also I have zero config options: I can’t make favorites bar smaller or bigger, can’t choose how to show windows in Activities. Without Gnome Tweaks I can’t even make workspaces static.
Now, I don’t want to say that these interface decisions are all bad as they are. They might be very convenient for someone. They are all bad because they don’t leave me a choice. Actually, even godforsaken Windows 10 is much more configurable than clean Gnome.
Sorry for this ranting about Gnome. :grinning: I’ll be super happy when there would be Silverblue Spins with KDE, XFCE, Cinnamon and so on to choose.


#4

Actually, this topic can be closed for now. Sadly, I no longer have access to Silverblue system.