CoreOS on Raspberry Pi 4B reboot fails with no bootable devices found


I have installed CoreOS 40 to 2 Raspberry Pi 4B 4GB booting from USB attached NVME drives following the procedure in the documentation on a PC running Fedora 40 Workstation. The installation completes fine and both devices boot up and run without problem. I can logon via SSH and run containers successfully.

If however, I reboot either of them, the system fails to start and I can see the Raspberry Pi complaining of ‘no bootable partitions’. If I attach the drive to another system I can see that the EFI-SYSTEM is empty and my only way to get the system back up is to reinstall it again. This happens if I use U-Boot or EDK2.

I’d really like to stick with CoreOS but it’s basically a non-starter if this is the case everytime it reboots.

Removed workstation

Hello @pauljwhelan and welcome to :fedora: !

Are you following the procedure described in Provisioning Fedora CoreOS on the Raspberry Pi 4 :: Fedora Docs?

Hi Hristo,


Yes, I’m following the procedure. I will say, the only option I didn’t try was EDK2: Separate Firmware Disk Mode. I found that a bit confusing!

Provisioning Fedora CoreOS on Raspberry Pi 4 works fine for SD Card or iPXE.

I haven’t tried booting from a drive connected via USB adapter. Is this your setup?

Yes, I have an NVME drive in a USB attached enclosure

I’m going to connect an SSD disk to a USB adapter to try to boot.

1 Like

Thanks, appreciate the help

Ok, it would seem that the problem was hardware and user error! I had some errors in my ignition file in that I was partitioning incorrectly. Once I fixed that my first system started fine and can reboot without problem. The second one was a bit stranger. The NVME drives I’m using are different revisions of the same model and the one I brought recently doesn’t seem to like EDK2 so I tried U-Boot and it works fine. Not sure why it would be like that but they both run and can reboot without problem so I’m happy. Thanks for taking the time to help Hristo. Much appreciated

Yeah, it seems that not all USB to SSD adapters are suitable for FCOS system disks attached to them. From my recent experience with this case, the reliable ones (of the ones I have) are from external drives.

It’s definitiely not an exact science!!