Constant network errors: "Connection Failed"

Fedora 39 Workstation - Lenovo Yoga 7 16"

I run a VPN 24/7, I use built in VPN option in system tray (top right corner drop down), I dont use any 3rd party VPN apps.

I have 6 or 7 VPN locations to choose from, all of which are Wireguard protocol (downloaded configs from VPN supplier)

I get great speeds and generally it works great, way better than their 3rd party app ran on my Mac (although it was on an unsupported OS).

I get repeated notifications like this:

Screenshot from 2024-02-26 13-19-01

I get them when the machine is locked, and also when it’s unlocked. Once I am busy using the machine they tend to stop, but if it sleeps, they start appearing again for a while.

I have tried all the different connections, they all do it.

But the connection errors seem wrong, as even when I have one hovering at the top of the screen I can get to websites fine, and an IP check confirms I am connected via the chosen VPN connection.

Any ideas what’s causing this? thanks

When a machine suspends or sleeps the network is disabled, then re-enabled when the machine wakes up. This includes vpns which depend upon the network interface to be functional.


So it’s just detecting those interrupts? If so, understood. Whilst I generally like that feature for privacy/security, i wonder if there will be instances where I’d like network connectivity to remain during sleep, such as to hear Signal calls or Transmission downloads or similar. Is that doable if desired?

Thanks again

You could configure the ethernet port with wake-on-lan, but I don’t think that is possible with wifi interfaces.

Interesting thanks. I don’t use wifi at all. So that would keep the ethernet connecton live through suspends?

Wake-on-Lan should allow the ethernet connection to wake the machine from sleep/suspend.

Note that apps on the suspended system would not be active and could not trigger the wake up, only an external connection could do that.

Ah ok, probably of little use to me then, worth knowing about though thanks