Wired and WiFI Network randomly dropping out and not connecting after sleep

HI there,

Congratulation to the Fedora team and all the developers building such great new developments in the recent 39 release. DNF5 is from my experience a BIG improvement on packaging speed and connecting to mirrors.

Currently, when my system goes into sleep I am unable to get connected to the wired or wifi network.

I have noticed there are a few people from past releases of fedora but thought perhaps there is a simple fix.

Is anyone able to offer any insights into this?

I have recently tried systemctl restart NetworkManager.service

Perhaps that may resolve it.

Kernel version is : 6.6.9-100.fc38.x86_64

Are you using Fedora 39 Workstation and Gnome? Here, I have a 39 Workstation configured with a web server so I don’t want it to sleep, and another system where I use wake-on-lan when I need to an ssh session. If you want to prevent the system from sleeping, see: Talk: GNOME suspends after 15 minutes of user inactivity, even on AC power.

1 Like

HI @gnwiii , thanks for the link, actually this machine is a workstation for desktop purposes.

So I dont want to keep it awake permanently. I let it sleep/standby and the issue happens.

I may have to run systemctl status NetworkManager.service to determine whats happening when it happens again.

Are you trying to connect to the sleeping F38 workstation from another PC or is the problem that you don’t have networking when the system wakes from sleep?

my problem is that I don’t have networking when the system wakes from sleep…

We need to determine whether this is a power management issue (network interface goes to
Power Management is an area where vendor support for linux is important. Whenever there are major changes to the kernel, as with a new Fedora release, vendors that don’t provide open source drivers have to make changes. Please paste the output from running inxi -Fzxx in a terminal (as text using the </> button) so we can the make and model of the PC and network hardware and the network drivers used.

In the short term, you need a way to manually enable networking. I think others with similar network issue were able to use Gnome Settings to bring networking back.

Make sure you have fully updated Fedora and also the vendor’s “BIOS” firmware so you aren’t chasing a problem that is already solved and because it is easier for others to duplicate your configuration.

There is a very good chance that journalctl will have details needed to understand the problem, but deeply buried under the massive detail journalctl provides. You can use journalctl -b -g <string> using wifi, a kernel module name, or a kernel network device name (typically enp1s0 or wlo1) for <string>.

Edit: typo: -s replaced by -g in the journalctl example.

Thats my specs below.

actually, i was unable to reconnect my network even through gnome settings terminal…

System:
  Kernel: 6.6.9-100.fc38.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.39-16.fc38 Desktop: GNOME v: 44.7 tk: GTK v: 3.24.38 wm: gnome-shell
    dm: GDM Distro: Fedora release 38 (Thirty Eight)
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX Z390-H GAMING v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2417
    date: 06/03/2019
Battery:
  Device-1: hidpp_battery_0 model: Logitech MX Vertical Advanced Ergonomic
    Mouse serial: <filter> charge: 55% (should be ignored) status: discharging
CPU:
  Info: 6-core model: Intel Core i5-9600KF bits: 64 type: MCP
    arch: Coffee Lake rev: D cache: L1: 384 KiB L2: 1.5 MiB L3: 9 MiB
  Speed (MHz): avg: 3233 high: 4601 min/max: 800/4600 cores: 1: 4601 2: 800
    3: 4400 4: 4400 5: 4400 6: 800 bogomips: 44398
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Gigabyte driver: amdgpu v: kernel arch: GCN-4 pcie: speed: 8 GT/s
    lanes: 16 ports: active: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 01:00.0
    chip-ID: 1002:67df temp: 36.0 C
  Device-2: Microdia [] driver: snd-usb-audio,uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 1-3:3 chip-ID: 0c45:636b
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,vesa dri: radeonsi gpu: amdgpu display-ID: 0
  Monitor-1: HDMI-A-1 model: LG (GoldStar) HDR QHD res: 2560x1440 dpi: 93
    diag: 801mm (31.5")
  API: OpenGL v: 4.6 vendor: amd mesa v: 23.1.9 glx-v: 1.4 es-v: 3.2
    direct-render: yes renderer: AMD Radeon RX 570 Series (polaris10 LLVM
    16.0.6 DRM 3.54 6.6.9-100.fc38.x86_64) device-ID: 1002:67df
    display-ID: :0.0
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a348
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Gigabyte driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s
    lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aaf0
  Device-3: Microdia [] driver: snd-usb-audio,uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 1-3:3 chip-ID: 0c45:636b
  API: ALSA v: k6.6.9-100.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Realtek RTL8192CE PCIe Wireless Network Adapter vendor: ASUSTeK
    driver: rtl8192ce v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: 3000
    bus-ID: 05:00.0 chip-ID: 10ec:8178
  IF: wlp5s0 state: down mac: <filter>
Drives:
  Local Storage: total: 465.76 GiB used: 493.08 GiB (105.9%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 500GB
    size: 465.76 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 39.9 C
Partition:
  ID-1: / size: 464.17 GiB used: 260.38 GiB (56.1%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 344.8 MiB (35.4%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 464.17 GiB used: 260.38 GiB (56.1%) fs: btrfs
    dev: /dev/nvme0n1p3
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 33.0 C mobo: N/A gpu: amdgpu temp: 36.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 1925
Info:
  Processes: 387 Uptime: 1m Memory: total: 16 GiB available: 15.53 GiB
  used: 3 GiB (19.3%) Init: systemd v: 253 target: graphical (5)
  default: graphical Compilers: gcc: 13.2.1 Packages: pm: rpm pkgs: N/A
  note: see --rpm pm: flatpak pkgs: 31 Shell: Bash v: 5.2.21
  running-in: gnome-terminal inxi: 3.3.31

Both ethernet and wifi are ASUS variants of widely used chips, so you have to rely on ASUS firmware updates when you update the kernel. One workaround may be to use LTS kernels.
Wake from sleep issues often occur with newer kernels as linux power management is different from Windows and is often done differently by vendors.

Linux Hardware Data Base probes for [8086:15bc] mention netmap as an “additional driver”. Fedora 38 Can’t Use Ethernet has some diagnostic checks. The I219-V ethernet controllers do not play well with linux, see Getting Intel I219-V to work in Debian. Newer ethernet controllers are available at reasonable prices so if you have a suitable bus slot available that may be your best solution.

Linux Hardware Data Base probes for [10ec:8178 lists couple alternative drivers. WiFi support in linux often lags behind the release schedule, so I find it helpful to have a USB WiFi dongle for use when onboard WiFi has a problem.

2 Likes

hmm thats a shame i may need an LTS kernel. I never had this issue with all other versions of Fedora.

I have heard some people say upgrading to Fedora 39 fixed this issue.

I use this machine as my daily workstation I guess for know I’ll just keep resetting it if the systemctl restart NetworkManager.service and see if that resolves it.

If not I shall upgrade to fedora 39 and see.

I know about installing other kernels but that seems a bit risky with the other hardware since I am not sure how the other peripherals and devices would respond to that. For me its Fedora or nothing/

Perhaps silverblue may be a better option as I can roll back to other kernel versions with ease

That may just mean the kernel interfaces used by your vendor’s firmware didn’t change until 6.6.

The LTS kernel may help with older systems from vendors that don’t update their firmware for the current kernels. You already have a 6.6 kernel. I would expect F38 with a 6.6 kernel to use the same firmware as F39, but I don’t recall if F39 gets firmware updates that aren’t in F38. On F39, the firmware packages I have are:

% doas dnf list installed | grep firmware
doas (gnw3@cerberusf39) password:
alsa-sof-firmware.noarch                             2023.12-1.fc39                      @updates             
amd-gpu-firmware.noarch                              20231211-1.fc39                     @updates             
amd-ucode-firmware.noarch                            20231211-1.fc39                     @updates             
atheros-firmware.noarch                              20231211-1.fc39                     @updates             
brcmfmac-firmware.noarch                             20231211-1.fc39                     @updates             
intel-gpu-firmware.noarch                            20231211-1.fc39                     @updates             
iwlegacy-firmware.noarch                             20231211-1.fc39                     @updates             
iwlwifi-dvm-firmware.noarch                          20231211-1.fc39                     @updates             
iwlwifi-mvm-firmware.noarch                          20231211-1.fc39                     @updates             
libertas-firmware.noarch                             20231211-1.fc39                     @updates             
linux-firmware.noarch                                20231211-1.fc39                     @updates             
linux-firmware-whence.noarch                         20231211-1.fc39                     @updates             
mt7xxx-firmware.noarch                               20231211-1.fc39                     @updates             
nvidia-gpu-firmware.noarch                           20231211-1.fc39                     @updates             
realtek-firmware.noarch                              20231211-1.fc39                     @updates           

We still need to see the relevant messages from journalctl to understand your issue.

1 Like

Thanks for your message,

Please see below the outputs

Also for output of journalctl, it doesn’t seem to pickup those commands

Perhaps my syntax is not correct.

see below:

[isaiah@fedora-office ~]$ journalctl -b -s <enpls0>
bash: syntax error near unexpected token `newline'
[isaiah@fedora-office ~]$ journalctl -b -s <wlo1>
bash: syntax error near unexpected token `newline'
[isaiah@fedora-office ~]$ 
[isaiah@fedora-office ~]$ systemctl restart NetworkManager.service
[isaiah@fedora-office ~]$ systemctl status NetworkManager.service
● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; preset: enabled)
    Drop-In: /usr/lib/systemd/system/service.d
             └─10-timeout-abort.conf
     Active: active (running) since Mon 2024-01-15 15:32:05 AEDT; 4s ago
       Docs: man:NetworkManager(8)
   Main PID: 413250 (NetworkManager)
      Tasks: 9 (limit: 19008)
     Memory: 3.8M
        CPU: 53ms
     CGroup: /system.slice/NetworkManager.service
             └─413250 /usr/sbin/NetworkManager --no-daemon

Jan 15 15:32:05 fedora-office NetworkManager[413250]: <info>  [1705293125.7777] dhcp6 (eno1): activation: beginning transaction (timeout in 45 secon>
Jan 15 15:32:05 fedora-office NetworkManager[413250]: <info>  [1705293125.7780] policy: set 'Wired connection 1' (eno1) as default for IPv6 routing >
Jan 15 15:32:05 fedora-office NetworkManager[413250]: <info>  [1705293125.7860] dhcp4 (eno1): state changed new lease, address=192.168.1.5
Jan 15 15:32:05 fedora-office NetworkManager[413250]: <info>  [1705293125.7862] policy: set 'Wired connection 1' (eno1) as default for IPv4 routing >
Jan 15 15:32:05 fedora-office NetworkManager[413250]: <info>  [1705293125.7937] device (eno1): state change: ip-config -> ip-check (reason 'none', s>
Jan 15 15:32:05 fedora-office NetworkManager[413250]: <info>  [1705293125.7952] device (eno1): state change: ip-check -> secondaries (reason 'none',>
Jan 15 15:32:05 fedora-office NetworkManager[413250]: <info>  [1705293125.7953] device (eno1): state change: secondaries -> activated (reason 'none'>
Jan 15 15:32:05 fedora-office NetworkManager[413250]: <info>  [1705293125.7956] manager: NetworkManager state is now CONNECTED_SITE
Jan 15 15:32:05 fedora-office NetworkManager[413250]: <info>  [1705293125.7958] device (eno1): Activation: successful, device activated.
Jan 15 15:32:05 fedora-office NetworkManager[413250]: <info>  [1705293125.7960] manager: startup complete
lines 1-23/23 (END)

You can see from the screenshot below that the wired network connection is not connecting with the icon in the top left.

I get the same issue with a realtek usb wifi dongle. I have to reboot to maybe get it back. Even the live CD of Fedora 39 may have issues with it.

This indicates that you have locally network connection but you can’t access the internet. You can see this also in the status for the NetworkManager.service, In my it says:

NetworkManager state is now CONNECTED_GLOBAL

resolvectl should reveal you the DNS addresses. They have to be set by connection. If empty try to verify if you can set a manual dns like 8.8.8.8 or 1.1.1.1 or whatever you prefer.

2 Likes

I see, so perhaps its normal that we need to reboot after wake to reactivate the network device on this kernel version for my hardware.

Does your system have this issue where the network manager does not reconnect after wake?

I dont recall having this issue on earlier versions of Fedora, the new Fedora reboots very very fast however so thats great.

No, mine works fine. Just when I used bridged networking I had sometimes a lag to get network up and running after sleep.

You can also try to switch off and on the network with nmcli n off and with nmcli n on
I made me a helper-script to combine this commands like nmcli c show to combine them to one command.

1 Like

Yesterday and today it has started to also drop out randomly (lose connection)

I am also using an alternative DNS resolver (nextdns), perhaps that may be affecting it I thought. I have disconnected that and will see if it resolves.

I wouldnt imagine it would disconnect the device though, but I could be wrong…

isaiah@fedora-office:~$  journalctl -fk
Jan 16 10:51:08 fedora-office kernel: usblp0: removed
Jan 16 10:51:08 fedora-office kernel: usblp 1-6:1.0: usblp0: USB Bidirectional printer dev 5 if 0 alt 0 proto 2 vid 0x04F9 pid 0x028B
Jan 16 10:51:13 fedora-office kernel: gnome-shell[1345]: memfd_create() called without MFD_EXEC or MFD_NOEXEC_SEAL set
Jan 16 10:51:13 fedora-office kernel: rfkill: input handler disabled
Jan 16 10:51:14 fedora-office kernel: usb 1-3: 3:1: cannot get freq at ep 0x84
Jan 16 10:51:14 fedora-office kernel: usb 1-3: 3:1: cannot get freq at ep 0x84
Jan 16 10:51:16 fedora-office systemd-journald[642]: /var/log/journal/d8452f05a2e444ed8f4e55d858e8e489/user-1000.journal: Journal file uses a different sequence number ID, rotating.
Jan 16 10:51:17 fedora-office kernel: rfkill: input handler enabled
Jan 16 10:51:18 fedora-office kernel: rfkill: input handler disabled
Jan 16 10:51:18 fedora-office kernel: logitech-hidpp-device 0003:046D:407B.0007: HID++ 4.5 device connected.

Hi @gnwiii .

So I ran journalctl to determine whats wrong and it gave me this output below…

It seems it is disconnecting but unsure why…

I saw this post from an unofficial forum, I am weary to use that though…

isaiah@fedora-office:~$ journalctl -b -u NetworkManager
Jan 16 10:51:04 fedora-office systemd[1]: Starting NetworkManager.service - Network Manager...
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.0916] NetworkManager (version 1.44.2-1.fc39) is starting... (boot:aaf8aec5-e7f8-4ab6-a8bd-7e0ed967f069)
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.0918] Read config: /etc/NetworkManager/NetworkManager.conf (lib: 20-connectivity-fedora.conf) (run: 15-carrier-timeout.conf)
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.0943] manager[0x563d71056950]: monitoring kernel firmware directory '/lib/firmware'.
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1453] hostname: hostname: using hostnamed
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1454] hostname: static hostname changed from (none) to "fedora-office"
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1456] dns-mgr: init: dns=systemd-resolved rc-manager=unmanaged (auto), plugin=systemd-resolved
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1460] rfkill0: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.6/0000:05:00.0/ieee80211/phy0/rfkill0) (driver rtl8192ce)
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1461] manager[0x563d71056950]: rfkill: Wi-Fi hardware radio set disabled
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1461] manager[0x563d71056950]: rfkill: WWAN hardware radio set enabled
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1480] Loaded device plugin: NMAtmManager (/usr/lib64/NetworkManager/1.44.2-1.fc39/libnm-device-plugin-adsl.so)
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1505] Loaded device plugin: NMBluezManager (/usr/lib64/NetworkManager/1.44.2-1.fc39/libnm-device-plugin-bluetooth.so)
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1512] Loaded device plugin: NMWifiFactory (/usr/lib64/NetworkManager/1.44.2-1.fc39/libnm-device-plugin-wifi.so)
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1523] Loaded device plugin: NMTeamFactory (/usr/lib64/NetworkManager/1.44.2-1.fc39/libnm-device-plugin-team.so)
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1526] Loaded device plugin: NMWwanFactory (/usr/lib64/NetworkManager/1.44.2-1.fc39/libnm-device-plugin-wwan.so)
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1527] manager: rfkill: Wi-Fi disabled by radio killswitch; disabled by state file
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1527] manager: rfkill: WWAN enabled by radio killswitch; enabled by state file
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1528] manager: Networking is enabled by state file
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1531] settings: Loaded settings plugin: keyfile (internal)
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1551] dhcp: init: Using DHCP client 'internal'
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1552] manager: (lo): new Loopback device (/org/freedesktop/NetworkManager/Devices/1)
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1559] device (lo): state change: unmanaged -> unavailable (reason 'connection-assumed', sys-iface-state: 'external')
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1562] device (lo): state change: unavailable -> disconnected (reason 'connection-assumed', sys-iface-state: 'external')
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1565] device (lo): Activation: starting connection 'lo' (22523c50-0711-4c26-8d85-64cf935a7055)
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1569] manager: (eno1): new Ethernet device (/org/freedesktop/NetworkManager/Devices/2)
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.1571] device (eno1): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.3432] device (wlp5s0): driver supports Access Point (AP) mode
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.3442] manager: (wlp5s0): new 802.11 Wi-Fi device (/org/freedesktop/NetworkManager/Devices/3)
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.3447] device (wlp5s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.3456] device (wlp5s0): set-hw-addr: set MAC address to DA:E3:FA:03:37:84 (scanning)
Jan 16 10:51:04 fedora-office systemd[1]: Started NetworkManager.service - Network Manager.
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.3476] bus-manager: acquired D-Bus service "org.freedesktop.NetworkManager"
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.3490] device (lo): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'external')
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.3494] device (lo): state change: prepare -> config (reason 'none', sys-iface-state: 'external')
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.3497] device (lo): state change: config -> ip-config (reason 'none', sys-iface-state: 'external')
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.3512] device (lo): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'external')
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.3519] modem-manager: ModemManager available
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.3529] device (lo): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'external')
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.3531] device (lo): state change: secondaries -> activated (reason 'none', sys-iface-state: 'external')
Jan 16 10:51:04 fedora-office NetworkManager[1052]: <info>  [1705362664.3537] device (lo): Activation: successful, device activated.
Jan 16 10:51:07 fedora-office NetworkManager[1052]: <info>  [1705362667.7569] device (eno1): carrier: link connected
Jan 16 10:51:07 fedora-office NetworkManager[1052]: <info>  [1705362667.7578] device (eno1): state change: unavailable -> disconnected (reason 'carrier-changed', sys-iface-state: 'managed')
Jan 16 10:51:07 fedora-office NetworkManager[1052]: <info>  [1705362667.7593] policy: auto-activating connection 'Wired connection 1' (011938d9-de65-30dd-87e0-1ce480ab2b2a)
Jan 16 10:51:07 fedora-office NetworkManager[1052]: <info>  [1705362667.7602] device (eno1): Activation: starting connection 'Wired connection 1' (011938d9-de65-30dd-87e0-1ce480ab2b2a)
Jan 16 10:51:07 fedora-office NetworkManager[1052]: <info>  [1705362667.7604] device (eno1): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Jan 16 10:51:07 fedora-office NetworkManager[1052]: <info>  [1705362667.7610] manager: NetworkManager state is now CONNECTING
Jan 16 10:51:07 fedora-office NetworkManager[1052]: <info>  [1705362667.7613] device (eno1): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Jan 16 10:51:07 fedora-office NetworkManager[1052]: <info>  [1705362667.8175] device (eno1): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
Jan 16 10:51:07 fedora-office NetworkManager[1052]: <info>  [1705362667.8179] dhcp4 (eno1): activation: beginning transaction (timeout in 45 seconds)
Jan 16 10:51:09 fedora-office systemd[1]: Reloading NetworkManager.service - Network Manager...
Jan 16 10:51:09 fedora-office NetworkManager[1052]: <info>  [1705362669.4234] audit: op="reload" arg="0" pid=1181 uid=0 result="success"

Some wifi

That should not happen. There have been changes to linux power management, and it is quite possible that hardware vendors haven’t made required firmware updates. Some network modules have options to maintain network connectivity in low-power modes. modinfo e1000e mentions “SmartPowerDown”. From README and manual page from Intel Linux Driver e1000e v3.0.4.1 :

SmartPowerDownEnable

Valid Range: 0-1

Default Value: 0 (disabled)

Allows Phy to turn off in lower power states. The user can turn off this parameter in supported chipsets.

1 Like

ah I see. So can I customise the settings to allow this to happen. I have another network card I can try but this is a wifi network card, the “wired” connection is going straight into the mother board (ASUS), so it may be my firmware is not yet up to date yet?

Typo: ‘s’ should be g (for grep).

The < and > characters have special meaning on the linux command-line. Try:

journalctl -b -g enpls0
journalctl -b -g wlo1
1 Like