Can't resize KDE apps running in Gnome on F31

I’ve been using Fedora for years, originally KDE, now Gnome (not classic, not Wayland), and have just upgraded to F31. I like to use Konsole and Kate. Previously I could use the mouse to grab any of the corners of the windows and resize them but in F31 that is not possible. I can only change width or height, one at a time. Middle-click paste also fails. This is a huge loss; I use it 100 times a day. It seems to work in Gnome apps but not in KDE apps.
Are there configuration options to address this? This is almost enough to send me back to K land.
Thanks for any help.


Hi @obriend, welcome to the community! Please take a minute to go through the informative posts in the #start-here category if you’ve not yet had a chance to do so. They explain how the forum is setup and how Discourse (this platform) is to be used well.

Can you create a new user and see if the issue persists there? That’ll tell us if this is a system issue or one related to some configuration in your current user. Also, is your system up to date?

I’m on Fedora 32 now, and here it seems to work OK. I don’t use Konsole or Kate, but I use Qutebrowser which is Qt based and the various gestures work OK.

Thanks Francisco. The issue persisted with a new user. The system is up-to-date as of a couple of hours ago after I updated from F30 to F31. The issue only appears to be with KDE apps; resizing worked ok with Terminal but I much prefer Konsole. Kate is my editor of choice for most things.

The inability to paste with the middle mouse button was a show stopper for me, and I was about to try KDE again but instead tried Gnome with Xorg and now everything seems to work.


1 Like

Uh, so this is a system issue. Could you try a live Fedora 32 image to see if the issue persists there? Fedora 32 has received lots of updates, so it would be expected that lots of bugs have been fixed there. You can try one of the updated-respins: Index of /pub/alt/live-respins

Out of curiosity. Are you sure you are using Xorg instead of Wayland?

1 Like

I am now using Xorg and everything works as it did before. Under Gnome, Gnome Classic, etc., it failed. When I log in I click the little gear icon and choose Gnome on Xorg.

I have an up-to-date F32 VM running and the behavior is the same.

  • Middle-click paste does not work in KDE apps.
  • Cannot grab corners of KDE application windows (Kate and Konsole) to resize.
  • Pressing Win key to enable Search field does not work except under Gnome and Xorg. In Gnome Classic the desktop dims, but nothing else happens afaict.

As soon as I switch to Xorg it all works again.

These are major concerns for me so please don’t remove Xorg :open_mouth:


1 Like

I can confirm that corner grabbing doesn’t work for me with Qt apps on Gnome either. I don’t use it much which is why I hadn’t noticed. I tile by dragging the window to the left or right or top. Does it work if you use the KDE image (so apps on KDE, not Gnome?). That’ll help identify if it’s a general KDE issue or if its an issue with Qt apps on Gnome, and then perhaps we could file bugs.

I don’t have a middle click mouse, so someone else will have to verify that one.
Xorg will not go away until a large proportion of DEs have moved to Wayland. This is a good read for context: