Can't play HD Videos on Fedora 33

I’ve recently installed Fedora and I have a performance issue. I can’t play any videos in HD/High Quality on my Fedora machine. First I thought it has something to do with my Fedora in generell so i disabled animations. Didn’t help. I installed the nvidia driver and made and followed this tipp (first comment):
Reddit - Dive into anything). First it seemed to work and the HD videos got a little bit better (still not working fluently) but after the second reboot I got this error:

I also tried installing adobe flash player but it didn’t work either.
Please can somebody help? Thank you!!

I can only upload one media item. So here are the details of the “system error”:

The error message indicates that you have Secure Boot on your computer enabled and the NVIDIA drivers are not signed. Try to disable the Secure Boot option on your UEFI/BIOS firmware and reboot.

1 Like

Hey! Thank you for your help!!
I disabled the secure boot option and after rebooting Fedora installed new updates which I’m not sure which they were.
But unfortunately it didn’t help :frowning: . Videos on high resolution are still laagy. Is there something else I can try?

Take a look at this:

Hey! Thank you again!
I’ve tried that too and my internet connection got way faster.
But videos are still a little laagy. Maybe it has something to do with the CPU usage or something?
I’ve screenshoted the top command as I played a video in the background.

Don’t judge me, I’m a little bit privacy fanatic :stuck_out_tongue: ^^ . Am I on the right track? The values vary but they are always very high.
If yes, is there anything I can do or try? Maybe a known bug that result a high cpu usage?
Appreciate any help!! Thanks!!