VLC Can't Play video Full HD?

Hai All,
I use fedora 35 with the lastest kernel

uname -r

I tried to play video I’ve been recorded with full hd resolution (1920x1080). I can’t play with totem/default video in gnome, I can’t also play with VLC, See my SS below:

Then I tried to boot to windows 10, I play with VLC with the same codec. See my SS below:

I can smoothly play this video in windows 10 with VLC.
The question is why I can’t play video full hd in fedora 35 worskataion. Usually I play movie with extension mkv in fedora there is no problem.
This is the first time I play a video recorded by my own camera with the extension mp4 but I can’t play it on my daily use fedora linux 35 workstation.

Graphic Card:

inxi -G
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Device-2: IMC Networks USB2.0 UVC HD Webcam type: USB driver: uvcvideo
  Display: wayland server: X.Org v: with: Xwayland v: 21.1.4
    compositor: gnome-shell v: 41.4 driver: gpu: i915 resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 4000 (IVB GT2)
    v: 4.2 Mesa 21.3.8

How to solve this problem?
Thank You in Advance
Best regards,

There must be some codecs missing

You can install them with gnome softwares also.
sudo dnf groupupdate multimedia

1 Like

Install ffmpeg ffmpeg-libs packages from rpmfusion repos – ‘sudo dnf install ffmpeg ffmpeg-libs’ that will give you option to run hd videos

1 Like

It doesn’t work, those package already installed.

sudo dnf install ffmpeg ffmpeg-libs
Last metadata expiration check: 3:18:11 ago on Min 27 Mar 2022 01:15:57 .
Paket ffmpeg-4.4.1-7.fc35.x86_64 telah terpasang.
Paket ffmpeg-libs-4.4.1-7.fc35.x86_64 telah terpasang.
Dependensi terselesaikan.
Tidak ada yang dilakukan.

Oke siap, I will try it:pray:

ok try to install packages 'sudo dnf install x264. x264-libs gstreamer1-libav gstreamer1-plugins-bad-freeworld gstreamer1-plugins-ugly libde265 ’

1 Like

Sadly it doesn’t work.
According to those guide:
sudo dnf install gstreamer1-plugins-{bad-*,good-*,base} gstreamer1-plugin-openh264 gstreamer1-libav --exclude=gstreamer1-plugins-bad-free-devel

sudo dnf install lame* --exclude=lame-devel

sudo dnf group upgrade --with-optional Multimedia

sudo dnf groupupdate multimedia

This is the result still can play full hd in fedora 35 workstation:

After install those software, I did reboot, and still can’t play full hd.
I am curious this is because I enable secure boot? please help me, actually I rare to touch my windows 10, my most time is use fedora 35 workstation.
Thank You.

too sadly it’s doesn’t work.
sudo dnf install x264 x264-libs gstreamer1-libav gstreamer1-plugins-bad-freeworld gstreamer1-plugins-ugly libde265

Not works:

For now Leave vlc install mpv from flathub
flatpak install flathub io.mpv.Mpv
Try with it if it can play that video.

Edit- it will tell us that if it is only vlc issue or it is something else if you have tried let us know.

1 Like

Have you tried changing the resolution?

Yes of course.

OK can you share your video upload it to https://send.vis.ee/ and share with us Thanks

Thank you very much for your suggestion, I decided install mpv from oficial fedora repo not from flatpak, and it works.

But unfortunatly is not perfectly working, when i play full hd video in mpv, sometime or I can said frequently mpv drop the audio or no sound but after i click timeline progress bar in mpv the audio is heard again. I don’t know why this is happening? So for a while I will use mpv.
Anyone have experience like me when using mpv for play full hd video?

Maybe your CPU is not fast enough, try installing packages that enables GPU acceleration of h264 decoding, for IvyBridge that should be:
dnf install libva-intel-driver gstreamer1-vaapi libva-utils

vainfo will show your system’s capabilities.

More information in Hardware video acceleration - ArchWiki


I do install all necessary program and packet. but vlc still doesn’t work on my fedora 35 workstation daily use. I post attachment you can read in my first post in this thread, in windows VLC play full hd smoothly, mpv doing the same in linux, but sometime or frequently the sound is gone, if i click timeline progress bar then the sound is heard again. I not yet try mpv in windows 10.

Then Voila thank you very much, amazing, it works. Thank you :heart_eyes: :pray:

libva info: VA-API version 1.13.0
libva info: Trying to open /usr/lib64/dri/iHD_drv_video.so
libva info: va_openDriver() returns -1
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_12
failed to open /usr/lib64/dri/hybrid_drv_video.so
Not using hybrid_drv_video.so
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.13 (libva 2.13.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Ivybridge Mobile - 2.4.1
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Simple            :	VAEntrypointEncSlice
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSlice
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointEncSlice
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointEncSlice
      VAProfileH264StereoHigh         :	VAEntrypointVLD
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileNone                   :	VAEntrypointVideoProc
      VAProfileJPEGBaseline           :	VAEntrypointVLD

it works now

Oke siap, thank you all, I can play full hd video with vlc now in fedora 35 workstation and I feel this is very smooth, more smoother than play in windows 10.


This looks like very useful information. Any chance you could update the quick docs to add this information? Maybe this page (or a new one?)

https://docs.fedoraproject.org/en-US/quick-docs/assembly_installing-plugins-for-playing-movies-and-music/ 1


If it’s ok to link ArchWiki there, then why not.

I could add a separate section with commands to install different drivers (depending on GPU), but I see no point in rewriting ArchWiki.

1 Like

I think it’ll be fine to add a link to the Arch wiki too, unless the commands differ on Fedora. We could even put the commands there for convenience, and then add a link to the Arch wiki as a reference. Whatever works—any addition will be a good :slight_smile: