Can't install refind


i’m new to fedora - i downloaded it yesterday - and have already of course a problem.
I can’t install refind although i used this fedora guide: Refind - Fedora Project Wiki
The output of dnf install refind-0.6.11-1.x86_64.rpm is always

Last metadata expiration check: 1:48:28 ago on Thu 23 Dec 2021 19:10:10 CET.
Can not load RPM file: refind-0.6.11-1.x86_64.rpm.
Could not open: refind-0.6.11-1.x86_64.rpm

Thanks in advance for any help

Hey, Julian, welcome! Sorry to hear you are so quick to have an issue.

The document you reference is more than six years old, and the instructions for a very old version of Fedora. You’ve probably installed Fedora 35, the most recent version, whereas the author of the document you reference was using Fedora 18. A more recent reference might be Set up rEFInd bootloader on Linux systems

1 Like

I would try just:

dnf install refind

Thanks. Well i am not surprised since i knew it would be harder, than the beginner distros.
However the guide also doesn’t work on mine OS: after i enteredsudo dnf install refind-0.11.4-1.x86_64.rpm i just got the same result

Can not load RPM file: refind-0.11.4-1.x86_64.rpm.
Could not open: refind-0.11.4-1.x86_64.rpm
1 Like

Seemingly you’re command worked, thanks! It also resolved some dependencies (whatever that means).
What should i do now to enable it over grub on fedora?

Likely the most authoritative web site for rEFInd is Rod’s Books.

Fedora will still boot with grub. Refind “points” to grub, if that makes sense. If you like, you can change your grub timeout to zero so you don’t have to look at it when you boot Fedora.

Refind has to be set as the default boot option in your UEFI BIOS settings to work. It should set itself as default when you install it, but if something kicks it out you’ll have to switch it back. You can:

  • Run refind-install, that will reset it. It will only work on the OS you installed it under.
  • Change the boot order in your UEFI BIOS. Getting into the BIOS is different on every motherboard, but usually you press an F key or escape or something when your system is booting (mine is F11, for example).
  • Change the boot order with efibootmgr, very easy but you’d have to take ten minutes or so to learn how to use it.

[EDIT] Just a note of clarification, those are three different options, of which you would pick whichever one you want. You wouldn’t need to do them all.

Alright the cause was me to use the path in which you download and install the file manually, because i thought that would be safer. Just using the terminal since the start instead worked for me