Grub is not detecting my linux

Dual boot my pc to fedora and a another os called kubuntu to experience kde but now i can’t go back to my fedora
*fedora was older installed
** kubuntu was newer and now i can only access kububtu

I have tried
I have done sudo update-grub
Sudo update-grub2
I have mounted mnt my linux installed partition in which fedora 34 was but no outcome after restart grub is not showing me fedora34 5.14. Please help my fedora install have many documents. I have to start that.

Hi thanks for but none of those commands are working i am stuck on my kubuntu and i have fedora also in another partition and i need to update the grub to see fedora and kubuntu both please help

If you are using UEFI boot, you should find your Fedora installation on bios boot list. Open your bios go to bios boot list. There should be Fedora boot on there.

Or you could install efibootmgr on your kubuntu. Run it on terminal:

$ sudo efibootmgr

Above command will print all available boot list. Take a note for Fedora boot number from the list. Let’s say a line mentioned Fedora like Boot0000 Fedora means your Fedora installation are currently on boot number 0000.

From Fedora boot number above you could use one of the following command:

  1. Boot to Fedora on next reboot and perform it once
$ sudo efibootmgr -n 0000
$ systemctl reboot
  1. Rearrange your boot order and make Fedora on the first boot
$ sudo efibootmgr
# Find a line with something like 
# `BootOrder: 0001,0017,0000,0002,0014,0015,0016,0018,0019,001A,001B` 
# and rearrange the order and make Fedora on first order.
# From above example we know that Fedora have boot number 0000
# Then the new arrangement is:
$ sudo efibootmgr -o 0000,0001,0017,0002,0014,0015,0016,0018,0019,001A,001B
$ systemctl reboot

There other solution too by enabling Kubuntu grub menu to detect other installed OS by enabling os prober on grub setting. But sometime it’s does not work correctly on my case.

Tips: Install efibootmgr on both distros and make script to switch between them by running efibootmgr to rearrange the boot order.