Fedora Missing From Grub Triple Boot

Hello. This morning I decided to install Fedora. Everything went smoothly with the USB and I rebooted. However, upon getting to the Grub menu, I still only had Kubuntu and Windows as options. In Bios, Fedora is set to boot first followed by Kubuntu then Windows. It is not encrypted or anything, just a normal install and it is on the same SSD as Kubuntu so I know it’s not a problem with the drive. Is there anything I can do to put Fedora in the Grub menu? At the moment I cannot even boot into it, only my other two options. Thank you.

Hi @adventurecommunist.
Welcome to the Fedora Community.

Boot up Fedora and make sure you have the most recent packages:
sudo dnf update

If your PC boots in UEFI mode then do:
grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

If you are using Legacy boot mode:
grub2-mkconfig -o /boot/grub2/grub.cfg

Reboot and see if your grub menu is complete