Can't Install Apache OpenOffice on Silverblue

I’m trying to install Apache OpenOffice on Silverblue and I’m getting errors… I’m likely not as good as you at operating this Linux Distro - or any others for that matter.
Downloaded Apache OpenOffice from:

Installation instructions:

When in the RPMS directory, I ran:
rpm -Uvih *rpm
error: can’t create transaction lock on /usr/share/rpm/.rpm.lock (Read-only file system)
Tried chmod’ing that directory to 777 temporarily didn’t work then 640 didn’t work.
cd desktop-integration
Then ran:
sudo rpm -Uvih *rpm
error: Failed dependencies:
openoffice4.1.12-suse-menus conflicts with openoffice4.1.12-freedesktop-menus-4.1.12-9809.noarch
openoffice4.1.12-redhat-menus conflicts with openoffice4.1.12-freedesktop-menus-4.1.12-9809.noarch
openoffice4.1.12-mandriva-menus conflicts with openoffice4.1.12-freedesktop-menus-4.1.12-9809.noarch
mandrake-release is needed by openoffice4.1.12-mandriva-menus-4.1.12-9809.noarch
redhat-release is needed by openoffice4.1.12-redhat-menus-4.1.12-9809.noarch
/etc/SuSE-release is needed by openoffice4.1.12-suse-menus-4.1.12-9809.noarch

I don’t know what to ask at this point. There’s no flatpak. I’m hopeful someone can help me understand what happened here. Respectfully, i’m not soliciting advice on whether to use OpenOffice vs LibreOffice; I’m asking how to solve this problem :slight_smile:

So its quite straightforward by using the terminal as thats the easiest way I have found.

  1. Download the setup file with wget (you already have it but redownload it incase you have move the location as it may affect the install commands)
  1. Extract the setup file
tar -xzf Apache_OpenOffice_4.1.10_Linux_x86-64_install-rpm_en-US.tar.gz
  1. Goto the RPM directory
cd en-US/RPMS/
  1. Run the rpm command to install the open-office packages
sudo rpm -Uvih *rpm
  1. Optional step - remove libreoffice to avoid issues with clashing dependencies and the like
sudo dnf remove libreoffice*
  1. Final Step- Intergrate it with the desktop

Navigate to the desktop-intergration directory

cd desktop-integration/
sudo rpm -i openoffice4.1.10-freedesktop-menus-4.1.10-9807.noarch.rpm

All done! :slight_smile:

Hey there, benny - thanks for the instructions. With that said, I had actually done exactly that - and at #4 I get the following response:
“error: can’t create transaction lock on /usr/share/rpm/.rpm.lock (Read-only file system)”
Also, regarding number five (5) - the optional step - I see that your command has “dnf” and I’m doing this on Silverblue. I speculate that the issue is that everything goes to a specific folder and there are scripts set up so that they can automatically execute. Silverblue saves things in the /var directory and therein lies the rub. Quite frankly, I don’t understand this system very much and I certainly don’t have the low-level programming knowledge to start changing config files and what not. I suppose I do fundamentally understand how this is meant to work though and I don’t quite get why downloads don’t just go to /var then automatically and recursively copy [the directory] over to the intended folder of where the script is meant to be run? Or upon the initial download, just have a script that just spins up a container w/ Toolbox? It seems like with the initial download - the directory could just clear a simple script to do one of those two (2) things, then chmod 400 after the copied directory goes to where it needs to go.

I’ll submit there’s a knowledge gap here though. That question should probably be on a different thread and I do have to step out to return some video tapes, so I’ll be punctual:
#4 is where I get the first error
After this error, I ran:
cd …/desktop-integration
…and from there ran the command you suggested (which I had originally ran as root, so without “sudo” but then included “sudo” per another thread I came across):
sudo rpm -Uvih *rpm
…and that’s where I get the second error:
error: Failed dependencies:
openoffice4.1.12-suse-menus conflicts with openoffice4.1.12-freedesktop-menus-4.1.12-9809.noarch
openoffice4.1.12-redhat-menus conflicts with openoffice4.1.12-freedesktop-menus-4.1.12-9809.noarch
openoffice4.1.12-mandriva-menus conflicts with openoffice4.1.12-freedesktop-menus-4.1.12-9809.noarch
mandrake-release is needed by openoffice4.1.12-mandriva-menus-4.1.12-9809.noarch
redhat-release is needed by openoffice4.1.12-redhat-menus-4.1.12-9809.noarch
/etc/SuSE-release is needed by openoffice4.1.12-suse-menus-4.1.12-9809.noarch

Ah yes i didnt think your using silverblue version of fedora, this could be the issue. silverblue is an immutable os so that could be the reason your getting the filesystem error.

to install files of this type you need to run the rpm-ostree command.

Silverblue runs software throught flatpaks mostly so its not so straightforward to install packages as rpms

I am a workstation user and not familiar entirely with the silverblue system so I dont want to lead you down the wrong path, it may be possible to install it with rpm-ostree and layer it into the system although I suspect this particular install method will not work asit requires access to the filesystem directories.

1 Like

To install an RPM on silverblue you need to layer it in.

Have you considered trying an appimage?(It is unofficial)

Hello @liamdev ,
Since this is Silverblue you don’t use yum/dnf/rpm for installing, you must use rpm-ostree for layering packages. Out of curiosity, why not LibreOffice which is included in the main Fedora repos? I think you can use it in flatpak form too so that works well on Silverblue.

Hi Stephen,

Understood. I’ve tried both LibreOffice and OnlyOffice and they’re okay, but given that this would be an “alternative” to Windows, it should have a similar user experience in terms of setting up, and it does not. Selecting time zones and then not recognizing that the file is .csv so asking one to select is really just an indicator that there are likely several other things that the devs didn’t consider as far as UX is concerned, so it’s more avoiding a headache. That said, I want to try this Apache version anyways so this was more of a “how do I solve this problem?” type of question - as I learn more about programming.

Now I’ve started a C++ programming course because i’m clearly getting nowhere with higher level languages - as they don’t make sense, and lower level seems to at least have a clear structure within the definitions and logic of what you’re working with. With that said, now it’s: how do I use VS Code to install the C++ compiler on this immutable desktop? I wish there was someone that just made videos about all of this for Silverblue. There’s no content on YouTube or anywhere else - then just documentation that covers some basic stuff but doesn’t seem like anyone is really taking the charge on showing people how to use this system.

I have not… Looks pretty cool though! Are there any plans for future releases to make installing things on this Silverblue system easier? rpm-ostree seems to fire back quite a few errors and it’s just not very much like dnf or apt. I end up just ding all of this stuff in an Ubuntu VM as a result ha.

Yes, seems like everything goes to “var” so all that to say, I’m confused as to why this wasn’t baked into the dev plans to roll out some type of script so that it’d be a similar experience to WorkStation, just a little bit more going on behind the scenes? IDK. We’ll see what happens when UX is considered a bit more I suppose.

I dont understand, gcc is the c and c++ compiler shipped with silverblue, I think ootb no less. Type g++ at the command line, if bash sees it as a valid command you have it installed and the system knows where.

VSCode is just an IDE not an installer for your system, this is not windows and don’t think it should be windows like. If you like working in windows better than you really should do that.

Fedora Linux is created and maintained by a slew of volunteers, including answering user help questions. The documentation does cover basics up front, but digging will get you more results. Also, there is an implied assumption that the person who decides to switch from a familiar OS to an unfamiliar one is very computer savvy to begin with. So you install things with rpm-ostree on Silverblue, not VSCode.

1 Like

Starting with Silverblue as an alternative to Windows seems like a difficult path unless you are a casual user who can get everything needed from flatpaks.

Silverblue is somewhat new and has a relatively small userbase compared to traditional Linux desktop options.

If you want a system where you can just install anything you want, I am not sure that is what silverblue is for. IMO, silverblue works best when:

  • You are willing to invest the time to learn how to work and think differently
  • You can do most of what you want using flatpaks or working in a toolbox

If not, it is probably better to just use Fedora Workstation than layer in tons and tons of packages.

Silverblue is fundamentally different than a traditional Linux distro. I don’t think it is intended to be a similar experience with different things happening in the background transparently to the user.

An interesting question for me is “Why did you decide to use Silverblue instead of Workstation?”


So the Open Office developers need to build an rpm package it seems. So best consulting with them directly about version releases, sometime there are unofficial rpm builds which technically could work. It is activly developed still (just had a recent release last month) but developer team is much smaller than it used to be as a lot have left for other Apache projects.

I have tested the Apache Open Office and it runs very well on Fedora, (in fact I like it better than my office suite so I removed my office suite). It has predictive text which I havn’t seen on any office suites before.

yup, for whatever reason when I reinstalled Silverblue gcc and g++ were not installed. I did type in that command and it wasn’t recognized in the system. I get that it’s a bunch of volunteers and I was unaware of this when I was gifted a new laptop with the (sort of) requested Linux Distro (at this time, I had no concept of Linux or distributions). I’m absolutely open to this model and I like it but most definitely wasn’t expecting it… I won’t go on about that as at this point, as I do very much appreciate responses and any help that comes my way so thank you for the reply!

Cool - i’m guessing this isn’t Silverblue? As yours above looks like it actually worked haha.

Good question. I had no idea what was going on at first and every time I got to the command line, I just assumed that I had broken the system by installing things that didn’t end up working. I wasn’t expecting to jump into Linux the way I did - and I’m glad I did - but all that to say, I ended up rebooting WorkStation a million times becaause I’d try to download programs in he same way that I’d download them on Mac, hten realize I should probably delete them - then I’d look up how to delete them and realized that all of this stuff is interconnected, so if I delete all of the components of a package that I installed, it could be deleting a dependency for another package. All that to say, opposed to just wiping everything out and starting over, I can just run “rollback” with Silverblue. Seemingly a much more reasonable solution/approach. It’s challenging though - because I literally can’t install anything. I just tried to install 1Password: error: can’t create transaction lock on /usr/share/rpm/.rpm.lock (Read-only file system)
error: key 1 import failed.


so IDK. I guess it’s just not worth it. All in all - for literally anything that I want to do on Linux and have it actually work - I’ve just been using Ubuntu in Gnome Boxes. Again, I’m dealing with Gnome Software with that, and the experience with them is similarly disappointing as time goes on and I see how many things are missing in terms of accommodating a user experience. I’ve tried switching to that distros to Ubuntu before and it went okay, just not as well as I had liked because it seemed like they did have a lot of software/programs that gave up your info. right off the rip. I suppose sticking with Fedora has been more of a typical “stick with the first thing you try” scenario; I carry on ignoring that the “first thing” has just failed me over and over. Ubuntu honestly never does; they consider the UX in every aspect of developing that system. I don’t want to go down this train of thought with interconnected orgs so I’ll just say - I think the immutable desktop is the future; Fedora Silverblue is to my understanding the first, so I bought the ticket and I’m just finding out the ride is not pleasant haha.

So basically, if it’s not a flatpak or an RPM package - I’m unable to install it? Or if I do then I change things about Siverblue making it “not silverblue” for a lack of better terms? Get the 1Password for Linux app

it seems like all instructions come with pretty much any and every type of Linux distro and absolutely nothing works on Silverblue lol.

Yes workstation, I suggest if you want to learn Fedora start with Workstation. Silverblue is fantastic and really interesting, especially if you know what you’re getting into and are willing to learn about how to drive it. I use Fedora as a desktop for writing documents I need straightforward ways to install printers, scanners and other peripherals using rpm packages.

Fedora Silverblue (apart from having the coolest name) is also way more secure and hardened due to the complete separation of the operating system and the software. Silverblue can be compared to Android. It’s packed as immutable image. All apps installed run in a container and can’t change the system… No other linux distro has this ability and eventually Fedora SilverBlue will replace workstation altogether apparently

Well you could do that with rpm-ostree install gcc g++

Predominantly, Silverblue is a paradigm shift from the typical Fedora Linux Workstation user experience. The immutable aspects of it create a sort of bifurcation in peoples perception of how to use it I find. I fell for the “thou shalt only use flatpaks for apps” purist approach early on in my use of it, but in my opinion this is a fallacy to apply the limitation since rpm-ostree was created specifically for the purpose of being able to layer packages when needed. Silverblue definitely is a container oriented work environment, but the biggest advantage I found it had was the stability combined with the rollback feature that gave a stout feeling of confidence in my system.

If you’re wanting a more traditional linux desktop experience then Fedora Linux Workstation is definitely the correct choice since it is an official edition while Silverblue is not (yet).

As for Linux in general, it is much more a hands on OS to use than MS or Mac offerings. Silverblue is more contained OOTB and is a good choice, but as you have found it is relatively new and the howtos are not as visible as the editions. Just don’t be worried about layering things with it. I found most flatpaks worked for what I installed them to do, with a couple of exceptions.

A tip that may be useful for the new Silverblue user: Create a toolbox to use dnf in order to easily search and get info on packages you are interested in.


Really, with silverblue you want to use flatpaks or things that can run in a toolbox. Layering in lots of rpms will leave you with a mess.

Silverblue is a tough choice for someone new to Linux.

  • It works on a different paradigm than most Linux distros
  • The instructions for most things you find won’t work with silverblue, even if they are fedora specific
  • There is very little simple documentation or tutorials on how to use silverblue from the perspective of a typical user

That could probably be layered in but you can’t follow those instructions because those instructions are for workstation.

However 1password is available as a flatpak. You are making your life harder than you need to. It can be easily installed on silverblue:

If you are having better luck with Ubuntu, just use it for now.

Just my opinion, but you are trying to tackle too many learning curves at the same time. Pick the thing that is easiest for you now. You can always switch later once you are more comfortable with how Linux works. If that is Ubuntu then go with that. Ubuntu has a few things going for it:

  • Most of the instructions on how to do things on Linux target Debian/Ubuntu.
  • There is a wealth of documentation and tutorials
  • Almost all software that is available for Linux is available for Ubuntu

It may be an easier path.

Linux Mint and PopOS! are both derivatives of Ubuntu that are more likely to respect your privacy if that is important to you.

There is a program called “timeshift” that can rollback most distros. It isn’t as elegant as what silverblue does but it does the job. It is integrated out of the box with Linux Mint but can be installed with almost any distro.


Awesome insight! Thanks so much, @dalto
I don’t have very much confidence in Flatpaks as I’ve run into problems - specifically with Gnome Boxes. I had all of my production workloads in Gnome Boxes, but wanted to move/upgrade the distros. When i plugged in the old flash drive, I came to find out that Gnome Boxes Flatpak version doesn’t support shared media.
IDK - at this point I’m going to sacrafice privacy and just go back to MacBook + Microsoft Office Suite ha because honestly, the damage that has come of this experience is unthinkable… I just couldn’t let this go for some reason - and persisted to the point where it’s costed me everything. This last bit was really the tipping point - where I’ve just literally got done getting a production site/product up and running, gone through an incredible amount of macro and micro research to map out my total addressable and observable markets, matched the industry details to ZoomInfo, pulled down the contact lists, split them up by industry, exported them as CSV, uploaded them to my CallTools software just to see that LibreOffice turned phone numbers into a god damn formula. If this was managed by someone that did the equivalent of “forking” this entire operating system and raised about 50-100 mil in funding - to basically just remove the engineer from the UX process and replaced with a focus group of non techies + product managers + project management team - then there’s no doubt that this could really take significant market share, even as a “free” operating system. It just comes down to user research, and engineers don’t care to do that type of research and if they do - it’s somehow a burden lol so I’m good on Linux; our information is forever in the hands of Microsoft and Apple.

This will be a cool toy sometime in the remarkably distant future - like retirement (if that exists anymore). That said, you guys are all awesome. I wish I would’ve known more about this stuff before Lenovo sent it shipped as a perceived commercial product. Hope you’re all doing great!