Silverblue first impressions (Silverblue30 22nd june 2019)

The installation is easy enough, it’s just fedora. I did everything as a default install, with the only exception that I encrypted my disk.

I loved how lean the system was on first boot! Some people complain about not having default software, as far as I’m concerned, if I have vi and a package manager, I’m good. Having Firefox as a bonus was all I needed.

Toolbox is great. It about as straight forward as possible to setup.

Things that I thought a bit weird:

Sudo

  • rpm-ostree works without sudo?!?
  • flatpaks install and remove without sudo?!?

Is my sudo somehow borked? I am id=1000, I’m not logged in as root.

Video

I couldn’t get some videos to work in Firefox, i watched Fedora Classroom Getting to Know Silverblue, and saw in the video that the author used a layered package called compat-ffmpeg28, which I installed, and now my videos work as expected.

Grub

Is it somehow possible to name a specific ostree commit? Now I have five times the same name in grub.

Toolbox gives an error the first time I enter a new toolbox

$ toolbox create -c temp             
Created container: temp
Enter with: toolbox enter --container temp
$ toolbox enter -c temp 
toolbox: unable to copy /etc/profile.d/toolbox.sh to container temp

The next time entering works, weird.

Overall, Silverblue is great, some minor papercuts, but nothing that can’t be fixed. Looking forward to using this for the foreseeable future.

This is normal; when you set yourself to be a user with admin privileges in the installer, that means that you’re configured to install via rpm-ostree and flatpak without needing sudo.

2 Likes

Silverblue employs rpm-ostree as you know. It and flatpak both work default at the system level, and you have to specifically use the --user option to limit to only user installation of software. This allows you to have a bit of flexibility with your runtimes for flatpak for instance, if you need something specifically for the user but not the system in general say. You would still need to use the sudo command if you wanted to use some of ostree’s tools at your disposal, as an example of when sudo is needed on Silverblue. Also, the user you setup at install will automatically get added to the wheel group.

2 Likes

This is a recent problem, see bug 1717379.

Thanks! I tried using an updated version of toolbox, but that doesn’t help either.

Reading up a bit more, it already has an assigned github-issue: toolbox: unable to copy /etc/profile.d/toolbox.sh to container #198 and also Bug 1719993 - toolbox appears broken by latest podman update

Also: Don’t use ‘podman cp’ to copy toolbox.sh to old containers #202, so the problem is being looked at.

The bug is minor, issuing the same command again works, so it’s more a paper-cut then anything else. Silverblue is still a work in progress, but, so far, it works for me®

I’ve tried again today and it works.

Note to myself: toolbox -v enter would have printed more information…