Can't install any snaps and Minecraft on Fedora 31 KDE fresh install


Hello, I have installed snapd package with

sudo dnf install snapd

Then I rebooted my pc and typed this command:

sudo snap install snap-store

And I get the following:

Warning: /var/lib/snapd/snap/bin was not found in your $PATH. If you’ve not restarted your session
since you installed snapd, try doing that. Please see How to fix snap binaries not found - snapd -
for more details.

Snap Store from Canonical✓ installed

I couldn’t find snap store on the menus and can’t find it when I search for it so I typed:

sudo snap install hello-world

And got the output:

Warning: /var/lib/snapd/snap/bin was not found in your $PATH. If you’ve not restarted your session
since you installed snapd, try doing that. Please see [It’s the same link, removed due to 2 link limit for new users]
for more details.

hello-world 6.4 from Canonical✓ installed

I thought that the problem was ony in menus, but when i typed hello-world on the command line, nothing happened. It said unknown command: hello-world

I also tried to install Minecraft by following and doing exact copy paste from this tutorial and it also didn’t appear in the menu: How to play Minecraft in Fedora - Fedora Magazine

I also tried logging out and logging in again, rebooting my pc a few times, uninstalling snap-store, snapd and then installing snapd, rebooting, then installing snap-store again.

Also, did a reinstall again and I get this when i try to install anything with snap:
error: too early for operation, device not yet seeded or device model not acknowledged
Just pressed up arrow and enter again and it installed. Then gave me the same error.

-Thanks for any help

Minecraft via Flatpak is on Flathub! If you don’t have the Flatpak package, just run sudo dnf install flatpak and go here and follow the instructions: Flatpak—the future of application distribution

I would suggest you remove the Snap package manager as well. There isn’t much you cannot find on Flathub that is in the Snap store and the infrastructure around Snap is proprietary and controlled by Cannonial. That’s your choice though.


Thanks! I have installed Flathub and it seems really nice. I didn’t remove snapd because there might be someone that want to solve this problem/face this problem in the future. If someone offers a solution, I can try it and mark it as the solution for the community.

I heard that Flatpak programs are in very high size. Are Flatpak packages downloading every dependency with them? I also heard that too. My net connection is a little bit slow and I would not want to re-install every dependency when I install a program, it would eat my disk space and network.

Also, I have searched for it but couldn’t find anything. Is there a GUI that I can download for the Flathub? Can you tell me the basic usage of this program? I downloaded Minecraft, clicked on file and installed via GUI Software Center.

Edit: I have installed Minecraft with Flathub and it is still not in the menu. I tried logging out and logging in again.

-Thanks again!

To fix the problem of Minecraft not being in the menu, you’ll probably have to reboot. Also, I believe the KDE Discover store should let you install from Flathub after the reboot too from what I know. In terms of Flatpak sizes, yes they do contain all of the dependencies of the programs. But this is also the case for Snap packages too.

Hello, reboot didn’t solve the issue

# Is it works this way?
1 Like

No, it didn’t solve the problem

# also if on the same line?
PATH="/var/lib/snapd/snap/bin:${PATH}" snap

I decided to stop using snaps and start using Flatpaks. Thanks for every answer!

1 Like