Can't choose my display or refresh rate on a 2k 240hz laptop monitor

I have a 2k 240 hz laptop monitor but the refresh rate is locked to 60 hz and the resolution is locked as well.

That’s the output when I enter xrandr command:

Screen 0: minimum 16 x 16, current 2560 x 1600, maximum 32767 x 32767
None-1 connected primary 2560x1600+0+0 (normal left inverted right x axis y axis) 677mm x 423mm
   2560x1600     59.99*+
   2048x1536     59.95  
   1920x1440     59.97  
   1600x1200     59.87  
   1440x1080     59.99  
   1400x1050     59.98  
   1280x1024     59.89  
   1280x960      59.94  
   1152x864      59.96  
   1024x768      59.92  
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   1920x1200     59.88  
   1680x1050     59.95  
   1440x900      59.89  
   1280x800      59.81  
   1152x720      59.97  
   960x600       59.63  
   928x580       59.88  
   800x500       59.50  
   768x480       59.90  
   720x480       59.71  
   640x400       59.95  
   320x200       58.96  
   2560x1440     59.96  
   2048x1152     59.90  
   1920x1080     59.96  
   1600x900      59.95  
   1368x768      59.88  
   1280x720      59.86  
   1024x576      59.90  
   864x486       59.92  
   720x400       59.55  
   640x350       59.77  

What’s the solution to this problem ?

Please add the Laptop make/model/GPU so we have a better idea of how to help.

I’ve got an Asus rog g16 zephyrus with RTX 4060 and 240 hz refresh rate monitor

1 Like

Make sure you have your Nvidia drivers installed properly.

lspci | grep NVIDIA

Are you using Gnome? What Fedora release are you on?

There are some other thngs you can do also,

xrandr --output None-1 --mode 2560x1600@240

to set it yourself, but I would be cautious witht that.

I just installed it and rebooted, and I could see 240 hz option in the display so thanks for that !

But I faced another problem that the screen is heavily blinking so I used the reduced mode as mentioned in xrandr doc but got that in the output

omarashour@fedora:~/Downloads$ xrandr --output eDP-1 --mode 2656x1600R X Error of failed request: BadValue (integer parameter out of range for operation) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 21 (RRSetCrtcConfig) Value in failed request: 0x0 Serial number of failed request: 22 Current serial number in output stream: 22
I’ve got fedora 39 dual booted with windows 11, I’m not sure that I’m using GNOME.

Gnome is the Desktop, If you installed Fedora 39 Workstation, you are using Gnome. Here is a screenshot of it.

click on the top bar to bring up the Menus

Clicking the gear wheel will bring up more helpful menu’s on the left bar. Monitor for you Monitors and About for more relevant info.

I have a Lenovo Ideapad, It’s a 144Hz monitor but consistently runs at 120Hz on the desktop. Not really interested in hitt 144Hz outside of edge case games so it’s good enough for me. 240Hz is a ton so hope you have fun with games and videos.

1 Like

The error message you’re getting (“X Error of failed request: BadValue (integer parameter out of range for operation)”) indicates that the xrandr command is trying to set a parameter (likely the refresh rate) that’s outside the range your monitor can support. In your case, it’s trying to set the refresh rate for your eDP-1 output (which is likely your laptop’s built-in display) to “R,” which probably translates to a very high refresh rate not supported by your panel.

Do me a favor and reboot the laptop and go straight to settings afterwards. See if you can set the refresh rate you want.

1 Like

This is the display menu when I rebooted. 240.00 Hz was just added after I installed the driver, but why can’t I see the other options for it ? and for resolution as well.

Does reducing the refresh rate help in solving the screen blinking problem ?

Sorry I just moved from elementary linux to fedora so I can’t figure things out.

That i am not sure, maybe something with using wrong xrandr ? I just checked my setup and it’s basically locked on 120Hz. as a matter of fact, using xrandr command probably set your monitor to 240Hz and it survived the reboot.

set it back to 60Hz, to test. Also, maybe try some other xrandr commands

xrandr --output eDP-1 --mode 2656x1600@120

for 120Hz or :

using ones from the list above


now that you have the driver installed check what it gives back to see what is available.

IMO : do this command with xrandr --output eDP-1 --auto and reboot the machine. This will set it back to normal + now that driver is installed properly and see what options are available.

1 Like

@omarashour here is a Copr repo for Asus ROG laptops to have most tof the features they bring OOTB work. This will be helpful as this will give you ability to set up keyboard features and GPU features as well.

1 Like

Thanks, you’re a life saver!!

Changing xandr model solved the issue, gonna take a look on Copr!

1 Like