Refresh Rate of Monitor

How do I decrease the refresh rate of the monitor… It’s 144hz screen but I want to decrease it to 60hz but the problem is there is no setting for that…
Will GNOME 40 have that setting?
Can you help me decrease or increase the refresh rate of the monitor as the I want it to be…?

1 Like

When I check at my Notebook, Gnomes->Settings->Display->Refresh Rate, I have 60Hz and 40Hz to choose from. While at my Desktop, I only have 60Hz.

I only got these?
Is this going to be addressed in upcoming GNOME 40

I am on Gnome 40 with Fedora 34, and when using my TV via HDMI, I got this:

1 Like

I guess you have a quite new monitor. Maybe try with Fedora 34, as it uses the new kernel and the drivers could be updated. Not sure, but give it a try with liveUSB.

1 Like

I’m not using gnome, so this might not be what you’re looking for, but it should be possible to get the desired refresh-rate by setting the video-mode at boot-time via the kernel cmd-line. Have a look here for some more information.

1 Like

@lapor Please mention the person to whom you are referring this message to…
For me yeah! its new and there is no such setting for setting desired refresh rate of my monitor
I may not be trying Fedora 34 right now(not even with live usb)… Only when it officially releases I guess…
But thanks for the suggestion…
On a side note: there was the setting with live usb in fedora 33 when I tried it months before but as soon as I installed completely I have no such setting right now…
I don’t know what the problem is ?

Sure, I was refering to @superadmin . I see. There were before, but they are gone. I’m sorry but I don’t have the knowledge to help you with this. I hope someone can. Good luck

1 Like

On my Fedora 33, I am able to tweak the refresh rate like @SampsonF . It maybe depends on the monitor you are using…


@lapor You don’t need to be sorry for that… Thanks dude

I might not have the luck… :frowning: Thanks @altons

Have you try to set via kernel parameters?

yeah I tried xrandr
and this was the result… where there were no any option for 60 hz

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
1920x1080 144.00*+
1680x1050 144.00
1280x1024 144.00
1440x900 144.00
1280x800 144.00
1280x720 144.00
1024x768 144.00
800x600 144.00
640x480 144.00
DP-1-0 disconnected (normal left inverted right x axis y axis)
DP-1-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-0 disconnected (normal left inverted right x axis y axis)
DP-1-2 disconnected (normal left inverted right x axis y axis)

Under Gnome, the output of xrandr only shows refresh rate I selected via Gnome Settings->Display.

When I select -

  • 60Hz, xrandr shows 59.xx Hz
  • 40Hz, xrandr shows 39.xx Hz

So xrandr is not reporting my monitors full capability for me.

Following the above article inside sway ,
$ swaymsg -t get_outputs
I also got 60Hz and 40Hz .

I can also think about, if your monitor allows your to set refresh rate manually. Sometimes, in the Monitor’s OnScreen menu, it allows to select different power saving modes, which will default to different refresh rates.

Good luck!

1 Like

Am I the only unluckiest guy who gets

00:00:00.028 [swaymsg/main.c:417] Unable to retrieve socket path

I am using a laptop so this might be the result, isn’t it?

When I run the swaymsg command inside Gnome-shell, I got the same error.

What I have done is:

  1. Boot into text mode, by sudo systemctl set-default then reboot
  2. Logon to the text console
  3. run sway
  4. press “Super+Return” to launch a terminal
  5. inside that terminal, run the above $ swaymsg -t get_outputs command


  • to start GNome in text mode, run sudo systemctl start gdm
  • to switch boot target back to GDM by default, run sudo systemctl set-default

real hardwork :laughing:
I am not trying this out :joy:
I had messed up things in my past… I don’t want to repeat the history

1 Like

For hardware issues, we can always hope for the next kernel update.

The Linux graphical stack is a fast moving area, improvements will keep coming.

@SampsonF I remember using this to get some picky hardware running, but not lately I admit :thinking:

So it could be hardware dependant but should work with DRM-drivers…

For wayland on the other hand using a custom EDID-file might be the way according to Wayland how to set a custom resolution and Forcing modes and EDID.

Since I neither use gnome nor wayland I have no way to test this ATM.

1 Like

Hmm, I might be wrong, but xrandr doesn’t work for wayland - or at least it didn’t. gnome-randr might be an option but I didn’t test it.