Can't boot Windows after installing Fedora — /boot/efi is NTFS


I have a similar problem.
I reinstalled Windows 7 and Fedora 33 having had several problems.
I don’t have Windows 7 available on start.

I tried to apply Twohot’s solution but I’m stuck in the Fedora personnalised disk partition.

I have :

  1. sda1 a ntfs partition of 100 Mo for system informations

  2. sda2 a 450 Go Ntfs partition for my windows

  3. / a 70 Go partition “fedora_localhost-live-root”

  4. sda3 a 600 Mo /boot/efi partition

  5. sda5 a /boot 1024 Mo parition

I tried to set the windows partition (sda2) mount point as /boot/efi but this is already taken for the sda3 and “/boot” is alerady taken by sda5.

I can’t set sda 1 as /boot/efi cause it’s a ntfs partition

What can I do ?

Thanks for your answers.

Hi Julien. I’m going to move this to a new thread, since I think having /boot/efi be on an NTFS partition makes this a different question from

1 Like

Do as you want, but to me it’s not a different question.
My problem is, just as was the problem in the first thread, that, after having installed Fedora 33 with a USB drive, I now have no possibility to start my Windows and this is why I’ve posted in this thread.

The fact that I can’t mount my NTFS partition as /boot/efi is just relevant to the fact that I can’t apply what seems to be the answer provided by Twohot and therefor can’t solve the problem of the thread.

Yeah, that’s why I think a new question is best. That question has an answer which will apply to many other people (which is good and it’ll be helpful for people to find it quickly) but you have a special case that needs to be addressed differently.

1 Like

So the fix is to set /dev/sda3 (already efi) to mount at /boot/efi and continue with /dev/sda5 as /boot and so on.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.