Can't boot windows after installing Fedora34

Hi, after searching the web for a little while, I came to the conclusion that I needed specific help to solve my issue, as I’ve seen in other post, this seems to be a recurring issue, I installed fedora via the usb key and now my windows boot is borked, while my bios is set to UEFI.


[liveuser@localhost-live ~]$ sudo efibootmgr 
BootCurrent: 0015
Timeout: 1 seconds
BootOrder: 0015,0006,0013,0000,0002,0011,0001,0005,0003,0014
Boot0000  Pop!_OS 20.04 LTS
Boot0001  Windows Boot Manager
Boot0002  manjaro
Boot0003  Hard Drive
Boot0005  Network Card
Boot0006* Fedora
Boot0011  ubuntu
Boot0013* UEFI OS
Boot0014  USB KEY
Boot0015* UEFI: Generic Flash Disk 8.07, Partition 1

I’m not very sure why there is so much of them, most of them are old installs that are not there anymore


sda           8:0    0 465.8G  0 disk
├─sda1        8:1    0   600M  0 part 
├─sda2        8:2    0     1G  0 part 
└─sda3        8:3    0 464.2G  0 part 
sdb           8:16   0 931.5G  0 disk 
└─sdb1        8:17   0 931.5G  0 part 
sdc           8:32   0 111.8G  0 disk 
└─sdc1        8:33   0 111.8G  0 part /run/media/liveuser/2F1F68470DDBAE04

sda is Fedora, and sdc is supposed to be Windows.

Let me know if you need more infos, any help appreciated…

At the windows partition should be an asterisk (*) in order to boot.

Have you tried to activate the windows boot option?

Probably something like
sudo efibootmgr -a 0001
should work.

Please try the following:

  1. From UEFI setup, please choose to boot Windows Directly. In this way, as long as the UEFI partition is working, it should be without involving any bootloaders installed by Fedora.

Some OS Installation will put files into UEFI partition, thus UEFI knows there are bootable shims of efi binaries. Once you are sure they are no longer needed, you can carefully remove those entries. (Do a backup, just in case you need to restore the content)

  1. Once confirmed Windows can boot via UEFI settings or boot menu, we can double confirm that Fedora can book normally. What bootloader you are using in Fedora? If you are using grub2, you can use grub2-mkconfig to have grub2 to auto-detect the Windows installation and create grub boot entries for Windows.

  2. lsblk -f will show partition type and fs information also. It will provide more details for bootloader troubleshooting.

1 Like

Sorry, this was wrong.
sudo efibootmgr -b 1 -a

-b is followed by the boot number in hexadecimal.
In your case the Windows Boot Manager is boot-number 1, or 0001, if you want so.

This actually reactivates the UEFI-Boot-Entry, not Grubs Boot Entry.
If you hit F11 or F12 to see the boot device list at startup, depending on the mainboard, you should now be able to select the windows boot manager.