After install of F32 from USB - can't boot UEFI Windows 10

So, I blindly installed F32 from USB expecting a dual boot option to automatically appear at power-up. I have Windows 10 with UEFI (I think). The only partitioning I did, all during install from USB, was reduce the size of the W10 data partition and create new a fedora partition, sda7. Now I can’t seem to boot W10. When I power on, the computer goes straight to the fedora logins screen. I would think this is an easy fix but the topics I looked at don’t seem to apply to me given

  1. My original boot partition created by W10, sda1, is not mounted
  2. I have no option in BIOS to select a boot file.
    1. After mounting sda1 to /temp/hoho I suspect the boot file is /temp/hoho/EFI/Boot/bootx64.efi
  3. I did
    %sudo dnf reinstall grub2-efi grub2-efi-modules shim
    and also
    %sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
  4. The file /boot/efi/EFI/fedora/grub.cfg exists for me.
  5. % efibootmgr
    EFI variables are not supported on this system.

I decided to post this topic when another thread said to create a new sda1 partition. I really don’t want to irreversibly damage my W10 - if I haven’t already. Any help would be greatly appreciated. I don’t mind nuking my F32 install as long as I can get my W10 back. Thanks in advance.

Welcome to the Fedora Community @grep4splat,

Don’t be afraid. Your Win10 should still be okay. We only need to figure out why the boot loader is not seeing it. Can you share the output of the following from your Fedora?:

sudo lsblk

This is comforting. Thanks.
In my OP I said I mounted sda1. I just did umount to bring it back to what it is after power on. The sda1 appears to be the original boot partition, I don’t know what sda2 is, sda3 is a recovery partition, sda4 is the W10 data partition that I shrunk by a little under 200GB to free room for F32, and sda5/6/7 were created by the F32 install.

sda 8:0 0 931.5G 0 disk
├─sda1 8:1 0 100M 0 part
├─sda2 8:2 0 16M 0 part
├─sda3 8:3 0 500M 0 part
├─sda4 8:4 0 746.3G 0 part
├─sda5 8:5 0 1M 0 part
├─sda6 8:6 0 1G 0 part /boot
└─sda7 8:7 0 183.6G 0 part
├─fedora_localhost–live-root 253:0 0 70G 0 lvm /
├─fedora_localhost–live-swap 253:1 0 7.9G 0 lvm [SWAP]
└─fedora_localhost–live-home 253:2 0 105.8G 0 lvm /home

Seems you installed in Legacy Mode over a UEFI enabled System
To be sure, please share:

sudo blkid

also do:
sudo mkdir /mnt/drive
sudo mount /dev/sda4 /mnt/drive
sudo ls -lh /mnt/drive

What do you see?

You can share the output by sending the resulting URL from the next command:
sudo ls -lh /mnt/drive/ | fpaste

Further more, how many partitions were you seeing after booting into Windows in the past?

This is actually starting to be fun! I hope you are having fun too!
%sudo blkid
/dev/sda1: LABEL=“SYSTEM” UUID=“461B-D156” BLOCK_SIZE=“512” TYPE=“vfat” PARTLABEL=“EFI system partition” PARTUUID=“147addcb-cb84-473b-8d15-772fa0a4a2f5”
/dev/sda2: PARTLABEL=“Microsoft reserved partition” PARTUUID=“caa5ebd0-ccd7-4ba7-a8eb-78d044b7cedf”
/dev/sda3: LABEL=“Recovery” BLOCK_SIZE=“512” UUID=“469E1C239E1C0E55” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“d21075da-8711-4f55-b535-f27ea6519d34”
/dev/sda4: LABEL=“Windows” BLOCK_SIZE=“512” UUID=“78062EF6062EB4D2” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“07c195e6-1e41-4f7b-8a96-c27c73b4e6e5”
/dev/sda5: PARTUUID=“a9ea5fb7-c945-40c4-9b20-3d25d3c4a215”
/dev/sda6: UUID=“72e00e0c-4b48-45a7-9a15-80e2268ba834” BLOCK_SIZE=“4096” TYPE=“ext4” PARTUUID=“fb85ec35-91b2-41b1-b95b-2c59f7b3c73a”
/dev/sda7: UUID=“hgFwlf-aDq9-bOuY-lg5b-1e8d-NVnr-IXZhc8” TYPE=“LVM2_member” PARTUUID=“f80d3463-eb71-4f76-a8c2-3cfc43f496e8”
/dev/mapper/fedora_localhost–live-root: UUID=“dc2b0e89-1b8f-45a1-9501-6dfb76743714” BLOCK_SIZE=“4096” TYPE=“ext4”
/dev/mapper/fedora_localhost–live-swap: UUID=“ea6c926a-aa4b-49cf-b604-5ebbbe914fc2” TYPE=“swap”
/dev/mapper/fedora_localhost–live-home: UUID=“cd5ae2b5-c759-4d75-99ab-f692654163f9” BLOCK_SIZE=“4096” TYPE=“ext4”

%sudo mkdir /mnt/drive
%sudo mount /dev/sda4 /mnt/drive
Windows is hibernated, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)

%sudo ls -lh /mnt/drive
total 19G
drwxrwxrwx. 1 root root 4.0K May 12 18:34 ‘$Recycle.Bin’
drwxrwxrwx. 1 root root 0 Jan 2 22:29 Capture
drwxrwxrwx. 1 root root 4.0K Jun 9 12:28 Config.Msi
lrwxrwxrwx. 2 root root 16 Nov 6 2018 ‘Documents and Settings’ → /mnt/drive/Users

%sudo ls -lh /mnt/drive/ | fpaste
Uploading (1.8KiB)…

The first time I looked at Windows partitions was when I started the F32 installation. If I remember correctly sda1/2/3/4 were the same as after (except, of course, for the shrink of sda4) the intstall but I am not 100% sure about that.

1 Like

For readability;
%sudo blkid | fpaste
Uploading (1.5KiB)…

1 Like

Your outputs support the hypothesis (quoted). So you need to reinstall Fedora (don’t worry about Windows, its safe in there waiting). Whatever you do, make sure you do not format sda1, sda2, sda3 and sda4. DON’T … those partitions affect Windows and how your system boots.

  1. Go to BIOS and make sure your PC boots in UEFI mode first.
  2. Insert a Fedora installation media (CD/DVD/USB) and boot in UEFI mode
  3. Choose sda drive in the Graphical Installation environment (Anaconda) – usually the first drive
  4. You may want to use blivet for configuring the partitions
  5. Delete partitions sda5, sda6, and sda7 (assuming you have not saved anything in your previous Fedora installation)
  6. Repartition as follows = sda5 (1Gb), sda6 (whatever is left)
  7. Set mount point for sda1 to /boot/efiDO NOT FORMAT THIS PARTITION – Only set the mount point
  8. Set mount point for sda5 to /boot
  9. You can split sda6 the way you did before (LVM).
  10. Accept the partitioning scheme and confirm that the installer does not complain about any missing/required mount points.
  11. Run the installation

If everything goes well … you should see a GRUB when you reboot the system. You should be able to select Windows or Fedora there.

How did it go?


Well, twohot, that worked perfectly! Thank you so much. So, really, the only mistake I made was selecting the wrong boot device when I modified my BIOS to boot from the Fedora thumb drive. Selecting the UEFI USB to re-install from gave me the dual boot Grub menu and Windows works fine too.

1 Like

Awesome! Don’t forget to tick the post that solved the question. That makes it easier for others with similar issues to find it (i.e. search)

before installing the system make sure the previous boot entry has been removed from the bios

2 posts were split to a new topic: Can’t boot Windows after installing Fedora — /boot/efi is NTFS

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.