Cannot use/format partitioned USB after trying to install distro

I’m a new Linux user and have been using Fedora 40 on my laptop for some time. Due to some issues, I tried to install PopOS. I used the Fedora Media Writer to flash PopOS on my USB. The boot installation failed and my USB remains partitioned (see image) and could not be formatted using different methods like this: After using USB to install Fedora 33, can't reformat the USB

I would like to format the USB to be able to use it again.

1 Like

What method are you trying to use to format it and what error message are you receiving?

2 Likes

In almost every case that is not hardware failure the device can be repartitioned with almost any of the partition mangers such as gdisk, fdisk, parted, gparted, and more.

I note from the image that you may be trying to alter the iso image which is immutable, but the device can have that partition table wiped and start new. Simply use something like gdisk and create a new partition table so the device is empty and start over.

1 Like

Mediawriter should be able to do that if you insert the USB device and start mediawriter.

It appears that windows won’t do it, whereas if you already have linux installed, it is no problem.

1 Like

I first used the Disk application to format. It throws an error.

I also tried using Mediawriter to restore the USB. It wouldn’t complete and the USB would simply unmount.

I tried using Disks as well. It wouldn’t work.

I also tried Gparted. It stops working and asks me to ‘Wait’ or ‘Force Quit’ indefinitely.

I tried using Mediawriter to restore the USB. It wouldn’t complete and the USB would simply unmount.

Your screen capture has partition one (POP OS …) mounted. You need to click on the small square box to unmount the partition before you can do operations that would remove the partition.

2 Likes

I tried that. It throws the same error.

I also tried creating a new partition table. It says ‘error during read/write’.

This is most likely a failed USB key.

1 Like

Is it impossible to revive it? It’s a new USB and I don’t want to lose it.

I also tried the mkfs command. Didn’t work either.

Was it a no-brand cheap one or a well-known brand unit?

1 Like

It is not a brand unit. I got it from my university after graduating (32 GB).

Even brand-name USB keys sometimes fail. Reliability engineering has the concept of “bathtub” curve for failure rates: failure rates for new gizmos are high, then drop during the “useful life” and increase as devices age out.

1 Like

Hi
Have you tried using other software to format the partition? Like balena Etcher or rufus.

1 Like

Yes I tried both of them. The USB disk simply disappears.

Hello @annih ,
How did you first set it up to install Fedora? You could try using dd to write all zeros to it. Then reformat it after using parted.

Welcome to Fedora @annih

Have you checked the device on a other OS?
Have you checked a other USB slot?