Cannot fractional scale \ change resolution of external display


I’ve just installed Fedora 38 (trying to migrate from Windows to do my daily work :slight_smile: ). I have a setup with 3 displays:

  • Laptop built-in
  • Dell 27" 4K60Hz - connected with HDMI
  • HP 23" 1080p60Hz - connected through dock on thunderbolt (monitor —DisplayPort—> dock station — USB-C ----> TB port of my Latitude laptop)

My problem is obviously scalling 4k monitor. 200% is too much - I’ve tried enabling fractional scalling but then I’m unable to change settings for my 4k monitor:

The same error occurs if I try to change resolution of that monitor (to lower).

Perfectly I would like to set 4k scalling to 125% - but if it will be possible to change resolution - that would also do the trick :slight_smile:

I’ve also found out that if I change scale of my main display - it changes for all displays. That’s expected behavior (what I doubt) or should I report it as a bug?

Thanks you in advance for your answers!

I’m having the same problem on one of my monitors. My other 3 (2 27" 4k screens and one laptop screen) work fine. It’s just my main monitor that will only take a single scaling option. It also happens to be a Dell monitor though it’s a 43" 4k monitor.

This is a bug in the Display Settings panel, which should be fixed in F39.

It happens when trying to change the geometry of a middle monitor when you have three or more. As a workaround, you can temporarily rearrange the monitors so that the one you want to change is on the outside.

1 Like

Thanks. I’ve got 39 in a VM right now to test it for regular use so I’ll see about that testing and then update once I upgrade in a week or so.