Fedora 38 - cannot enable fractional scaling

Dear All,

having a hdpi framework laptop, I used to enable fractional scaling with the following command:

gsettings set org.gnome.mutter experimental-features “[‘scale-monitor-framebuffer’]”

to be able to activate 125% and 150% in screen settings.
However, after updating to fedora 38, this doesn’t seem to work anymore.
Can you recommend a workaround or another solution?
Thanks, 2bfrank

This should work. I use 200% scaling on my laptop and just tried it out, it worked immediately, I can choose scaling in steps of 25%.

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

You can try disabling and enabling again. Run this do disable the setting:
gsettings set org.gnome.mutter experimental-features "[]"

Dear Kevin, thanks a lot ! It actually works in Gnome.
I had installed the Budgie desktop, and strangely it doesn’t work there (beyond 100 or 200%), although it is based on the Gnome desktop as far as I know…

The same at LXQt

I try
LXQt Session Settings → Global Screen Scaling

Scale factor up to 1.99 no impact to font size. Fonts are tiny.
at 2.0 fonts suddenly become huge.

I have the same issue on the newest Fedora 38 with 4k monitor.
Also installed Nvidia drivers not sure if this might play a role.
I need ideas on how to debug this.
GNOME Shell 44.5

Is this the type of visual glitches that you received?

AMD FW 13 Display issues