Upgraded from 38 to 39: Scaling explodes after login

Hello, I am new here. Sorry for immediately asking a question instead of helping others first…

But I have a problem I don’t know really how to solve it.
For work I use a Dell Precision 7530 workstation with Intel HD graphics. I have happily run Fedora 37 and 38 (normal Gnome edition) since I switched from Ubuntu a while back. This afternoon I upgraded my work laptop to Fedora 39 (Gnome version, via the Software window) after testing it on my personal desktop first.

The upgrade went fine, the login screen works fine. But after logging in the scaling explodes to a 1000% or more and I can’t do anything. I have seen this behavior before when I tried to enable fractional scaling using gsettings set org.gnome.mutter experimental-features "[ 'scale-monitor-framebuffer' ]" in Fedora 38 on the same laptop. I had to switch to a tty terminal to disable it again (gsettings set org.gnome.mutter experimental-features "[]") and logging out and back in and everything worked fine again.

I have been reading that fractional scaling was enabled by default on Fedora 39 so I tried disabling it with gsettings set org.gnome.mutter experimental-features "[]" again, but no effect. Then I read a bit further and I noticed that this patch is actually postponed to Fedora 40.

So I am a bit at loss here and don’t know what to look for now (or what data to present to you)
I tried logging in after disabling/enabling/resetting/disabling fractional scaling with all of the following commands in different orders and I do see the change when I get the values again:

gsettings set org.gnome.mutter experimental-features "[]"
gsettings set org.gnome.mutter experimental-features "[ 'scale-monitor-framebuffer' ]"
gsettings set org.gnome.mutter experimental-features "[]"
gsettings reset org.gnome.mutter experimental-features

So it might not be related to fractional-scaling after all. Do you have any idea where I can look?

The first screenshot shows a big mouse pointer and parts of the welcome screen. The second screenshot is when I press Esc and right click on the desktop.

You can remove ~/.config/monitors.xml to reset scaling. I’m not sure how that could do this, but it’s worth trying.

Are you using a custom shell theme? You can also try gsettings set org.gnome.shell disable-user-extensions true

Thanks a lot for your comment. Sounds like good tips. I tried them both separately followed by a reboot but no luck so far. I use a default shell theme.

I forgot to mention that logging in via Wayland or Xorg makes no difference as well.

I’d guess some kind of driver issue if the login screen weren’t working. Assuming you’re using the default GDM, that session is also using GNOME Shell.

Can you try a fresh user account?

1 Like

Thanks again, sounds like a good idea as well. I will try first thing tomorrow, and report here

So I created a new user account and everything works fine when I log in with this new account. This is a step in the right direction. Now I am looking for the config to reset this scaling in my own user account. If nothing works I can always use the new user. Thanks for you help, I really appreciate it.

1 Like

I managed to restore my settings with dconf reset -f /org/gnome/ so everything works again with my normal account, except that I have to reset (keyboard) shortcuts and stuff, but that’s fine. Thanks again, you really saved me here.