Can’t Install OS| Intel | Kernel Bug | Fedora 40

@jandemus @glb @gnwiii @hamrheadcorvette

Good day All. First of all I would like to take a minute to thank you all for your unwavering help.

I have news, I borrowed another LGA socket1151 mother board, the only thing I changed out was the motherboard. The processor, RAM, GPU and HDD were all the same.

I loaded fedora cinnamon, and the install went smoothly, as usual…

I have since gone out and purchased and AMD5 board and processor with RAM DDR5, same HDD, same GPU… Install and restart… Again, flawless…

The verdict is then that the Asus STRIX GL12CX Mother boards ARE NOT Linux capable…

For those wanting to try and run a Linux or Ubuntu kernel on this make of motherboard should please not waste your time as I did, you will most likely NOT be able to run the kernel on more then 3 cores of your processor or at the worst one…

Even with the aid of these wonderful fellows on this group I was not able to get around the myriad of plaguing problems I was experiencing, I do hope you heed my warning…

Again thank you gentlemen each and every one of you for your help, undoubtedly you will hear from me again as I am now loading and will soon be daily driving Fedora cinnamon and, might be in need of some more of your assistance…

Thank you all, To those wanting to venture forward with this, please do read on…

Wishing you the best…

Good day all, new to the forum.

I have tried to install fedora, it is not going well, I have come from windows, I have tried different HDD’s as well and I have disabled secure boot, when met with the boot menu after the first restart because there is no reboot as claimed I can selected the first or second options from the boot menu and both exhibit the same behaviour… The screen just stays where it is and does not go any further.

See picture please.
Any help please?

Edit: after using the fedora media creation tool my system does not even show that screen, it is now just blank and my keyboard and mouse are dead, zero sytem response. When going back into the boot menu I find two fedora boot partitions, deleting one or the other bring back the same above behaviour…

Device name DESKTOP-4O4KU13
Processor Intel(R) Core™ i7-9700K CPU @ 3.60GHz 3.60 GHz
Installed RAM 32.0 GB
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display
Asus Geforce RTX2060 GPU
Asus Strix GL12CX Mobo


Hi, and welcome to the Fedora forum.

When I understand what you wrote then you installed Fedora and after the installation there was no reboot. It looks like you have installed Fedora from within a “Live version”. That is a version which runs, like an installed version, but not from hard disk but from a USB stick.

When you started and booted the computer from your USB stick, did you enter a screen with an item placed on it which said something like: Install Fedora?
If so, then at the end of the installation, when you leave the installer, you return to the “Live version” on the USB. You then have to manually reboot. I see in your picture you have chosen the Workstation Edition which uses the Gnome desktop. If I’m not wrong in the top-right corner of your screen you see several icons, of which one is to restart, switch off, log off and maybe some other choices.
I wanted to say, use that button but that won’t help you right now cause the computer doesn’t boot now.

Instead, hold down the power button of the computer for at least 5 seconds and the computer will be switched off the hard way. Just keep the button pressed till the picture is gone from the screen and the on light, when present, is off.

Wait 5 seconds and switch on the computer AFTER having removed the USB stick. Remember what you see and write it here so forum users can read it and hopefully help you. Tip, film the boot sequence from screen so it is easier to write it down in the correct order.

It sounds like some sort of hardware compatibility problem. If you can edit that boot menu entry and remove the rhgb and quiet parameters, you might see some error message that would hint at what device Fedora Linux is having difficulty initializing.

See here for instructions on editing the boot menu entry.

Hi and thank you for your response JandeMus. Am I supposed to use something else as an OS? Yes I install via the live session. There is a window that comes up and allows me to install from there, I choose a language, then a disc and delete everything on it, the install runs, and completes, I then manually reboot and unplug the usb stick, once the system restarts that screen is what I am met with.

There is nothing else that happens. My keyboard is dead and so is my mouse, there is no further activity on my screen.

Hi Gregory, thank you for your comment, I have done as you have suggested, once removed and f10 is pressed a screen comes up saying “booting a command list” the cursor is underneth that line not flashing and no further activity happens.

That sounds like the problem is occurring before the kernel is even loaded. There might be some problem with the GRUB bootloader or there might be files missing from your /boot partition. I don’t know what else would cause that.

Can GRUB access your /boot partition? If you press c to go to GRUB’s command line, can you then run ls and browse the filesystems on your hard drive(s)?

P.S. I’ve got errands to run and I don’t expect to be back online for several hours. Hopefully someone else will be able to help in the meanwhile. :slightly_smiling_face:

1 Like

Hello Gregory,.

Thank you, understood.

I am new to the linux world so do not know what I am doing.

I have done as you have asked.

Typing ls brings up the following:

(memdisk)  (proc)  (hd0)  (hd0gpt3)  (hd0gpt2)  (hd0gpt1) 

There is a second boot option with a * preceeding it and something about rescue. Selecting it and typing e brings up some stuff. But, I have no idea what it means.

I will attach foto’s.

Although the installation seems to have run fine, would you mind doing it again? And I mean start all the way from the beginning:
download the iso file again, if possible to a checksum test to know the download went okay,
place the file on disk, reboot with the USB stick connected and make sure you boot from it.
If the Workstation version does the same as the KDE version you get to see a start menu where the top item says install, the second however wants you to perform another test, this time the written iso file on the USB stick. After the test ended without error the install will begin automatically.
Hopefully this time the system does boot.

Hi JandeMus.

I actually did think about this, and, I have done so 3 times already. I tried installing ubuntu during December of 2023… I think that the motherboard is causing issues. With 22.04 LTS it would install right through and reboot, then, once rebooting it would bring up the boot menu and once selected, the screen would go blank and nothing further would happen. If choosing safe mode from Ubuntu I could boot into the system.

I spent 3 weeks on various ubuntu forums with countless hours of videos and could not get it running.
I have an I7 9700K with more than enough ram, I am using ssd’s the whole nine yards so. Linux / ubuntu based systems should not have issues, but they do… I can only think this is mother board related. I have the updates for the bios as new as possible. So, I do not know what else to do…

Okay, this is new information.
I went searching for a combination of your motherboard and Linux and a lot of distro’s don’t seem to work. Then I found this website:
I didn’t read it but I would advise you to do it and to follow the way Fedora is installed.

Success and keep us informed please.

Hi JandeMus, thank you, I will only be able to do this by Friday my time, but will read and follow and revert back. Thank you for your efforts.


1 Like

If the problem is just the graphics card, you might be able to work around the problem by adding nomodeset to the list of kernel parameters.

Good day Gregory,

Where would I add this? I am a noob and so have no idea as to what you are referring to add that to where.

As I explained to JandeMus I had the exact same issue last December trying to load Ubuntu 22.04. Countless hours spent on forums and tried watching yt videos to try and learn something.

Sorry, it must be super easy to do but I have no clue what I am doing as linux is new to me.

Anyway, I will only be able to try all this tomorrow afternoon my time when I am home again, I have a very long day today that will only se me returning home late tonight.


You would need to use the method described here: Working with the GRUB 2 Boot Loader :: Fedora Docs

Hi Gregory,

Thank you for the link I will go and read up so long.


Hi Gregory,

So, I tried nomodeset and also removed rhgb quiet when I press f10 it just gives me the same Booting a command list with the stable cursor, my keyboard lights and mouse lights go out and no further activity takes place.


I expect GRUB would say if the problem were that it couldn’t find the kernel to load it. So don’t really think that is the problem. (Though I’m also not sure what GRUB would do in that case.)

Maybe it could be something like a corrupt filesystem. I’m not sure.

If your numlock key won’t toggle the LED on your keyboard, that is a pretty good indication that the system is truly “hung” or locked-up.

What’s strange though is that the kernel worked well enough for you to install the OS. I think the initial installation will use the same kernel that was used when booting from the installation media. So how could the kernel work with your hardware when loaded from your installation media, but not when loaded from your hard disk drive? This one has me confused.

Maybe the kernel is loading but something is going wrong in the initramfs stage. A new/different initramfs is generated for the installed system.

How about trying this – in addition to removing rhgb and quiet, add rd.debug. That might print some additional trace information to the console, but only if the problem is occurring in the initramfs stage, after the kernel has loaded and initialized the hardware.

Another thing you might try would be to disable ports, wifi-cards, bluetooth, built-in network adapters, etc. via your PC’s BIOS/firmware and see if that allows the system to boot.

I’ve never had to use it personally, but there is also a earlyprintk=efi (assuming your system is EFI, use earlyprintk=vga instead if your system is booting in legacy BOIS mode). You can try adding earlyprintk=efi to the list of kernel parameters and see if that yields any additional output (again, remove the rhgb and quiet parameters because those are designed to conceal the error messages).

Hope that helps. Without any sort of error message, I don’t know what else to suggest.

P.S. Try adding ignore_loglevel in addition to earlyprintk=efi to try to get the kernel to make even more noise about what it is doing when the system fails.

Have you tried booting your system with the rescue kernel (i.e., press enter instead of e when it is highlighted)?

You might also want to try booting the rescue kernel with nomodeset if you haven’t already.

Hi Gregory.

I have tried all of the above. All I am getting on both the boot menu items is Booting a command list the stable _ and that is it, I have tried all options in both those menu boot items… There is no specific setting on this damned mobo to select uefi or legacy,… The only options are fastboot and secure boot that I can disable…


I’m not sure I understand this statement from your original post. Did you delete a partition?