Blank Gray Screen on boot

I installed a fresh version of Fedora 36 a couple weeks ago, and at some point my installation has stopped working. Now, when I try to boot into Fedora, I am met with a blank gray screen instead of a login page:

I can’t find a way to login or anything. I was able to get to a console by pressing Ctrl + Alt + F3, and from there I was able to run sudo dnf update which didn’t seem to fix the problem.

I also am unable to get my live Fedora USB to work. I can boot into the live environment, but I am stuck on the desktop without any access to apps:

I believe Fedora was working fine a few weeks ago. I’m also dual-booting Windows 11 on the same drive, and Windows is working fine.

What happens if you unplug and replug in the monitor when it’s in that state?

Which kernel version are you on? (uname -a )

I’ve got a similar issue but it appears to be fine in 5.17.12 but broken in 5.18.

I tried unplugging and replugging in my monitor(s), but that didn’t seem to change anything.

I’m on 5.17.13-300. I think I was on 5.17.5-300 before I ran sudo dnf update earlier, and I was still getting the issue then.

So I believe there is a way to boot into lower graphics mode to troubleshoot the graphics card/driver but I am having a hard time finding that resource online right now.
Hopefully someone else smarter than me will pipe in and assist.

1 Like

If you press shift during reboot and select an older kernel from the grub2 menu does it work correctly?

Can you post inxi -Fzx


I selected 5.17.5-300 and it doesn’t work on this kernel either.

inxi -Fzx:

  Kernel: 5.17.13-300.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc v: 2.37-27.fc36
    Console: tty 3 Distro: Fedora release 36 (Thirty Six)
  Type: Desktop System: Gigabyte product: A320M-S2H v: N/A serial: <superuser required>
  Mobo: Gigabyte model: A320M-S2H-CF v: x.x serial: <superuser required>
    UEFI: American Megatrends v: F53 date: 01/05/2021
  Info: 6-core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ rev: 2 cache: L1: 576 KiB
    L2: 3 MiB L3: 16 MiB
  Speed (MHz): avg: 2057 high: 3898 min/max: 1550/3400 boost: enabled cores: 1: 1564 2: 3898
    3: 1564 4: 1272 5: 1272 6: 2793 7: 1551 8: 3882 9: 1555 10: 1269 11: 1275 12: 2796
    bogomips: 81443
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: Micro-Star MSI
    driver: amdgpu v: kernel bus-ID: 08:00.0
  Device-2: Focusrite-Novation Scarlett 2i2 Camera type: USB driver: snd-usb-audio
    bus-ID: 1-5:3
  Display: server: v: 1.20.14 with: Xwayland v: 22.1.2 driver: gpu: amdgpu
    note:  X driver n/a - try sudo/root tty: 240x67 resolution: 1: 1920x1080 2: 1920x1080
    3: 2880x1440
  Message: GL data unavailable in console. Try -G --display
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 08:00.1
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
    bus-ID: 0a:00.3
  Device-3: Focusrite-Novation Scarlett 2i2 Camera type: USB driver: snd-usb-audio
    bus-ID: 1-5:3
  Device-4: Realtek USB Audio type: USB driver: hid-generic,snd-usb-audio,usbhid
    bus-ID: 3-2.2:4
  Sound Server-1: ALSA v: k5.17.13-300.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169
    v: kernel port: f000 bus-ID: 07:00.0
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: TP-Link UB500 Adapter type: USB driver: btusb v: 0.8 bus-ID: 1-9:4
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 3.38 TiB used: 1.36 TiB (40.3%)
  ID-1: /dev/nvme0n1 vendor: Mushkin model: MKNSSDPE500GB-D8 size: 465.76 GiB temp: 36.9 C
  ID-2: /dev/sda vendor: Western Digital model: WD20EZRX-00D8PB0 size: 1.82 TiB temp: 34 C
  ID-3: /dev/sdb vendor: A-Data model: SU650 size: 894.25 GiB temp: 40 C
  ID-4: /dev/sdc type: USB vendor: Generic model: STORAGE size: 239.08 GiB
  ID-1: / size: 227.18 GiB used: 11.6 GiB (5.1%) fs: ext4 dev: /dev/nvme0n1p6
  ID-2: /boot/efi size: 1022 MiB used: 13.9 MiB (1.4%) fs: vfat dev: /dev/nvme0n1p5
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 16.8 C mobo: N/A gpu: amdgpu temp: 50.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1866
  Processes: 301 Uptime: 8m Memory: 15.53 GiB used: 1.1 GiB (7.1%) Init: systemd runlevel: 5
  Compilers: gcc: 12.1.1 Packages: 12 note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.14


Are you using a second monitor?

After a fresh reboot please post:
journalctl -rxb

Can you try restarting gdm.
systemctl restart gdm.service

Well, it looks like I’ve found a “solution” for my problem. I’ve had my Windows Mixed Reality headset plugged in (I’m dual-booting Windows for this), and I guess Fedora didn’t like that. When I unplug the headset, it seems to work fine. This isn’t ideal behavior, but I guess it is OK for now. Do you know where I might be able to report this bug/issue?

Anyway, here is the reply I was originally going to write before I found a solution:

Yes, I have two monitors and a VR headset plugged in.

Here’s journalctl -rxb: journalctl.txt · GitHub

Restarting gdm just brings me back to the gray screen.

Thanks for assisting me with this issue!

1 Like

You may want to have a look at Login Screen on wrong monitor - #4 by nightromantic