Fedora 38 Workstation - Blank gray screen instead of GRUB after manufacturers logo

Hello at the begining i’m sorry for my bad english. I’m not native speaker, but i try my best. Few days ago i installed Fedora 38 Workstation dualboot with Windows 10 (i still need it if i want to play games without problems). Each system has it’s own drive. Problem is that everyday when i try to start my PC, after manufacturer bios logo I get blank gray screen. I must force shutdown PC with button and turn it on again and it works perfectly fine. I’ve searched this problem on the internet and found few posts with simmilar problem but didn’t found solution. I’m newbie in linux world but very intrested in this system so i would appreciate every bit of help. If u need any more information to help me, i will try to answer you the best i can

My specs:

Motherboard: ASRock B450M Pro4-F

CPU: AMD Ryzen 3600

GPU: NVIDIA GeForce GTX 1650 Super


OTHER SSD’s for windows

Hello Ted and welcome to ask :fedora:

One thing that is known to interfere with booting fedora when dual booting is that some users have windows with ‘fast boot’ enabled. If this is your situation then please turn off ‘fast boot’ within windows. Always do a full shutdown of windows so it does not interfere with booting fedora.

If that works then let us know. If not then after a failed boot followed by a successful boot please post the output of inxi -Fzxx and journalctl -b -1 so we may see what else the system may tell us to assist in triage and repair.

Formatting as seen on the screen for both those may be retained by using the preformatted text tags with the </> button on the toolbar.

Result of inxi -Fzxx:

  Kernel: 6.4.12-200.fc38.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.39-9.fc38 Desktop: GNOME v: 44.4 tk: GTK v: 3.24.38 wm: gnome-shell
    dm: GDM Distro: Fedora release 38 (Thirty Eight)
  Type: Desktop Mobo: ASRock model: B450M Pro4-F serial: <superuser required>
    UEFI: American Megatrends v: P1.60 date: 08/01/2019
  Info: 6-core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2
    rev: 0 cache: L1: 384 KiB L2: 3 MiB L3: 32 MiB
  Speed (MHz): avg: 2777 high: 4120 min/max: 2200/4208 boost: enabled cores:
    1: 2057 2: 2200 3: 3865 4: 2194 5: 2200 6: 3826 7: 2200 8: 2200 9: 4068
    10: 2200 11: 2200 12: 4120 bogomips: 86239
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] vendor: Gigabyte
    driver: nvidia v: 535.98 arch: Turing pcie: speed: 2.5 GT/s lanes: 16 ports:
    active: none off: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 07:00.0
    chip-ID: 10de:2187
  Device-2: Trust Full HD Webcam driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 1-6:7 chip-ID: 145f:02aa
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: gnome-shell driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,nouveau,vesa alternate: nv
    gpu: nvidia,nvidia-nvswitch display-ID: :1 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96
  Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled
    model: LG (GoldStar) ULTRAGEAR res: 2560x1440 dpi: 93 diag: 800mm (31.5")
  API: OpenGL v: 4.6.0 NVIDIA 535.98 renderer: NVIDIA GeForce GTX 1650
    SUPER/PCIe/SSE2 direct-render: Yes
  Device-1: NVIDIA TU116 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 07:00.1 chip-ID: 10de:1aeb
  Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
    bus-ID: 09:00.4 chip-ID: 1022:1487
  Device-3: Trust Full HD Webcam driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 1-6:7 chip-ID: 145f:02aa
  Device-4: AOKEO LCS_USB_Audio driver: snd-usb-audio type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 5-3:3 chip-ID: 2e3c:4444
  API: ALSA v: k6.4.12-200.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.78 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 1.6 TiB used: 10.98 GiB (0.7%)
  ID-1: /dev/nvme0n1 vendor: Kingston model: SA2000M8500G size: 465.76 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 26.9 C
  ID-2: /dev/sda vendor: SanDisk model: SSDPR-CX400-01T-G2 size: 953.87 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-3: /dev/sdb vendor: Silicon Power model: SPCC Solid State Disk
    size: 223.57 GiB speed: 6.0 Gb/s serial: <filter>
  ID-1: / size: 221.98 GiB used: 10.67 GiB (4.8%) fs: btrfs dev: /dev/sdb3
  ID-2: /boot size: 973.4 MiB used: 292.3 MiB (30.0%) fs: ext4
    dev: /dev/sdb2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/sdb1
  ID-4: /home size: 221.98 GiB used: 10.67 GiB (4.8%) fs: btrfs
    dev: /dev/sdb3
  ID-1: swap-1 type: zram size: 7.66 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 64.6 C mobo: N/A gpu: nvidia temp: 41 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 61%
  Processes: 705 Uptime: 2m Memory: total: 8 GiB available: 7.66 GiB
  used: 1.86 GiB (24.2%) Init: systemd v: 253 target: graphical (5)
  default: graphical Compilers: gcc: 13.2.1 Packages: pm: rpm pkgs: N/A
  note: see --rpm pm: flatpak pkgs: 10 Shell: Bash v: 5.2.15
  running-in: gnome-terminal inxi: 3.3.29

And the result of journalctl -b -1:

sie 27 11:26:10 fedora kernel: Linux version 6.4.12-200.fc38.x86_64 (mockbuild@>
sie 27 11:26:10 fedora kernel: Command line: BOOT_IMAGE=(hd1,gpt2)/vmlinuz-6.4.>
sie 27 11:26:10 fedora kernel: BIOS-provided physical RAM map:
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x0000000000000000-0x00000000000>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x00000000000a0000-0x00000000000>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x0000000000100000-0x0000000009d>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x0000000009d02000-0x0000000009f>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x000000000a000000-0x000000000a1>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x000000000a200000-0x000000000a2>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x000000000a20c000-0x000000000af>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x000000000b000000-0x000000000b0>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x000000000b020000-0x00000000db0>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x00000000db055000-0x00000000dc5>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x00000000dc551000-0x00000000dc5>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x00000000dc5ce000-0x00000000dcb>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x00000000dcb21000-0x00000000dd8>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x00000000dd857000-0x00000000def>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x00000000df000000-0x00000000dff>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x00000000f8000000-0x00000000fbf>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x00000000fd000000-0x00000000fff>
sie 27 11:26:10 fedora kernel: BIOS-e820: [mem 0x0000000100000000-0x000000021f3>
sie 27 11:26:10 fedora kernel: The simpledrm driver will not be probed
sie 27 11:26:10 fedora kernel: The simpledrm driver will not be probed

Also after dusabling fast boot in windows. Bios manufacturer screen lasts very long and fedora loading screen also is really longer with smaller screen resolution

Thanks for the info.
I erred when I asked for journalctl -b -1 as I forgot about the automatic paging.
Please repeat that with journalctl -b -1 | tail -300 > logfile then send the content of that file (logfile) so we may see that full content. Whatever is causing the gray screen may show up in that log segment.

It’s logfile: sie 27 19:18:26 fedora systemd[1962]: pipewire.service: Consumed 1.995s CPU time - Pastebin.com

I had to put it on pastebin couse here is lenght of text limit

That part looks like a normal shutdown. Was it run from a successful boot immediately following a failed boot?

Yes, but i discovered new thing today. If i enter into boot menu at first boot and choose boot partition manually then it also runs successful.

Bios boot menu or grub boot menu?

Bios boot menu

So booting is ok, but the grub boot is failing.

Try doing this.
sudo dnf reinstall grub2-*
followed by
sudo grub2-mkconfig -o /boot/grub2/grub.cfg

Also run dnf list installed \*nvidia\* and if the package nvidia-gpu-firmware is not there then add in the command sudo dnf install nvidia-gpu-firmware. There was just today another user that was missing that firmware package and the system would occasionally not properly boot.

A reboot should be performed after all those commands are completed.

OK i will tell toy tommorow if it works

Ok i tried and still the same thing. Is there a chance that it’s drive fault or something like that? Previously i had ubuntu but bootloader was installed on Windows partition and everything was fine

If you are able to boot properly from bios then I doubt drive issues. A failing drive would appear always, not just with one boot method and not another. This seems an issue with the boot loader not properly configured, or a graphics driver config issue.

When booted, what is the output of efibootmgr and cat /proc/cmdline?

When attempting to boot, does the grub boot menu appear? If so it may be possible to manually edit the options passed to the kernel during boot and find out what is causing this behavior.

I will give outputs of those commands when i’m back from work, but answering second question, yes grub menu is loading but as i said, after reboot from 1 failed boot or when i select boot drive manually

Okay output of efibootmgr:

BootCurrent: 000D
Timeout: 1 seconds
BootOrder: 000D,0000,0004,0005,0006,0007,0008,000C,0001,0002
Boot0000* Windows Boot Manager	HD(1,GPT,1f59dfc8-a602-4b8e-8ec5-f7cbd1f97ac4,0x800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000061000100000010000000040000007fff0400
Boot0001  Pop!_OS 20.10	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0002* Pop!_OS 20.10	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0004* Hard Drive	BBS(HD,,0x0)0000474f00004e4fb10000000100000073004b0049004e004700530054004f004e0020005300410032003000300030004d003800350030003000470000000501090002000000007fff040002010c00d041030a0000000001010600010101010600000003171000010000000026b76839028fa57fff040001043600ef47642dc93ba041ac194d51d01b4ce6350030003000320036004200370036003800330039003000320038004600410000007fff04000000424f00004e4fad000000010000007500530053004400500052002d00430058003400300030002d003000310054002d004700320000000501090002000000007fff040002010c00d041030a0000000001010600030101010600010003120a000000ffff00007fff040001043e00ef47642dc93ba041ac194d51d01b4ce65a00470031004500330033003000370020003800200020002000200020002000200020002000200000007fff04000000424f00004e4fb30000000100000075005300500043004300200053006f006c006900640020005300740061007400650020004400690073006b0000000501090002000000007fff040002010c00d041030a0000000001010600030101010600010003120a000400ffff00007fff040001043e00ef47642dc93ba041ac194d51d01b4ce64500440046003300370030003700340035003100360043003000300036003600310034003400380000007fff04000000424f
Boot0005* UEFI: HTTP IP4 Realtek PCIe GBE Family Controller	PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x2)/Pci(0x1,0x0)/Pci(0x0,0x0)/MAC(a8a159083cf5,0)/IPv4(,0,0)/Uri()0000424f
Boot0006* UEFI: PXE IP4 Realtek PCIe GBE Family Controller	PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x2)/Pci(0x1,0x0)/Pci(0x0,0x0)/MAC(a8a159083cf5,0)/IPv4(,0,0)0000424f
Boot0007* UEFI: HTTP IP6 Realtek PCIe GBE Family Controller	PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x2)/Pci(0x1,0x0)/Pci(0x0,0x0)/MAC(a8a159083cf5,0)/IPv6([::]:<->[::]:,0,0)/Uri()0000424f
Boot0008* UEFI: PXE IP6 Realtek PCIe GBE Family Controller	PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x2)/Pci(0x1,0x0)/Pci(0x0,0x0)/MAC(a8a159083cf5,0)/IPv6([::]:<->[::]:,0,0)0000424f
Boot000C  Fedora	HD(1,GPT,cb17dcb9-379f-49ad-86c8-f8253b6d4414,0x800,0x12c000)/File(\EFI\FEDORA\SHIMX64.EFI)
Boot000D* Fedora	HD(1,GPT,cb17dcb9-379f-49ad-86c8-f8253b6d4414,0x800,0x12c000)/File(\EFI\FEDORA\SHIM.EFI)0000424f

and cat /proc/cmdline:

BOOT_IMAGE=(hd1,gpt2)/vmlinuz-6.4.12-200.fc38.x86_64 root=UUID=78c9dcf1-d623-40db-be36-36d023210db8 ro rootflags=subvol=root rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1