Fedora 36 Black Screen

When I boot my new Fedora 36 install, I get a black screen after GRUB starts the booting process. I had this the last time I booted, but I could press enter then put in my password and it logged me in and it worked from there. This time I tried the same thing, but even after login it’s the same issue. None of the TTY consoles display either. I booted to an older kernel release and it works (though it does not have the proprietary nvidia drivers loaded), but there were no system updates or anything. Any ideas on how I can fix this? Honestly I blame the nvidia driver but I don’t even know how to uninstall that

1 Like

This seems like a knee jerk reaction to automatically assign blame to the video driver without any specific details that point that way.

I don’t even understand if you are using the nvidia driver with fedora 36 or not. I also do not see whether you have done a system-upgrade from 35 to 36 or if this is a clean install.

If this is after doing a system-upgrade from 35 to 36, and you have this problem after the upgrade, then I must also ask if you have done a full system upgrade after getting 36 to boot. (sudo dnf upgrade)

I also must ask if you followed all the steps here when doing the upgrade, including the anticipated resolution of all problems before you even start the upgrade.

Your comment about having the same problem with the last boot before the upgrade makes me wonder if this is a new problem or if it is carried over from the earlier version.

Sorry, I meant to include that. It’s a clean install and I’m using the nvidia proprietary drivers from RPMFusion (I did make sure to use the fc36 version of the repo)

That clarifies things a bit.

Welcome to :fedora: BTW :+1:

If I am understanding things right, you are able to boot but get a black screen. Then pressing enter gets you to a text login.

If this is correct and you are able to log in then additional info will be needed.

  1. have you done sudo dnf upgrade in the last 24 hours? If not then please do so and reboot before continuing.
  2. This is fedora 36 which is still in beta testing so some things are not yet ready for release.
  3. Can you please provide the following (inside the </> Preformatted text tags seen on the bar at the top of the edit window) inxi -Fzx, dnf list installed \*nvidia* and dmesg | grep -iE 'secure|nvidia' The dmesg output should be immediately after a reboot so we can see the results from the start of the boot.

I’ll do that, but I want to make sure that it’s fine if I use the older kernel version that DOES boot. It reverts to nouveau.

Let me clarify real quick: I am able to boot to a black screen. I can login, but there is no display still. I can just press enter and put in the password but there is no display at all for it, as if GDM is running but there’s no picture. None of the TTY terminals work. I just have no display at all. Based on how my displays go to sleep and wake, it seems that it does login but there’s still no display after login. I’m really operating blind. I booted into the second kernel boot entry and ran those commands.

Output from inxi -Fzx:

  12Kernel 5.17.0-0.rc7.116.fc36.x86_64 12arch x86_64 12bits 64 12compiler gcc 12v 2.37-24.fc36
    12Desktop GNOME 12v 42.0 12Distro Fedora release 36 (Thirty Six)
  12Type Desktop 12Mobo ASUSTeK 12model PRIME B450M-A 12v Rev X.0x 12serial <superuser required>
    12UEFI American Megatrends 12v 3211 12date 08/10/2021
  12Info 6-core 12model AMD Ryzen 5 2600X 12bits 64 12type MT MCP 12arch Zen+ 12rev 2 12cache 12L1 576 KiB
    12L2 3 MiB 12L3 16 MiB
  12Speed (MHz) 12avg 3949 12high 4000 12min/max 2200/4000 12boost disabled 12cores 121 4000 122 3999 123 3999
    124 3995 125 3915 126 3978 127 3999 128 3992 129 4000 1210 3999 1211 3560 1212 3956 12bogomips 95993
  12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  12Device-1 NVIDIA TU104 [GeForce RTX 2060] 12vendor eVga.com. 12driver nouveau 12v kernel 12bus-ID 09:00.0
  12Device-2 Logitech Webcam C270 12type USB 12driver snd-usb-audio,uvcvideo 12bus-ID 5-2.2.2:9
  12Display wayland 12server X.Org 12v 12with Xwayland 12v 22.1.1 12compositor gnome-shell 12driver 12X
    12loaded nvidia 12gpu nouveau 12resolution 121 1920x1080~60Hz 122 1920x1080~60Hz
  12OpenGL 12renderer NV164 12v 4.3 Mesa 22.0.1 12direct render Yes
  12Device-1 NVIDIA TU104 HD Audio 12vendor eVga.com. 12driver snd_hda_intel 12v kernel 12bus-ID 09:00.1
  12Device-2 AMD Family 17h HD Audio 12vendor ASUSTeK 12driver snd_hda_intel 12v kernel 12bus-ID 0b:00.3
  12Device-3 Apple USB-C to 3.5mm Headphone Jack Adapter 12type USB
    12driver hid-generic,snd-usb-audio,usbhid 12bus-ID 5-1:2
  12Device-4 Blue Microphones Yeti Stereo Microphone 12type USB
    12driver hid-generic,snd-usb-audio,usbhid 12bus-ID 5-2.1:4
  12Device-5 Logitech Webcam C270 12type USB 12driver snd-usb-audio,uvcvideo 12bus-ID 5-2.2.2:9
  12Sound Server-1 ALSA 12v k5.17.0-0.rc7.116.fc36.x86_64 12running yes
  12Sound Server-2 PipeWire 12v 0.3.49 12running yes
  12Device-1 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 12vendor ASUSTeK PRIME B450M-A
    12driver r8169 12v kernel 12port f000 12bus-ID 08:00.0
  12IF enp8s0 12state up 12speed 1000 Mbps 12duplex full 12mac <filter>
  12Device-1 Realtek Bluetooth Radio 12type USB 12driver btusb 12v 0.8 12bus-ID 5-2.2.1:7
  12Report rfkill 12ID hci0 12rfk-id 0 12state up 12address see --recommends
  12Local Storage 12total 2.43 TiB 12used 12.35 GiB (0.5%)
  12ID-1 /dev/nvme0n1 12vendor Intel 12model SSDPEKNW010T8 12size 953.87 GiB 12temp 39.9 C
  12ID-2 /dev/sda 12vendor Western Digital 12model WDS500G2B0B-00YS70 12size 465.76 GiB
  12ID-3 /dev/sdb 12vendor Western Digital 12model WD1003FZEX-00MK2A0 12size 931.51 GiB
  12ID-4 /dev/sdc 12type USB 12vendor Patriot 12model N/A 12size 14.78 GiB
  12ID-5 /dev/sdd 12type USB 12vendor Generic 12model STORAGE DEVICE 12size 119.08 GiB
  12ID-1 / 12size 431 GiB 12used 4.78 GiB (1.1%) 12fs btrfs 12dev /dev/nvme0n1p5
  12ID-2 /boot 12size 973.4 MiB 12used 187.4 MiB (19.3%) 12fs ext4 12dev /dev/nvme0n1p4
  12ID-3 /boot/efi 12size 598.8 MiB 12used 13.9 MiB (2.3%) 12fs vfat 12dev /dev/nvme0n1p3
  12ID-4 /home 12size 431 GiB 12used 4.78 GiB (1.1%) 12fs btrfs 12dev /dev/nvme0n1p5
  12ID-1 swap-1 12type partition 12size 9 GiB 12used 0 KiB (0.0%) 12dev /dev/nvme0n1p6
  12ID-2 swap-2 12type zram 12size 8 GiB 12used 0 KiB (0.0%) 12dev /dev/zram0
  12System Temperatures 12cpu N/A 12mobo N/A 12gpu nouveau 12temp 31.0 C
  12Fan Speeds (RPM) N/A 12gpu nouveau 12fan 1300
  12Processes 713 12Uptime 0m 12Memory 15.6 GiB 12used 1.53 GiB (9.8%) 12Init systemd 12runlevel 5 12Compilers
  12gcc 12.0.1 12Packages N/A 12note see --pkg 12Client Unknown Client: pk-command-not-found 12inxi 3.3.14

Output from dnf list installed \*nvidia*:

Installed Packages
akmod-nvidia-470xx.x86_64                 3:470.103.01-2.fc36 @rpmfusion-nonfree
                                          3:470.103.01-2.fc36 @@commandline     
nvidia-persistenced.x86_64                3:510.60.02-1.fc36  @rpmfusion-nonfree
nvidia-settings-470xx.x86_64              3:470.103.01-2.fc36 @rpmfusion-nonfree
xorg-x11-drv-nvidia-470xx.x86_64          3:470.103.01-3.fc36 @rpmfusion-nonfree
xorg-x11-drv-nvidia-470xx-cuda.x86_64     3:470.103.01-3.fc36 @rpmfusion-nonfree
                                          3:470.103.01-3.fc36 @rpmfusion-nonfree
xorg-x11-drv-nvidia-470xx-kmodsrc.x86_64  3:470.103.01-3.fc36 @rpmfusion-nonfree
xorg-x11-drv-nvidia-470xx-libs.x86_64     3:470.103.01-3.fc36 @rpmfusion-nonfree

Output from dmesg | grep -iE 'secure|nvidia':

[    0.000000] Command line: BOOT_IMAGE=(hd5,gpt4)/vmlinuz-5.17.0-0.rc7.116.fc36.x86_64 root=UUID=a75dd261-c10d-47de-a0de-0e8075f92d2d ro rootflags=subvol=root00 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 resume=UUID=ba55feb3-4a2c-4f00-8de3-5657796744ef rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 nvidia-drm.modeset=1
[    0.000000] secureboot: Secure boot disabled
[    0.005765] secureboot: Secure boot disabled
[    0.072222] Kernel command line: BOOT_IMAGE=(hd5,gpt4)/vmlinuz-5.17.0-0.rc7.116.fc36.x86_64 root=UUID=a75dd261-c10d-47de-a0de-0e8075f92d2d ro rootflags=subvol=root00 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 resume=UUID=ba55feb3-4a2c-4f00-8de3-5657796744ef rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 nvidia-drm.modeset=1
[    5.072815] nvidia-gpu 0000:09:00.3: enabling device (0000 -> 0002)
[    5.230135] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.1/0000:09:00.1/sound/card0/input14
[    5.308889] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.1/0000:09:00.1/sound/card0/input15
[    5.308944] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.1/0000:09:00.1/sound/card0/input16
[    5.462538] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:03.1/0000:09:00.1/sound/card0/input17
[    5.486679] input: HDA NVidia HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:03.1/0000:09:00.1/sound/card0/input18
[    5.526688] input: HDA NVidia HDMI/DP,pcm=11 as /devices/pci0000:00/0000:00:03.1/0000:09:00.1/sound/card0/input19
[    5.964690] nouveau 0000:09:00.0: NVIDIA TU104 (164000a1)
[    6.357458] nvidia-gpu 0000:09:00.3: i2c timeout error e0000000

Hope this helps

Please post the output as </> Preformatted text!

Sorry, I meant to do that but I used the wrong formatting. Fixed it.

1 Like

Ah, I think I may see part of the problem.

  1. You have the nvidia 470xx driver installed
  2. You have an nvidia GeForce RTX 2060 GPU which works well with the newest 510 driver.
  3. You are running fedora 36 which by default uses wayland for the desktop (not supported by the 470 drivers).
  4. The system has installed nvidia-persistenced 510 but all the other nvidia packages are still at the 470xx version.

I cannot guarantee that is the issue but the newest kernel for fedora 36 may have issues with the 470xx nvidia drivers since they do NOT support wayland and the default for fedora 36 is wayland. The default for fedora 35 was (I believe) xorg so the issue did not show up there by default (at least not for me).

While booted to the older kernel, I suggest you do these steps to upgrade the nvidia drivers and it is likely the problem will be solved.

  1. sudo dnf remove \*nvidia* (you want everything related to be removed) Make a note of what is removed so that if step 3 does not reinstall something you can do it yourself.
  2. Edit /etc/default/grub and remove all from the kernel command line there that contains rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
  3. reboot (which should succeed with the nouveau drivers and should give you back a functioning screen)
  4. sudo dnf install akmod-nvidia*510*
  5. reboot (which should activate the newer nvidia driver and allow wayland to function)

The action in step 2 will handle existing duplication in the kernel command line.



I’ve read through this and a few other threads as well. Unfortunately, I’ve run into the blank screen issue as well.

  • some time ago I’ve did a clean install of F35 and then I’ve installed akmod-nvidla – everything worked,
  • yesterday I performed an upgrade (via gnome-software) to the F36 and the issue has appeared,
  • I’ve tried reinstalling nvidia drivers – no success,
  • I have all nvidia packages from version 510 – no mix here.

Selecting an older kernel (from F35) in GRUB starts the system in the software rendering mode, selecting the F36’s kernel leaves me with a black screen instead of GDM.

My configuration is Ryzen 9 5900HX + RTX 3070.

What else can I do in order to look into or solve the problem? If more diagnostic data is needed, please instruct me what and how should I get it, as I’m new to Fedora. Thank you in advance!

1 Like

I am also running into the same issue.
GDM is running, but not visible. I can enter my password blind and then come into a perfectly normal user session.
I’m also using the Nvidia driver for a gtx 730.
This is an upgraded Fedora, but I made sure to have the correct version of the modules. This is also verified by checking nvidia-settings in the user session.

This is not actually the case for me – I cannot do such a blind login. Also, pressing enter won’t get me into the console log-in, so I can do exactly nothing once the screen gets blank.\

It seems like the screen is not only just “black” but turned off including no backlight. Of course brightness keys won’t reveal anything.

Something is definitely not booted, as during the next boot I see the GRUB menu as if the system failed to start.

— merged posts —

OK, it seems that I was wrong. Or something has changed, as I was sure I tried to blind login and I couldn’t – or sudo dnf update made some change here.

Anyway: now I can blind-login what allows me to use the computer with the external monitor. However, the laptop screen’s backlight is off and cannot be changed, so I see nothing on it.

— reply to below, as I cannot add more posts in the thread —

I’ve installed the drivers by installing akmod-nvidia before and I have Secure Boot off anyway.

I’m having the same problem using the proprietary Nvidia driver from the negativo17 repo and using X11 exclusively. SDDM doesn’t start, instead I get a black screen (but there is a signal to the monitor, I can see the backlight).

In my case I found out that:

  • booting with 5.17.6-300.fc36.x86_64 doesn’t work
  • booting with 5.17.6-200.fc35.x86_64 works

in both cases the Nvidia driver is 510.68.02.

Looking around for logs I found the following line in /var/log/Xorg.0.log when booting with 5.17.6-300.fc36.x86_64:

[    24.206] (EE) [drm] Failed to open DRM device for (null): -22

This line doesn’t exist when booting with 5.17.6-200.fc35.x86_64 so I’m assuming it’s related, however I couldn’t find any information on this error yet.


I had the same issue. Solved it by installing the akmod-nvidia driver and disabling secure boot.

Most of the issues I see with F36 and nvidia is directly related to wayland DE. When using xorg I have no problems.

1 Like

I finally resolved my problem but the solution might not apply to others.

After some debugging and diffing logs between Xorg starting with the old Fedora 35 kernel and the new Fedora 36 kernel, I noticed these differences:

  • when starting with the Fedora 36 kernel, Xorg sees 2 DRI cards:
[   480.124] (II) xfree86: Adding drm device (/dev/dri/card1)
[   480.176] (II) xfree86: Adding drm device (/dev/dri/card0)

Since I got the following error:

[   480.409] (EE) [drm] Failed to open DRM device for (null): -22

I was thinking the two are related and somehow Xorg uses the wrong device, but had no idea why.

After some more diffing of the kernel logs between the old Fedora 35 kernel and the new Fedora 36 kernel I saw this:

  • old Fedora 35 kernel:
kernel: efifb: probing for efifb
kernel: efifb: framebuffer at 0xd0000000, using 3072k, total 3072k
kernel: efifb: mode is 1024x768x32, linelength=4096, pages=1
kernel: efifb: scrolling: redraw
kernel: efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0
kernel: Console: switching to colour frame buffer device 128x48
kernel: fb0: EFI VGA frame buffer device
  • new Fedora 36 kernel:
kernel: [drm] Initialized simpledrm 1.0.0 20200625 for simple-framebuffer.0 on minor 0
kernel: Console: switching to colour frame buffer device 128x48
kernel: simple-framebuffer simple-framebuffer.0: [drm] fb0: simpledrmdrmfb frame buffer device

Next I looked around to see if I could somehow disable simpledrm but that’s not possible, however while searching I found out that nvidia-kmod from rpmfusion has a patch for this exact problem (disable simpledrm for the nvidia driver to work).

In my case I wasn’t using the rpmfusion package, I was using the negativo17 package which apparently doesn’t include this patch.
So in the end I resolved my issue by using the rpmfusion package instead.

This is why I was saying it may not apply to others: if you use rpmfusion you shouldn’t have this problem as far as I can tell.

1 Like

In my case I wasn’t using the rpmfusion package, I was using the negativo17 package which apparently doesn’t include this patch.

Well, I’m using the RPM Fusion version, so that won’t apply.

Actually, the problem is very strange and annoying. After every kernel update things break and login screen is not displayed at all, even at the fully dimmed screen. Switching between dGPU only and hybrid mode and back may randomly make it work again, but I cannot find any rule.

Until the next kernel update, which breaks thinks again.

Maybe this forum post here is of help. There are updates to the Kernel and Rpmfusion packages to address issues with Nvidia.


Thank you. I’ve just noticed, that there are updates available for the nvidia driver and akmods package and installed them via terminal instead of Gnome Software + restart.

It seems to fix the problem for now even without the modeset workaround mentioned in the post. I’m not yet entirely optimistic though, let’s see if it still works after the next kernel update.

I noticed the problem resolves itself for the particular kernel, it will continue working with this kernel. Therefore, even if the newer kernel won’t work, I’ll be able to select the older one in GRUB.

It’s not a proper solution, but at least a fallback one for now.

I have exactly the same issue as described here:

But for me the display comes back after logging in.

To my mind, this issue doesn’t seem to be connected to nvidia driver versions, as described here:

Output from dnf list installed \*nvidia*

Installed Packages
akmod-nvidia.x86_64                                                 3:510.68.02-2.fc36                            @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-5.18.7-200.fc36.x86_64.x86_64                           3:510.68.02-2.fc36                            @@commandline                   
kmod-nvidia-latest-dkms.x86_64                                      3:515.48.07-1.fc35                            @cuda-fedora35-x86_64           
nvidia-driver.x86_64                                                3:515.48.07-1.fc35                            @cuda-fedora35-x86_64           
nvidia-driver-NVML.x86_64                                           3:515.48.07-1.fc35                            @cuda-fedora35-x86_64           
nvidia-driver-NvFBCOpenGL.x86_64                                    3:515.48.07-1.fc35                            @cuda-fedora35-x86_64           
nvidia-driver-cuda-libs.x86_64                                      3:515.48.07-1.fc35                            @cuda-fedora35-x86_64           
nvidia-driver-devel.x86_64                                          3:515.48.07-1.fc35                            @cuda-fedora35-x86_64           
nvidia-driver-libs.x86_64                                           3:515.48.07-1.fc35                            @cuda-fedora35-x86_64           
nvidia-kmod-common.noarch                                           3:515.48.07-1.fc35                            @cuda-fedora35-x86_64           
nvidia-libXNVCtrl.x86_64                                            3:515.48.07-1.fc35                            @cuda-fedora35-x86_64           
nvidia-libXNVCtrl-devel.x86_64                                      3:515.48.07-1.fc35                            @cuda-fedora35-x86_64           
xorg-x11-drv-nvidia-kmodsrc.x86_64                                  3:510.68.02-2.fc36                            @rpmfusion-nonfree-nvidia-driver

Output from inxi -Fzx:

  Kernel: 5.18.7-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: GNOME v: 42.2
    Distro: Fedora release 36 (Thirty Six)
  Type: Desktop System: Gigabyte product: Z390 I AORUS PRO WIFI v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: Z390 I AORUS PRO WIFI-CF v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F7
    date: 10/15/2019
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    charge: 55% (should be ignored) status: discharging
  Info: 6-core model: Intel Core i7-8700K bits: 64 type: MT MCP
    arch: Coffee Lake rev: A cache: L1: 384 KiB L2: 1.5 MiB L3: 12 MiB
  Speed (MHz): avg: 4600 high: 4603 min/max: 800/4700 cores: 1: 4601
    2: 4601 3: 4601 4: 4601 5: 4601 6: 4600 7: 4600 8: 4602 9: 4600 10: 4600
    11: 4601 12: 4603 bogomips: 88796
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: Micro-Star MSI
    driver: nvidia v: 515.48.07 arch: Pascal bus-ID: 01:00.0
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.2 driver: X:
    loaded: modesetting,nouveau,nvidia unloaded: fbdev,vesa gpu: nvidia
    resolution: 1: 3840x2160~60Hz 2: 1920x1080~60Hz 3: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2
    v: 4.6.0 NVIDIA 515.48.07 direct render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel
    v: kernel bus-ID: 1-7:3 bus-ID: 00:1f.3
  Device-2: NVIDIA GP104 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Device-3: DCMT USB Condenser Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-4: Kingston HyperX Cloud Stinger S type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-8.2:12
  Sound Server-1: ALSA v: k5.18.7-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3
  IF: wlo1 state: up mac: <filter>
  Device-2: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6
  IF: eno2 state: down mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-14:7
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0
    bus-ID: 00:17.0
  Local Storage: total: 1.91 TiB used: 94.04 GiB (4.8%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB
    size: 465.76 GiB temp: 40.9 C
  ID-2: /dev/sda vendor: Kingston model: SA400S37120G size: 111.79 GiB
  ID-3: /dev/sdb vendor: Kingston model: SA400S37480G size: 447.13 GiB
  ID-4: /dev/sdc vendor: Western Digital model: WD10EZEX-08WN4A0
    size: 931.51 GiB
  ID-1: / size: 445.54 GiB used: 93.78 GiB (21.0%) fs: btrfs dev: /dev/sdb3
  ID-2: /boot size: 973.4 MiB used: 248.7 MiB (25.5%) fs: ext4
    dev: /dev/sdb2
  ID-3: /boot/efi size: 598.8 MiB used: 14 MiB (2.3%) fs: vfat
    dev: /dev/sdb1
  ID-4: /home size: 445.54 GiB used: 93.78 GiB (21.0%) fs: btrfs
    dev: /dev/sdb3
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 45.0 C pch: 55.0 C mobo: 38.0 C
  Fan Speeds (RPM): N/A
  Processes: 332 Uptime: 23m Memory: 15.46 GiB used: 3.2 GiB (20.7%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.1.1 Packages: 8
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.

Output from dmesg | grep -iE 'secure|nvidia'

[    0.000000] secureboot: Secure boot disabled
[    0.006043] secureboot: Secure boot disabled
[   10.037861] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input20
[   10.037930] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input21
[   10.037996] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input22
[   10.038044] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input23
[   10.038108] input: HDA NVidia HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input24
[   10.038145] input: HDA NVidia HDMI/DP,pcm=11 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input25
[   10.038189] input: HDA NVidia HDMI/DP,pcm=12 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input26
[   10.610364] nvidia: loading out-of-tree module taints kernel.
[   10.610370] nvidia: module license 'NVIDIA' taints kernel.
[   10.615463] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[   10.626339] nvidia-nvlink: Nvlink Core is being initialized, major device number 509
[   10.626948] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem
[   10.833936] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  515.48.07  Fri May 27 03:26:43 UTC 2022
[   10.877986] nvidia_uvm: module uses symbols from proprietary module nvidia, inheriting taint.
[   10.885274] nvidia-uvm: Loaded the UVM driver, major device number 507.
[   10.918651] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  515.48.07  Fri May 27 03:18:00 UTC 2022
[   10.921718] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[   10.921720] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 1

I’ve noticed that this issue is quite common for any distros, and some managed to solve it adding 2 second timeout before running GDM, as described here, but none of those solutions worked for me. Have anyone found any solutions to this problem?