Fedora 36 Black Screen

I’ve managed to solve my problem with NVIDIA KMS using RPM Fusion as described here.

I’ve entered the following command:
sudo grubby --update-kernel=ALL --args='nvidia-drm.modeset=1'

1 Like

I had that problem with an HP Envy with a 4GB nvidia mx250. If you are using F36 Cinnamon and install the Nvidia drivers from RPMFusion in a laptop with Intel/Nvidia graphics cards, you will likely end up with a black screen. However, if you have set your nvidia as the primary in the /etc/X11/xorg.conf.d/nvidia.conf file the black screen displays but, you can still login blindly and get to the desktop. This worked for me with nvidia 470.141.03 from RPMFusion.

Section “OutputClass”
Identifier “nvidia”
MatchDriver “nvidia-drm”
Driver “nvidia”
Option “AllowEmptyInitialConfiguration”
Option “SLI” “Auto”
Option “BaseMosaic” “on”
Option “PrimaryGPU” “yes”

Section “ServerLayout”
Identifier “layout”
Option “AllowNVIDIAGPUScreens”

Section “Monitor”
Identifier “Screen 0”
Option “Ignore” “true”
Option “Enable” “false”

Section “Screen”
Identifier “nvidia”
Device “nvidia”
# Uncomment this line if your computer has no display devices connected to
# the NVIDIA GPU. Leave it commented if you have display devices
# connected to the NVIDIA GPU that you would like to use.
# Option “UseDisplayDevice” “none”
Option “AllowEmptyInitialConfiguration”


Lightdm (the default login screen for Cinnamon) is not initializing the Nvidia card.
Type in your password on the blank screen and you should be greeted with your desktop.

Open a terminal and edit the following file (use sudo): /etc/lightdm/lightdm.conf

Under [Seat:*]Find the following line: #display-setup-script= and uncomment it by removing the #.

Add “xrandr --output eDP-1-1 --mode 1920x1080” after the equal sign (without the quotes).

Adjust for your screen size.

I used:
display-setup-script=xrandr --output eDP-1-1 --mode 1920x1080



Your login should be operational again.

Sorry if this thread is not the right place for me to ask a follow-up to this. I’ll open a new one if that’s better.

But I’m also looking to resolve a black screen issue with my NVidia GTX 880M. This answer looks like it’s heading in the right direction for me.

I can log in to my laptop from another machine and see that gdm is running, but I don’t get anything on the laptop’s built-in display or the external monitor connected with DP. I also see almost nothing during boot, except for Fedora logo for two seconds on both screens, including the spinning animation.

dmesg doesn’t show any errors, the nvidia modules are loaded, so far so good.

The graphics card works fine in Windows, but I can see a weird screen that doesn’t exist. It has a 640x480 resolution and seems to be built-in to the graphics card. If I could disable this display in some way and make gdm use one of the real displays instead, I think I should be fine.

Any hints would be greatly appreciated.

I had quite an adventure getting this far.
Although this seems circumstantial, and may not work for everyone here, here is the fix that I did for my system.
This is a fix based on regenerating the X window config, and/or making it run the correct driver. The issue for me was caused by X falling back to nouveau graphics while they were blacklisted - this may not be the case for you.

Some of my system specs (as of writing this):
OS: Fedora Linux 36 (Xfce) x86_64
Kernel: 5.19.8-200.fc36.x86_64
CPU: Intel i9-9880H (16) @ 4.800GHz
GPU: NVIDIA GeForce GTX 1650 Mobile / Max-Q
DE: Xfce 4.16
WM: Xfwm4
I’m running on X, not Wayland.

Right after installing NVIDIA graphics and setting my system to use them, I had a black screen. The reason for me is because there was no default xorg config file generated for the system, so by default it’s trying to use Nouveau graphics anyways.

This might work with AMD graphics too, but I’m not totally certain.

NOTE: I am unsure if this is ideal for people running with Optimus graphics (like me). I still have to figure this out, but if I do get a good setup for Prime Render Offload, then I’ll edit this post. If you’re running a desktop then continue.

This may reset some of your display settings. This ended up reverting my screen resolution, but I was able to set it back.

  1. Check if you have an xorg.conf file already. If there is a file called /etc/X11/xorg.conf, then skip steps 1, 2 and 6, and instead edit that file.
  2. Boot into your system (either by chrooting in off a USB, SSHing, or using a TTY if you can access it).
  3. Generate the xorg config file with Xorg :1 -configure, which will generate a new config file called xorg.conf.new in /root.
  4. Make sure you have akmod-nvidia installed properly (or whatever other graphics card drivers you want to run Xorg with)!
  5. Edit the file with sudo nano xorg.conf.new (or your text editor of choice). Find the section with your graphics card by searching for “nouveau” in the file. (This is what it’ll probably say by default.)
  6. Replace “nouveau” with “nvidia”.
  7. Running sudo mv /root/xorg.conf.new /etc/X11/xorg.conf will apply the new X config to your system.
  8. Reboot the machine! reboot
  9. If you’re running XFCE like I am, you can run xfce4-settings-manager and go into the Display settings. Perhaps there is some way to change this with xrandr if you do not have a settings manager in your desktop environment.

I hope this helps!

I had a similar problem with nvidia (and cuda) drivers on my f36 desktop machine. I posted a solution that has worked for my at Bug report on nvidia driver 515.65.01 for fedora 36 (kernel 5.18.19, RTX 2060 Rev. 1) - #8 by aannoaanno - Linux - NVIDIA Developer Forums

I’ve run Gnome (Wayland and X11) and Plasma-Kde (Wayland and X11) successful on fc36 with nvidia drivers. (For Plasma on wayland, you have to delete /usr/lib/udev/rules.d/61-gdm.rules first.)