Black screen after trying to boot from live USB

This exact issue has already been here once, but I wasnt able to try the solution (not knowing if it would work). I am trying to install dual boot F38 on my surface laptop 4. Yesterday i actually did it, everything worked, but eventually i found out, that the speakers arent working in windows (in Linux they were fine) So after some trobleshooting i disabled bitlocker and decrypted my drive which resolved the issue, but another problem occured. When booting into Fedora, i would get black screen. So i thought something went wrong during the decryption so i decided to reinstall. Now when i insert the USB and get into GRUB, then after selecting first option to boot Fedora, my screen goes black. The same behaviour occurs when trying the second (test) and third (troubleshoot) options. I tried adding nomodeset, didnt help. I tried writing the iso file into usb from gnome disks (which was the old forum solution) but my download of iso file failed (so i could not test it yet) My boot order is empty (with just windows) and i have one empty partition on disk (which i created by just deleting volume which contained Ubuntu beforehand) I would appreciate any help, thanks.

Am i to understand that it gives you a black screen with initial boot from the live media?
and that also appears when using the troubleshooting mode with basic graphics?

Did you download the iso file from and also download fedora media writer from the same location for windows?
Did you do the checksum verification of the iso image after downloading it?

If you downloaded both those and verified the iso is intact then the media writer can be used to write that iso to the usb device from windows. One may also choose to use etcher or rufus for that task.

Once the iso is properly written onto the usb then one should be able to boot from it. The troubleshooting mode is for those cases where the GPU requires newer drivers than are on the install media and usually makes it possible to boot.

Having the drive decrypted seems a good thing and I would not anticipate that it should be an issue.

Yes, the black screen occures right after trying to boot from live USB. As I said, I already managed to install it successfully, I was even able to create an account and connect to wifi. Only after the problem with sound and decrypting the disk this started. The basic graphics mode doesnt work aswell. I downloaded lastest iso and writer from the fedproject. I didnt do checksum, but i tried booting fedora on different PC and it worked.